hal_0.5.7.bb : fix for dbus 1.0 API changes
authorGraeme Gregory <dp@xora.org.uk>
Thu, 9 Nov 2006 14:04:41 +0000 (14:04 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Thu, 9 Nov 2006 14:04:41 +0000 (14:04 +0000)
packages/hal/files/.mtn2git_empty [new file with mode: 0644]
packages/hal/files/dbus-fix-api.patch [new file with mode: 0644]
packages/hal/hal_0.5.7.bb

diff --git a/packages/hal/files/.mtn2git_empty b/packages/hal/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/hal/files/dbus-fix-api.patch b/packages/hal/files/dbus-fix-api.patch
new file mode 100644 (file)
index 0000000..1f02587
--- /dev/null
@@ -0,0 +1,26 @@
+Index: hal-0.5.7/tools/lshal.c
+===================================================================
+--- hal-0.5.7.orig/tools/lshal.c       2006-02-13 14:35:31.000000000 +0000
++++ hal-0.5.7/tools/lshal.c    2006-11-09 13:48:07.000000000 +0000
+@@ -701,7 +701,7 @@
+       libhal_ctx_shutdown (hal_ctx, &error);
+       libhal_ctx_free (hal_ctx);
+-      dbus_connection_disconnect (conn);
++      dbus_connection_close (conn);
+       dbus_connection_unref (conn);
+       if (show_device)
+Index: hal-0.5.7/tools/hal-device.c
+===================================================================
+--- hal-0.5.7.orig/tools/hal-device.c  2006-11-09 13:49:44.000000000 +0000
++++ hal-0.5.7/tools/hal-device.c       2006-11-09 13:50:00.000000000 +0000
+@@ -155,7 +155,7 @@
+       libhal_ctx_shutdown(hal_ctx, &error);
+       libhal_ctx_free(hal_ctx);
+-      dbus_connection_disconnect(conn);
++      dbus_connection_close(conn);
+       dbus_connection_unref(conn);
+       dbus_error_free(&error);
index 5476e2e..6139203 100644 (file)
@@ -8,7 +8,8 @@ HOMEPAGE = "http://freedesktop.org/Software/hal"
 LICENSE = "GPL LGPL AFL"
 PR = "r0"
 
-SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
+SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
+           file://dbus-fix-api.patch;patch=1"
 S = "${WORKDIR}/hal-${PV}"
 
 inherit autotools pkgconfig