apr: add versions from .oz354x
authorJustin Patrin <papercrane@gmail.com>
Fri, 17 Nov 2006 15:46:09 +0000 (15:46 +0000)
committerJustin Patrin <papercrane@gmail.com>
Fri, 17 Nov 2006 15:46:09 +0000 (15:46 +0000)
packages/apr/apr-util_1.1.2.bb [new file with mode: 0644]
packages/apr/apr_1.1.1.bb [new file with mode: 0644]

diff --git a/packages/apr/apr-util_1.1.2.bb b/packages/apr/apr-util_1.1.2.bb
new file mode 100644 (file)
index 0000000..ad89228
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r0"
+
+# apache mirrors?
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+  oe_runconf
+}
+
+do_stage() {
+  oe_libinstall -a -so -C .libs libaprutil-1 ${STAGING_LIBDIR}
+}
diff --git a/packages/apr/apr_1.1.1.bb b/packages/apr/apr_1.1.1.bb
new file mode 100644 (file)
index 0000000..6374949
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "Apache Portable Runtime (APR) library"
+SECTION = "libs"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r0"
+
+# apache mirrors?
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+  oe_runconf
+}
+
+do_stage() {
+  oe_libinstall -a -so -C .libs libapr-1 ${STAGING_LIBDIR}
+}