mtx-3a.conf, nylon-image-mini.bb: fixes to not conflict with the recent bitbake versions.
authorMartin Dietze <di@fh-wedel.de>
Fri, 27 Apr 2007 09:06:29 +0000 (09:06 +0000)
committerMartin Dietze <di@fh-wedel.de>
Fri, 27 Apr 2007 09:06:29 +0000 (09:06 +0000)
conf/machine/mtx-3a.conf
packages/images/nylon-image-mini.bb

index 6f963d1..000b200 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the mtx-3a 
 
 TARGET_ARCH = "arm"
-#PACKAGE_ARCHS = "all arm ${MACHINE}"
+PACKAGE_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-3a"
 EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 -n"  
 TARGET_CC_ARCH = "-march=armv5te"
index e6acd1f..c0ed998 100644 (file)
@@ -1,5 +1,8 @@
 export IMAGE_BASENAME = "nylon-mini"
 
+inherit image
+LICENSE = "MIT"
+
 NYLON_BASE = "base-files base-passwd busybox \
        dropbear \
        miniinit \
@@ -8,12 +11,9 @@ NYLON_BASE = "base-files base-passwd busybox \
        netbase \
        wireless-tools"
 
-RDEPENDS = "kernel \
+RDEPENDS += "kernel \
        ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
 
 export PACKAGE_INSTALL = "${RDEPENDS}"
 
 IMAGE_LINGUAS = ""
-
-inherit image
-LICENSE = "MIT"