Convert IPKG_ARCHS -> PACKAGE_ARCHS, IPKG_EXTRA_ARCHS -> PACKAGE_EXTRA_ARCHS in prepa...
authorRichard Purdie <rpurdie@rpsys.net>
Mon, 20 Nov 2006 11:04:45 +0000 (11:04 +0000)
committerRichard Purdie <rpurdie@rpsys.net>
Mon, 20 Nov 2006 11:04:45 +0000 (11:04 +0000)
64 files changed:
classes/multimachine.bbclass
classes/package_ipk.bbclass
classes/packaged-staging.bbclass
classes/rootfs_ipk.bbclass
conf/bitbake.conf
conf/distro/openmn.conf
conf/distro/unslung.conf
conf/documentation.conf
conf/machine/a780.conf
conf/machine/akita.conf
conf/machine/blueangel.conf
conf/machine/colinux.conf
conf/machine/compulab-pxa270.conf
conf/machine/db1200.conf
conf/machine/devkitidp-pxa255.conf
conf/machine/dht-walnut.conf
conf/machine/efika.conf
conf/machine/ep93xx.conf
conf/machine/epia.conf
conf/machine/guinness.conf
conf/machine/h1910.conf
conf/machine/h1940.conf
conf/machine/h2200.conf
conf/machine/h3600.conf
conf/machine/h3900.conf
conf/machine/h4000.conf
conf/machine/h5xxx.conf
conf/machine/h6300.conf
conf/machine/htcuniversal.conf
conf/machine/hx2000.conf
conf/machine/hx4700.conf
conf/machine/include/ixp4xx.conf
conf/machine/include/tune-iwmmxt.conf
conf/machine/include/zaurus-clamshell.conf
conf/machine/ipaq-pxa270.conf
conf/machine/ixp4xx.conf
conf/machine/lite5200.conf
conf/machine/logicpd-pxa270.conf
conf/machine/magician.conf
conf/machine/mainstone.conf
conf/machine/mtx-1.conf
conf/machine/mtx-2.conf
conf/machine/mtx-3.conf
conf/machine/mx31ads.conf
conf/machine/navman-icn330.conf
conf/machine/netbook-pro.conf
conf/machine/nokia770.conf
conf/machine/omap1510inn.conf
conf/machine/omap1610h2.conf
conf/machine/omap1710h3.conf
conf/machine/omap2420h4.conf
conf/machine/omap5912osk.conf
conf/machine/palmld.conf
conf/machine/poodle.conf
conf/machine/qemuarm.conf
conf/machine/rb500.conf
conf/machine/smdk2440.conf
conf/machine/spitz.conf
conf/machine/tosa.conf
conf/machine/triton.conf
conf/machine/wrap.conf
conf/machine/x86.conf
packages/meta/meta-sdk.bb
packages/meta/meta-toolchain.bb

index d63aeb6..4187a00 100644 (file)
@@ -17,7 +17,7 @@ def multi_machine_after_parse(d):
 
         # We could look for != PACKAGE_ARCH here but how to choose 
         # if multiple differences are present?
-        # Look through IPKG_ARCHS for the priority order?
+        # Look through PACKAGE_ARCHS for the priority order?
         if pkgarch and pkgarch == macharch:
             multiarch = macharch
 
index 47cff1d..02bac7d 100644 (file)
@@ -30,9 +30,9 @@ python package_ipk_install () {
        # Generate ipk.conf if it or the stamp doesnt exist
        conffile = os.path.join(stagingdir,"ipkg.conf")
        if not  os.access(conffile, os.R_OK):
-               ipkg_archs = bb.data.getVar('IPKG_ARCHS',d)
+               ipkg_archs = bb.data.getVar('PACKAGE_ARCHS',d)
                if ipkg_archs is None:
-                       bb.error("IPKG_ARCHS missing")
+                       bb.error("PACKAGE_ARCHS missing")
                        raise FuncFailed
                ipkg_archs = ipkg_archs.split()
                arch_priority = 1
index 9aba940..4b4ebb5 100644 (file)
@@ -113,7 +113,7 @@ do_stage_prepend() {
                rm ${DEPLOY_DIR_PSTAGE}/ipkg.conf
        fi
 
-       ipkgarchs="${BUILD_ARCH} all any noarch ${TARGET_ARCH} ${IPKG_ARCHS} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
+       ipkgarchs="${BUILD_ARCH} all any noarch ${TARGET_ARCH} ${PACKAGE_ARCHS} ${PACKAGE_EXTRA_ARCHS} ${MACHINE}"
        priority=1
        for arch in $ipkgarchs; do
                echo "arch $arch $priority" >> ${DEPLOY_DIR_PSTAGE}/ipkg.conf
index c4b2991..8020fd0 100644 (file)
@@ -42,7 +42,7 @@ real_do_rootfs () {
        fi
        mkdir -p ${T}
        echo "src oe file:${DEPLOY_DIR_IPK}" > ${T}/ipkg.conf
-       ipkgarchs="${IPKG_ARCHS}"
+       ipkgarchs="${PACKAGE_ARCHS}"
        priority=1
        for arch in $ipkgarchs; do
                echo "arch $arch $priority" >> ${T}/ipkg.conf
index 7da0a9a..b2d7e2b 100644 (file)
@@ -57,7 +57,7 @@ TARGET_CC_ARCH = ""
 
 PACKAGE_ARCH = "${HOST_ARCH}"
 MACHINE_ARCH = "${@[bb.data.getVar('HOST_ARCH', d, 1), bb.data.getVar('MACHINE', d, 1)][bool(bb.data.getVar('MACHINE', d, 1))]}"
-IPKG_ARCHS = "all any noarch ${TARGET_ARCH} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
+PACKAGE_ARCHS = "all any noarch ${TARGET_ARCH} ${PACKAGE_EXTRA_ARCHS} ${MACHINE}"
 
 ##################################################################
 # Date/time variables.
index 8118acb..9de6c7d 100644 (file)
@@ -12,7 +12,7 @@ TARGET_OS = "linux"
 
 INHERIT += "package_ipk"
 INHERIT += "debian"
-IPKG_EXTRA_ARCHS = "armv5te openmn"
+PACKAGE_EXTRA_ARCHS = "armv5te openmn"
 
 FEED_URIS  = "mnci54##http://www.mn-solutions.de/feed/mnci54/base"
 
index 541eaef..892c589 100644 (file)
@@ -26,7 +26,7 @@ THUMB_INTERWORK = "no"
 # to armeb - this makes this stuff independent of changes in machine/nslu2.conf
 TARGET_ARCH = "armeb"
 PACKAGE_ARCH = "${TARGET_ARCH}"
-# IPKG_EXTRA_ARCHS has the full list of supported architectures (from nslu2.conf)
+# PACKAGE_EXTRA_ARCHS has the full list of supported architectures (from nslu2.conf)
 
 # match the optimisation settings to that which has traditionally been used
 # in unslung
index 9996b27..62622ea 100644 (file)
@@ -38,8 +38,8 @@ PACKAGE_ARCH[doc] = 'The architecture needed for using a resulting package. If y
 machine dependant configuration options in your bitbake file add a \
 PACKAGE_ARCH  = "${MACHINE_ARCH}" to the file.'
 
-IPKG_ARCHS[doc] = 'A list of architectures compatible with the given target in order of priority'
-IPKG_EXTRA_ARCHS[doc] = 'Set this variable to add extra architectures to the list of supported architectures'
+PACKAGE_ARCHS[doc] = 'A list of architectures compatible with the given target in order of priority'
+PACKAGE_EXTRA_ARCHS[doc] = 'Set this variable to add extra architectures to the list of supported architectures'
 
 DATE[doc] = "The date the build was started Ymd"
 TIME[doc] = "The time the build was started HMS"
index 6b6e5a8..a62fafb 100644 (file)
@@ -5,7 +5,7 @@
 require conf/machine/include/motorola-ezx.conf
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 
index e14efa7..27695be 100644 (file)
@@ -5,7 +5,7 @@
 include conf/machine/include/zaurus-clamshell.conf
 include conf/machine/include/zaurus-2.6.conf
 
-IPKG_EXTRA_ARCHS += "iwmmxt" 
+PACKAGE_EXTRA_ARCHS += "iwmmxt" 
 IMAGE_FSTYPES ?= "jffs2"
 
 ROOT_FLASH_SIZE = "58"
index 979c002..dd079c2 100644 (file)
@@ -7,7 +7,7 @@ KERNEL ?= "kernel26"
 OVERRIDES =. "${KERNEL}:"
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel_kernel26 = "xanadux-ba-2.6"
 PREFERRED_PROVIDER_virtual/kernel = "xanadux-ba-2.6"
index 556944e..31e55e9 100644 (file)
@@ -3,6 +3,6 @@
 #@DESCRIPTION: Machine configuration for Cooperative Linux running on an x86 compatible PC
 
 TARGET_ARCH = "i686"
-IPKG_EXTRA_ARCHS = "i386 x86"
+PACKAGE_EXTRA_ARCHS = "i386 x86"
 PREFERRED_PROVIDER_virtual/kernel = "linux-colinux"
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel kernel-modules"
index 38bc900..b49bf48 100644 (file)
@@ -7,7 +7,7 @@ PREFERRED_VERSION_logicpd-pxa270 = "2.6.17"
 GUI_MACHINE_CLASS = "bigscreen"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
 
 include conf/machine/include/tune-xscale.conf
 
index d46636c..efa45f6 100644 (file)
@@ -1,7 +1,7 @@
 # Alchemy db1200
 
 TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "${TARGET_ARCH} ${MACHINE}"
+PACKAGE_ARCHS = "${TARGET_ARCH} ${MACHINE}"
 
 PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
 
index 6bc632d..7d19d02 100644 (file)
@@ -5,7 +5,7 @@
 TARGET_ARCH = "arm"
 
 GUI_MACHINE_CLASS = "bigscreen"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_virtual/bootloader = "uboot-${MACHINE}"
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
index 68b754f..eae1a34 100644 (file)
@@ -1,5 +1,5 @@
 TARGET_ARCH = "powerpc"
-IPKG_ARCHS = "all powerpc ${MACHINE}"
+PACKAGE_ARCHS = "all powerpc ${MACHINE}"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-dht-walnut"
 
index 2faf6eb..33fac1a 100644 (file)
@@ -4,7 +4,7 @@
 
 
 TARGET_ARCH = "powerpc"
-IPKG_EXTRA_ARCHS = "ppc"
+PACKAGE_EXTRA_ARCHS = "ppc"
 
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-${MACHINE}"
index 82905dd..67efb58 100644 (file)
@@ -4,7 +4,7 @@
 
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4t"
+PACKAGE_EXTRA_ARCHS = "armv4t"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
 
index e82da27..08f12a0 100644 (file)
@@ -7,7 +7,7 @@ udevdir = "/dev"
 OLDEST_KERNEL = "2.6.5"
 GLIBC_ADDONS = "nptl"
 GLIBC_EXTRA_OECONF = "--with-tls"
-IPKG_EXTRA_ARCHS = "i386"
+PACKAGE_EXTRA_ARCHS = "i386"
 
 include conf/machine/include/tune-c3.conf
 
index 4890f3c..bcbd6e8 100644 (file)
@@ -5,7 +5,7 @@
 # i386 doesn't work with NTPL, see http://ecos.sourceware.org/ml/libc-ports/2006-03/msg00030.html
 TARGET_ARCH = "i686"
 
-IPKG_EXTRA_ARCHS = "x86 i386 i486 i586"
+PACKAGE_EXTRA_ARCHS = "x86 i386 i486 i586"
 PREFERRED_PROVIDER_virtual/kernel = "linux-x86"
 
 # todo: convert to task-base
index a2c4a9c..c8b2fad 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 
 require conf/machine/include/tune-xscale.conf
 
index 1ea4a68..0810462 100644 (file)
@@ -2,7 +2,7 @@
 #@NAME: h1940
 #@DESCRIPTION: Machine configuration for the HP iPAQ h1930 and h1940
 
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
 TARGET_ARCH = "arm"
 PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-h1940"
index 8a6cee3..91c733b 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 
 #Compile with armv5te optimizations, incompatible with armv4(t) cpus
 require conf/machine/include/tune-xscale.conf
index 14a9bb6..104d518 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "ipaqsa"
+PACKAGE_EXTRA_ARCHS = "ipaqsa"
 
 require conf/machine/include/tune-strongarm.conf
 
index 6102458..f00dc9e 100644 (file)
@@ -10,7 +10,7 @@ INHERIT += "linux-kernel-base"
 OVERRIDES =. "${KERNEL}:"
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel_kernel24 = "handhelds-pxa"
 PREFERRED_PROVIDER_virtual/kernel_kernel26 = "linux-handhelds-2.6"
index f2ecbc5..4eef599 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 
 require conf/machine/include/tune-xscale.conf
 
index 941d08c..5aac579 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 
 require conf/machine/include/tune-xscale.conf
 
index 8cce5f6..f793b49 100644 (file)
@@ -7,7 +7,7 @@
 #
 TARGET_ARCH = "arm"
 PACKAGE_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "arm armv4 armv4t"
+PACKAGE_EXTRA_ARCHS = "arm armv4 armv4t"
 
 #Use OMAP 1510 cpu specifig arm9tdmi options for gcc
 require conf/machine/include/tune-arm9tdmi.conf
index 4366cb1..efb9251 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "ipaqpxa armv4t armv5te iwmmxt"
+PACKAGE_EXTRA_ARCHS = "ipaqpxa armv4t armv5te iwmmxt"
 
 # Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
 require conf/machine/include/tune-xscale.conf
index da2e466..25f093e 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the hx2000 iPAQs with a pxa27x CPU 
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-openzaurus"
 
index d43d16f..3a94220 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
 
 # Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
 require conf/machine/include/tune-xscale.conf
index 541d350..190ebe1 100644 (file)
@@ -111,7 +111,7 @@ TARGET_PACKAGE_ARCH = "${TARGET_PACKAGE_ARCH_BASE}${BYTE_SEX_CHAR}"
 #    because everything built here is no more specific than that.
 MACHINE_ARCH = "ixp4xx${ARCH_BYTE_SEX}"
 
-# IPKG_EXTRA_ARCHS
+# PACKAGE_EXTRA_ARCHS
 #    The full list of package architectures which should run on the system.
 #    This takes into account both the board level issues and the INPUTS set
 #    by the distro.  The arm list is derived from the architecture settings
@@ -126,12 +126,12 @@ THUMB_ARCHITECTURES = "thumbe${BYTE_SEX_CHAR} thumbv4t${BYTE_SEX_CHAR} thumbv5t$
 #    NOTE: this list contains just the things which rootfs_ipk.bbclass does
 #    not add, rootfs_ipk.bbclass evaluates:
 #
-#        ipkgarchs="all any noarch ${TARGET_ARCH} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
+#        ipkgarchs="all any noarch ${TARGET_ARCH} ${PACKAGE_EXTRA_ARCHS} ${MACHINE}"
 #
 #    This is a priority ordered list - most desireable architecture at the end,
 #    so put <ARM_INSTRUCTION_SET>_ARCHITECTURES at the end and, if
 #    THUMB_INTERWORK precede this with the other architectures.
-IPKG_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
+PACKAGE_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
                ${@(lambda arch_thumb, arch_arm, is_arm, interwork: \
                (interwork and (is_arm and arch_thumb or arch_arm) + ' ' or '') \
                + '${TARGET_ARCH} ' + (is_arm and arch_arm or arch_thumb)) \
@@ -146,7 +146,7 @@ IPKG_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
 #    the removal of the raw "${MACHINE}" from the end of the list.  ${MACHINE} and
 #    ixp4xx are included at the start (lower priority) as the non-byte-sex specific
 #    versions.
-IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${IPKG_EXTRA_ARCHS}"
+IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${PACKAGE_EXTRA_ARCHS}"
 
 #-------------------------------------------------------------------------------
 # Board defaults
index 990aee5..8376fac 100644 (file)
@@ -1,6 +1,6 @@
 # Configurations for the Intel PXA27x Appications Processor Family. 
 # Please use tune-xscale for PXA255/PXA26x based processors.
-IPKG_EXTRA_ARCHS += "iwmmxt"
 TARGET_CC_ARCH = "-march=iwmmxt -mcpu=iwmmxt -mtune=iwmmxt"
 PACKAGE_ARCH = "iwmmxt"
+PACKAGE_EXTRA_ARCHS += "iwmmxt"
 
index e600a49..3c02f7b 100644 (file)
@@ -1,5 +1,5 @@
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 
index b3db5c8..afc1318 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the iPAQ with a pxa27x CPU  devices
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa hx4700"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa hx4700"
 #use this for a hx47xx ipaq
 PREFERRED_PROVIDER_virtual/kernel = "linux-handhelds-2.6"
 
index c3e5606..dc174b8 100644 (file)
@@ -6,4 +6,4 @@ MACHINE_FEATURES = "kernel26 usbhost ext2"
 
 include conf/machine/include/ixp4xx.conf
 
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ixp4xx${ARCH_BYTE_SEX}"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ixp4xx${ARCH_BYTE_SEX}"
index cd943f7..3cbc444 100644 (file)
@@ -1,5 +1,5 @@
 TARGET_ARCH = "powerpc"
-IPKG_EXTRA_ARCHS = "ppc"
+PACKAGE_EXTRA_ARCHS = "ppc"
 UBOOT_MACHINE = "Lite5200"
 SERIAL_CONSOLE="38400 ttyS0"
 
index efb19ae..dc41e7c 100644 (file)
@@ -7,7 +7,7 @@ PREFERRED_VERSION_logicpd-pxa270 = "2.6.17-rc5"
 GUI_MACHINE_CLASS = "smallscreen"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
 
 include conf/machine/include/tune-xscale.conf
 
index d2cc9b1..e5138be 100644 (file)
@@ -6,7 +6,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
 
 # Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
 require conf/machine/include/tune-xscale.conf
index 72a305d..914022c 100644 (file)
@@ -5,7 +5,7 @@
 TARGET_ARCH = "arm"
 
 GUI_MACHINE_CLASS = "smallscreen"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
 
index 73500b5..33a69f4 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the mtx-1 (aka MeshCube)
 
 TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
+PACKAGE_ARCHS = "all mipsel ${MACHINE}"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-1"
 
index d3e15af..438c1fe 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the mtx-2 (aka SurfBox 2nd generation)
 
 TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
+PACKAGE_ARCHS = "all mipsel ${MACHINE}"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-2"
 
index bdd39ab..dd848ea 100644 (file)
@@ -9,7 +9,7 @@
 # For compiling the kernel, ARCH will be derived form it by kernel-arch.bbclass 
 TARGET_ARCH = "arm"
 
-IPKG_ARCHS = "all arm ${MACHINE}"
+PACKAGE_ARCHS = "all arm ${MACHINE}"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-3"
 
index 4b3fff7..33456a4 100644 (file)
@@ -8,7 +8,7 @@ TARGET_FPU_arm = "hard"
 MACHINE_FEATURES = "kernel26 apm alsa ext2 pcmcia usbhost usbgadget"
 
 GUI_MACHINE_CLASS = "smallscreen"
-IPKG_EXTRA_ARCHS = "arm armv4t armv5te armv6"
+PACKAGE_EXTRA_ARCHS = "arm armv4t armv5te armv6"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
 
index 79bafd1..c5fbdf2 100644 (file)
@@ -8,7 +8,7 @@
 # Hardware-based properties
 #
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
 
 #Compile with armv5te optimizations, incompatible with armv4(t) cpus
 require conf/machine/include/tune-xscale.conf
index 095cd95..1048cb1 100755 (executable)
@@ -5,7 +5,7 @@
 INHERIT += "linux-kernel-base"
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "arm armv4 armv4t armv5te"
+PACKAGE_EXTRA_ARCHS = "arm armv4 armv4t armv5te"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
 
index aa57bb4..6bde574 100644 (file)
@@ -2,7 +2,7 @@
 #@NAME: Nokia 770 internet tablet
 #@DESCRIPTION: Machine configuration for the Nokia 770, an omap 1710 based tablet
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te"
 
 PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-omap"
 PREFERRED_PROVIDER_virtual/bootloader = ""
index bd367d4..51d5b12 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index bd367d4..51d5b12 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index bd367d4..51d5b12 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index 5140692..70a3082 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te armv6te"
+PACKAGE_EXTRA_ARCHS = "armv5te armv6te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index c6bb209..f8a3472 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP Starter Kit with a 5912 processor
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
 
 HOTPLUG = "udev"
 
index 35a31aa..ef8f4ca 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the Palm LifeDrive
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "arm armv4t armv5te"
+PACKAGE_EXTRA_ARCHS = "arm armv4t armv5te"
 
 PREFERRED_PROVIDER_virtual/kernel = "hackndev-2.6trunk"
 
index fc8fb71..c904372 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the PXA250 based Sharp Zaurus SL-B500 and SHarp Zaurus SL-5600 devices
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
 
 MACHINE_KERNEL_VERSION ?= "2.4"
 include conf/machine/include/poodle-${MACHINE_KERNEL_VERSION}.conf
index c32353f..d67acac 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for running an ARM system under qemu emulation
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
 
 require conf/machine/include/qemu.conf
 require conf/machine/include/tune-arm926ejs.conf
index aec2a8f..ab669ae 100644 (file)
@@ -4,5 +4,5 @@
 
 TARGET_ARCH = "mipsel"
 TARGET_CC_ARCH = "-Os -mips2"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
+PACKAGE_ARCHS = "all mipsel ${MACHINE}"
 PREFERRED_PROVIDER_virtual/kernel = "linux-rb500"
index 04694cd..c054cf6 100644 (file)
@@ -4,7 +4,7 @@
 
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4t"
+PACKAGE_EXTRA_ARCHS = "armv4t"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-smdk2440"
 
index 5434efb..2c4e109 100644 (file)
@@ -7,7 +7,7 @@ include conf/machine/include/zaurus-2.6.conf
 
 PIVOTBOOT_EXTRA_RDEPENDS += "pivotinit ${PCMCIA_MANAGER}"
 
-IPKG_EXTRA_ARCHS += "iwmmxt"
+PACKAGE_EXTRA_ARCHS += "iwmmxt"
 IMAGE_FSTYPES ?= "tar.gz"
 
 ROOT_FLASH_SIZE = "100"
index e7f2aa2..1d7b04e 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the PXA255 based Sharp Zaurus SL-6000 device
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
 
 MACHINE_KERNEL_VERSION ?= "2.6"
 include conf/machine/include/tosa-${MACHINE_KERNEL_VERSION}.conf
index 671def3..685dcd9 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the XScale based triton boards from KaRo Electronics 
 
 TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
 PREFERRED_PROVIDER_virtual/kernel = "triton-kernel"
 
 BOOTSTRAP_EXTRA_RDEPENDS = "virtual/kernel"
index 1073259..592be8d 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the PC Engines WRAP (Wireless Router Application Platform) boards.
 
 TARGET_ARCH = "i486"
-IPKG_EXTRA_ARCHS = "i386"
+PACKAGE_EXTRA_ARCHS = "i386"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-wrap-geode"
 PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
index 0953f6d..b2147f2 100644 (file)
@@ -5,7 +5,7 @@
 # i386 doesn't work with NTPL, see http://ecos.sourceware.org/ml/libc-ports/2006-03/msg00030.html
 TARGET_ARCH = "i486"
 # TARGET_VENDOR = "-oe"
-IPKG_EXTRA_ARCHS = "x86"
+PACKAGE_EXTRA_ARCHS = "x86"
 PREFERRED_PROVIDER_virtual/kernel = "linux-x86"
 # todo: convert to task-base
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel pciutils udev kernel-modules"
index 0714e50..35ea863 100644 (file)
@@ -42,7 +42,7 @@ EOF
         cat <<EOF >${SDK_DIR}/ipkg-target.conf
 src oe file:${DEPLOY_DIR_IPK}
 EOF
-       ipkgarchs="${IPKG_ARCHS}"
+       ipkgarchs="${PACKAGE_ARCHS}"
         priority=1
         for arch in $ipkgarchs; do
                 echo "arch $arch $priority" >> ${SDK_DIR}/ipkg-target.conf
index 45ce852..f3a0332 100644 (file)
@@ -39,7 +39,7 @@ EOF
         cat <<EOF >${SDK_DIR}/ipkg-target.conf
 src oe file:${DEPLOY_DIR_IPK}
 EOF
-       ipkgarchs="${IPKG_ARCHS}"
+       ipkgarchs="${PACKAGE_ARCHS}"
         priority=1
         for arch in $ipkgarchs; do
                 echo "arch $arch $priority" >> ${SDK_DIR}/ipkg-target.conf