gcc(-cross): enable fortran for arm/EABI, thanks to Alain for showing and testing...
authorKoen Kooi <koen@openembedded.org>
Wed, 19 Sep 2007 09:46:23 +0000 (09:46 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 19 Sep 2007 09:46:23 +0000 (09:46 +0000)
packages/gcc/files/.mtn2git_empty [new file with mode: 0644]
packages/gcc/files/gfortran.patch [new file with mode: 0644]
packages/gcc/gcc-cross_4.1.2.bb
packages/gcc/gcc-cross_4.2.1.bb
packages/gcc/gcc_4.1.2.bb
packages/gcc/gcc_4.2.1.bb

diff --git a/packages/gcc/files/.mtn2git_empty b/packages/gcc/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gcc/files/gfortran.patch b/packages/gcc/files/gfortran.patch
new file mode 100644 (file)
index 0000000..96905e5
--- /dev/null
@@ -0,0 +1,40 @@
+The patch below fixes a crash building libgfortran on arm-linux-gnueabi.
+
+This target doesn't really have a 128-bit integer type, however it does use 
+TImode to represent the return value of certain special ABI defined library 
+functions. This results in type_for_size(TImode) being called.
+
+Because TImode deosn't correspond to any gfortran integer kind 
+gfc_type_for_size returns NULL and we segfault shortly after.
+
+The patch below fixes this by making gfc_type_for_size handle TImode in the 
+same way as the C frontend.
+
+Tested on x86_64-linux and arm-linux-gnueabi.
+Applied to trunk.
+
+Paul
+
+2007-05-15  Paul Brook  <paul@codesourcery.com>
+
+       gcc/fortran/
+       * trans-types.c (gfc_type_for_size): Handle signed TImode.
+
+Index: gcc-4.2.1/gcc/fortran/trans-types.c
+===================================================================
+--- gcc-4.2.1/gcc/fortran/trans-types.c        (revision 170435)
++++ gcc-4.2.1/gcc/fortran/trans-types.c        (working copy)
+@@ -1800,6 +1800,13 @@ gfc_type_for_size (unsigned bits, int un
+         if (type && bits == TYPE_PRECISION (type))
+           return type;
+       }
++
++      /* Handle TImode as a special case because it is used by some backends
++         (eg. ARM) even though it is not available for normal use.  */
++#if HOST_BITS_PER_WIDE_INT >= 64
++      if (bits == TYPE_PRECISION (intTI_type_node))
++      return intTI_type_node;
++#endif
+     }
+   else
+     {
index 003fd9e..34f083b 100644 (file)
@@ -5,7 +5,7 @@ inherit cross
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
 # NOTE: split PR.  If the main .oe changes something that affects its *build*
 # remember to increment this one too.
-PR = "r6"
+PR = "r7"
 
 DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
 PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
index a9e4a0d..9433c23 100644 (file)
@@ -5,7 +5,7 @@ inherit cross
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
 # NOTE: split PR.  If the main .oe changes something that affects its *build*
 # remember to increment this one too.
-PR = "r4"
+PR = "r5"
 
 DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
 PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
index 39980bf..9e05ae6 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
 DESCRIPTION = "The GNU cc and gcc C compilers."
 HOMEPAGE = "http://www.gnu.org/software/gcc/"
 SECTION = "devel"
@@ -30,19 +30,23 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
        file://unbreak-armv4t.patch;patch=1 \
         file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
        file://cache-amnesia.patch;patch=1 \
-       "
+       file://gfortran.patch;patch=1 \
+       "
 
 SRC_URI_append_sh3  = " file://sh3-installfix-fixheaders.patch;patch=1 "
 
 #Set the fortran bits
-# 'fortran' or '', not 'f77' like gcc3 had
+# ',fortran' or '', not 'f77' like gcc3 had
 FORTRAN = ""
+FORTRAN_linux-gnueabi = ",fortran"
 HAS_GFORTRAN = "no"
-HAS_G2C = "no"
+HAS_GFORTRAN_linux-gnueabi = "yes"
+HAS_G2C = "yes"
 
 #Set the java bits
-JAVA_arm = ""
 JAVA = ""
+JAVA_arm = ""
+
 
 LANGUAGES = "c,c++${FORTRAN}${JAVA}"
 require gcc3-build.inc
index 7c50167..a4ac7a9 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 DESCRIPTION = "The GNU cc and gcc C compilers."
 HOMEPAGE = "http://www.gnu.org/software/gcc/"
 SECTION = "devel"
@@ -55,19 +55,22 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
         file://arm-crunch-truncsi-disable.patch;patch=1 \
         file://arm-crunch-cfcvt64-disable.patch;patch=1 \
         file://arm-crunch-cirrus-bugfixes.patch;patch=1 \
-       "
+        file://gfortran.patch;patch=1 \        
+       "
 
 SRC_URI_append_sh3  = " file://sh3-installfix-fixheaders.patch;patch=1 "
 
 #Set the fortran bits
-# 'fortran' or '', not 'f77' like gcc3 had
+# 'i,fortran' or '', not 'f77' like gcc3 had
 FORTRAN = ""
+FORTRAN_linux-gnueabi = ",fortran"
 HAS_GFORTRAN = "no"
-HAS_G2C = "no"
+HAS_GFORTRAN_linux-gnueabi = "yes"
+HAS_G2C = "yes"
 
 #Set the java bits
-JAVA_arm = ""
 JAVA = ""
+JAVA_arm = ""
 
 LANGUAGES = "c,c++${FORTRAN}${JAVA}"
 require gcc3-build.inc