woodstox: New recipe.
authorRobert Schuster <thebohemian@gmx.net>
Tue, 4 Mar 2008 16:47:17 +0000 (16:47 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Tue, 4 Mar 2008 16:47:17 +0000 (16:47 +0000)
packages/woodstox/.mtn2git_empty [new file with mode: 0644]
packages/woodstox/woodstox2_2.0.6.bb [new file with mode: 0644]

diff --git a/packages/woodstox/.mtn2git_empty b/packages/woodstox/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/woodstox/woodstox2_2.0.6.bb b/packages/woodstox/woodstox2_2.0.6.bb
new file mode 100644 (file)
index 0000000..390c4ff
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION = "High-performance XML processor."
+LICENSE = "AL2.0 LGPL2.1"
+
+AUTHOR = "Codehaus"
+HOMEPAGE = "http://woodstox.codehaus.org"
+
+SRC_URI = "http://woodstox.codehaus.org/2.0.6/wstx-src.tar.gz"
+
+S = "${WORKDIR}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+  mkdir -p build/META-INF/services
+
+  javac -nowarn -sourcepath src/java -d build \
+               `find src/java/org -name "*.java"` \
+               `find src/java/com -name "*.java"`
+
+  cp -r src/resources/* build/META-INF/services
+
+  fastjar -C build -c -f ${JARFILENAME} .
+}