litephone: add new recipe
authorChristian Rüb <christian.rueb@gmx.net>
Sun, 24 Jan 2010 21:16:26 +0000 (21:16 +0000)
committerMartin Jansa <Martin.Jansa@gmail.com>
Tue, 2 Feb 2010 00:52:37 +0000 (01:52 +0100)
* Qt4 based phone application for FSO based phones

Signed-off-by: Christian Rüb <christian.rueb@gmx.net>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/litephone/files/litephone.desktop [new file with mode: 0644]
recipes/litephone/litephone.inc [new file with mode: 0644]
recipes/litephone/litephone_git.bb [new file with mode: 0644]

diff --git a/recipes/litephone/files/litephone.desktop b/recipes/litephone/files/litephone.desktop
new file mode 100644 (file)
index 0000000..f58bc58
--- /dev/null
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Litephone
+Comment=Ligthweight Qt telephony app
+Exec=litephone
+Icon=litephone-mobile
+Terminal=false
+Type=Application
+Categories=Applications;
+StartupNotify=true
diff --git a/recipes/litephone/litephone.inc b/recipes/litephone/litephone.inc
new file mode 100644 (file)
index 0000000..e2ca8ca
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "Ligthweight Qt telephony app"
+AUTHOR = "Michal Brzozowski"
+HOMEPAGE = "http://www.litephone.org"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+LICENSE = "GPL QPL"
+RRECOMMENDS = "fsodeviced fsogsmd fsousaged frameworkd"
+INC_PR = "r0"
+
+inherit qt4x11
+
+do_configure() {
+    ${OE_QMAKE_QMAKE} QMAKE_LRELEASE=lrelease4
+}
+
+do_compile() {
+    oe_runmake
+}
diff --git a/recipes/litephone/litephone_git.bb b/recipes/litephone/litephone_git.bb
new file mode 100644 (file)
index 0000000..e209a1c
--- /dev/null
@@ -0,0 +1,26 @@
+require litephone.inc
+
+SRCREV = "4c9f16d9acc6cd18fc3f647b7e4f44a2d3bdd7b6"
+PV = "0.1+gitr${SRCREV}"
+PR = "${INC_PR}.0"
+
+SRC_URI = "git://git.senfdax.de/git/litephone;protocol=http \
+           file://files/litephone.desktop"
+
+S = "${WORKDIR}/git/"
+
+do_install() {
+    install -d ${D}/${datadir}/pixmaps
+    install -m 644 ${S}/pics/blue/Mobile.png ${D}/${datadir}/pixmaps/litephone-mobile.png
+    install -d ${D}/${bindir}
+    install -m 0755 ${S}/litephone ${D}/${bindir}
+    install -d ${D}/etc/litephone
+    install ${S}/style_sheet.conf ${D}/etc/litephone/
+    install -d ${D}/${datadir}/litephone/translations
+    install ${S}/translations/*.qm ${D}/${datadir}/litephone/translations/
+    install -d ${D}/${datadir}/applications
+    install ${WORKDIR}/files/litephone.desktop ${D}/${datadir}/applications/
+}
+
+FILES_${PN}-locale-pl-pl += "/usr/share/litephone/translations/litephone_pl.qm"
+PACKAGES =+ "${PN}-locale-pl-pl"