update libdvdnav and libdvdread
authorghost <andreas.monzner@multimedia-labs.de>
Mon, 7 Jun 2010 12:33:53 +0000 (14:33 +0200)
committerghost <andreas.monzner@multimedia-labs.de>
Mon, 7 Jun 2010 16:54:22 +0000 (18:54 +0200)
recipes/libdvdnav/libdvdnav_git.bb [new file with mode: 0644]
recipes/libdvdread/libdvdread_git.bb [new file with mode: 0644]

diff --git a/recipes/libdvdnav/libdvdnav_git.bb b/recipes/libdvdnav/libdvdnav_git.bb
new file mode 100644 (file)
index 0000000..d8aa652
--- /dev/null
@@ -0,0 +1,33 @@
+# libdvdnav.bb build file
+HOMEPAGE="http://git.debian-maintainers.org/"
+DESCRIPTION="DVD navigation multimeda library"
+LICENSE = "GPL"
+DEPENDS = "libdvdread"
+RDEPENDS = "libdvdread"
+
+PV = "4.1.3+git"
+PR = "r7"
+
+#debian/4.1.3-7
+SRCREV="850e513d4fea29b40879378b13003cd677e5214b"
+
+EXTRA_OECONF = "--with-dvdread-prefix=${STAGING_LIBDIR}/.."
+
+SRC_URI = "git://git.debian-maintainers.org/git/daniel/libdvdnav.git;protocol=git;branch=debian"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+do_munge() {
+       for i in `ls debian/patches | grep ".patch" | sort -n`; do
+               oenote "Applying debian patch '$i'";
+               patch -p1 < debian/patches/$i;
+       done;
+}
+
+addtask munge before do_compile after do_patch
+
+do_stage() {
+       autotools_stage_all
+}
diff --git a/recipes/libdvdread/libdvdread_git.bb b/recipes/libdvdread/libdvdread_git.bb
new file mode 100644 (file)
index 0000000..0aa878a
--- /dev/null
@@ -0,0 +1,38 @@
+# libdvdread.bb build file
+HOMEPAGE="http://git.debian-maintainers.org"
+DESCRIPTION="DVD read multimeda library"
+LICENSE = "GPL"
+
+PV = "4.1.3+git"
+PR = "r9"
+# tag debian/4.1.3-9
+SRCREV = "8d2745c6e61cbcf70112d5bb0d15685090e20af1"
+
+SRC_URI = "git://git.debian-maintainers.org/git/daniel/libdvdread.git;protocol=git;branch=debian;tag=${SRCREV}"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OEMAKE = "DESTDIR=${D}"
+
+do_munge() {
+       for i in `ls debian/patches | grep ".patch" | sort -n`; do
+               oenote "Applying debian patch '$i'";
+               patch -p1 < debian/patches/$i;
+       done;
+}
+
+addtask munge before do_compile after do_patch
+
+do_install() {
+       oe_runmake install
+}
+
+do_stage() {
+       autotools_stage_all
+       cat ${S}/misc/dvdread-config | sed -e "s,-I/usr/include,-I${STAGING_INCDIR}," \
+                                    | sed -e "s,-L/usr/lib,-L${STAGING_LIBDIR}," \
+               > ${STAGING_BINDIR_CROSS}/dvdread-config
+       chmod a+rx ${STAGING_BINDIR_CROSS}/dvdread-config
+}
+