twisted-web2: work around sometimes-not-appearing connectionLost
authorFelix Domke <tmbinc@elitedvb.net>
Mon, 26 Jan 2009 00:29:32 +0000 (01:29 +0100)
committerFelix Domke <tmbinc@elitedvb.net>
Mon, 26 Jan 2009 00:29:32 +0000 (01:29 +0100)
packages/twisted/twisted-web2/fix-connectionlost.patch [new file with mode: 0644]
packages/twisted/twisted-web2_8.1.0.bb

diff --git a/packages/twisted/twisted-web2/fix-connectionlost.patch b/packages/twisted/twisted-web2/fix-connectionlost.patch
new file mode 100644 (file)
index 0000000..fadf734
--- /dev/null
@@ -0,0 +1,12 @@
+--- TwistedWeb2-8.1.0/twisted/web2/channel/http.py     2007-01-02 00:41:33.000000000 +0100
++++ TwistedWeb2-8.1.0/twisted/web2/channel/http.py     2009-01-24 07:21:29.000000000 +0100
+@@ -845,6 +845,9 @@
+         # probably a client abort, so lose the connection.
+         if self.chanRequest:
+             self.transport.loseConnection()
++
++        # Workaround for enigma2's webinterface.
++        self.transport.loseConnection()
+         
+     def connectionLost(self, reason):
+         self.factory.outstandingRequests-=1
index f84923c..6230ef2 100644 (file)
@@ -10,7 +10,8 @@ LICENSE = "LGPL"
 DEPENDS = "twisted twisted-native"
 RDEPENDS = "twisted python-netserver"
 
-SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Web2/8.1/TwistedWeb2-${PV}.tar.bz2"
+SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Web2/8.1/TwistedWeb2-${PV}.tar.bz2\
+       file://fix-connectionlost.patch;patch=1;pnum=1"
 S = "${WORKDIR}/TwistedWeb2-${PV}"
 
 inherit distutils