ezxd: add svn version, replaces opentapi
authorAntonio Ospite <ospite@studenti.unina.it>
Fri, 7 Sep 2007 08:16:24 +0000 (08:16 +0000)
committerKoen Kooi <koen@openembedded.org>
Fri, 7 Sep 2007 08:16:24 +0000 (08:16 +0000)
packages/ezx/ezxd/.mtn2git_empty [new file with mode: 0644]
packages/ezx/ezxd/ezxd.init [new file with mode: 0644]
packages/ezx/ezxd_svn.bb [new file with mode: 0644]

diff --git a/packages/ezx/ezxd/.mtn2git_empty b/packages/ezx/ezxd/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/ezx/ezxd/ezxd.init b/packages/ezx/ezxd/ezxd.init
new file mode 100644 (file)
index 0000000..dccd293
--- /dev/null
@@ -0,0 +1,84 @@
+#! /bin/sh
+# -*- coding: utf-8 -*-
+# init.d script for ezxd
+
+set -e
+
+DAEMON=/usr/bin/ezxd
+NAME=ezxd
+PIDDIR=/var/run/ezxd
+PIDFILE=$PIDDIR/pid
+DESC="ezxd server"
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/ezxd ]; then
+  . /etc/default/ezxd
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+  if [ ! -d $PIDDIR ]; then
+    mkdir -p $PIDDIR
+  fi
+  if [ -e $PIDFILE ]; then
+    PIDDIR=/proc/$(cat $PIDFILE)
+    if [ -d ${PIDDIR} -a  "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then 
+      echo "$DESC already started; not starting."
+    else
+      echo "Removing stale PID file $PIDFILE."
+      rm -f $PIDFILE
+    fi
+  fi
+
+  echo -n "Starting $DESC: "
+  start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
+    --exec $DAEMON -- --system $PARAMS
+  # We need to sleep here because opening the mux devices takes some time
+  sleep 15
+  echo "$NAME."
+  if [ -d $EVENTDIR ]; then
+      run-parts --arg=start $EVENTDIR
+  fi
+}
+
+shut_it_down()
+{
+  if [ -d $EVENTDIR ]; then
+      run-parts --reverse --arg=stop $EVENTDIR
+  fi
+  echo -n "Stopping $DESC: "
+  start-stop-daemon --stop  --quiet --pidfile $PIDFILE 
+   
+  # We no longer include these arguments so that start-stop-daemon
+  # can do its job even given that we may have been upgraded.
+  # We rely on the pidfile being sanely managed
+  # --exec $DAEMON -- --system $PARAMS
+  echo "$NAME."
+  rm -f $PIDFILE
+}
+
+case "$1" in
+  start)
+    start_it_up
+  ;;
+  stop)
+    shut_it_down
+  ;;
+  restart|force-reload)
+    shut_it_down
+    sleep 1
+    start_it_up
+  ;;
+  *)
+    echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+    exit 1
+  ;;
+esac
+
+exit 0
diff --git a/packages/ezx/ezxd_svn.bb b/packages/ezx/ezxd_svn.bb
new file mode 100644 (file)
index 0000000..3a05217
--- /dev/null
@@ -0,0 +1,34 @@
+DESCRIPTION = "Open implementation of motorola's tapisrv, replaces opentapi"
+LICENSE = "GPLv2"
+SECTION = "devel"
+AUTHOR = "Daniel Ribeiro"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=ezxd;proto=http \
+           file://ezxd.init \
+          "
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ezxd"
+INITSCRIPT_PARAMS = "start 00 S ."
+
+RREPLACES = "opentapi"
+
+
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+       install -d ${D}${bindir}
+       install -m 755 ezxd ${D}${bindir}
+
+       install -d ${D}${libdir}/ezxd
+       install -m 755 *.so ${D}${libdir}/ezxd
+        
+       install -d ${D}${sysconfdir}/init.d
+        install -m 0600 ezxd.conf ${D}${sysconfdir}/
+        install -m 0755 ${WORKDIR}/ezxd.init ${D}${sysconfdir}/init.d/ezxd
+}
+