Patches to get glibc 2.3.2 and 2.3.3 compile for nylon * disable check of gcc version...
authorMartin Dietze <martin@the-little-red-haired-girl.org>
Sat, 23 May 2009 11:14:20 +0000 (13:14 +0200)
committermd <md@freiheit.com>
Wed, 27 May 2009 19:50:56 +0000 (21:50 +0200)
recipes/glibc/glibc-2.3.2/allow-gcc.patch [new file with mode: 0644]
recipes/glibc/glibc-2.3.2/mips-abio32.patch [new file with mode: 0644]
recipes/glibc/glibc-2.3.3/allow-gcc.patch [new file with mode: 0644]
recipes/glibc/glibc-2.3.3/etc/ld.so.conf [new file with mode: 0644]
recipes/glibc/glibc-2.3.3/mips-abio32.patch [new file with mode: 0644]
recipes/glibc/glibc_2.3.2.bb
recipes/glibc/glibc_2.3.3.bb

diff --git a/recipes/glibc/glibc-2.3.2/allow-gcc.patch b/recipes/glibc/glibc-2.3.2/allow-gcc.patch
new file mode 100644 (file)
index 0000000..1e38f0e
--- /dev/null
@@ -0,0 +1,70 @@
+--- glibc-2.3.2/configure-orig 2009-03-26 15:46:33.000000000 +0100
++++ glibc-2.3.2/configure      2009-03-26 15:49:15.000000000 +0100
+@@ -3850,67 +3850,6 @@
+ # These programs are version sensitive.
+-for ac_prog in ${ac_tool_prefix}gcc ${ac_tool_prefix}cc
+-do
+-  # Extract the first word of "$ac_prog", so it can be a program name with args.
+-set dummy $ac_prog; ac_word=$2
+-echo "$as_me:$LINENO: checking for $ac_word" >&5
+-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+-if test "${ac_cv_prog_CC+set}" = set; then
+-  echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-  if test -n "$CC"; then
+-  ac_cv_prog_CC="$CC" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+-  IFS=$as_save_IFS
+-  test -z "$as_dir" && as_dir=.
+-  for ac_exec_ext in '' $ac_executable_extensions; do
+-  if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+-    ac_cv_prog_CC="$ac_prog"
+-    echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+-    break 2
+-  fi
+-done
+-done
+-
+-fi
+-fi
+-CC=$ac_cv_prog_CC
+-if test -n "$CC"; then
+-  echo "$as_me:$LINENO: result: $CC" >&5
+-echo "${ECHO_T}$CC" >&6
+-else
+-  echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-fi
+-
+-  test -n "$CC" && break
+-done
+-
+-if test -z "$CC"; then
+-  ac_verc_fail=yes
+-else
+-  # Found it, now check the version.
+-  echo "$as_me:$LINENO: checking version of $CC" >&5
+-echo $ECHO_N "checking version of $CC... $ECHO_C" >&6
+-  ac_prog_version=`$CC -v 2>&1 | sed -n 's/^.*version \([egcygnustpi-]*[0-9.]*\).*$/\1/p'`
+-  case $ac_prog_version in
+-    '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+-    3.[2-9]*)
+-       ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+-    *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+-
+-  esac
+-  echo "$as_me:$LINENO: result: $ac_prog_version" >&5
+-echo "${ECHO_T}$ac_prog_version" >&6
+-fi
+-if test $ac_verc_fail = yes; then
+-  critic_missing="$critic_missing gcc"
+-fi
+-
+ for ac_prog in gnumake gmake make
+ do
+   # Extract the first word of "$ac_prog", so it can be a program name with args.
diff --git a/recipes/glibc/glibc-2.3.2/mips-abio32.patch b/recipes/glibc/glibc-2.3.2/mips-abio32.patch
new file mode 100644 (file)
index 0000000..49c46f9
--- /dev/null
@@ -0,0 +1,12 @@
+--- glibc-2.3.3-r16/sysdeps/mips/sgidefs.h-orig        2009-02-27 16:05:55.000000000 +0100
++++ glibc-2.3.3-r16/sysdeps/mips/sgidefs.h     2009-02-27 16:06:26.000000000 +0100
+@@ -43,4 +43,9 @@
+ #define _MIPS_SIM_NABI32      2
+ #define _MIPS_SIM_ABI64               3
++/* compatibility stuff needed e.g. by gdb */
++#ifndef _ABIO32
++# define _ABIO32      _MIPS_SIM_ABI32
++#endif
++
+ #endif /* sgidefs.h */
diff --git a/recipes/glibc/glibc-2.3.3/allow-gcc.patch b/recipes/glibc/glibc-2.3.3/allow-gcc.patch
new file mode 100644 (file)
index 0000000..1e38f0e
--- /dev/null
@@ -0,0 +1,70 @@
+--- glibc-2.3.2/configure-orig 2009-03-26 15:46:33.000000000 +0100
++++ glibc-2.3.2/configure      2009-03-26 15:49:15.000000000 +0100
+@@ -3850,67 +3850,6 @@
+ # These programs are version sensitive.
+-for ac_prog in ${ac_tool_prefix}gcc ${ac_tool_prefix}cc
+-do
+-  # Extract the first word of "$ac_prog", so it can be a program name with args.
+-set dummy $ac_prog; ac_word=$2
+-echo "$as_me:$LINENO: checking for $ac_word" >&5
+-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+-if test "${ac_cv_prog_CC+set}" = set; then
+-  echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-  if test -n "$CC"; then
+-  ac_cv_prog_CC="$CC" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+-  IFS=$as_save_IFS
+-  test -z "$as_dir" && as_dir=.
+-  for ac_exec_ext in '' $ac_executable_extensions; do
+-  if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+-    ac_cv_prog_CC="$ac_prog"
+-    echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+-    break 2
+-  fi
+-done
+-done
+-
+-fi
+-fi
+-CC=$ac_cv_prog_CC
+-if test -n "$CC"; then
+-  echo "$as_me:$LINENO: result: $CC" >&5
+-echo "${ECHO_T}$CC" >&6
+-else
+-  echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-fi
+-
+-  test -n "$CC" && break
+-done
+-
+-if test -z "$CC"; then
+-  ac_verc_fail=yes
+-else
+-  # Found it, now check the version.
+-  echo "$as_me:$LINENO: checking version of $CC" >&5
+-echo $ECHO_N "checking version of $CC... $ECHO_C" >&6
+-  ac_prog_version=`$CC -v 2>&1 | sed -n 's/^.*version \([egcygnustpi-]*[0-9.]*\).*$/\1/p'`
+-  case $ac_prog_version in
+-    '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+-    3.[2-9]*)
+-       ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+-    *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+-
+-  esac
+-  echo "$as_me:$LINENO: result: $ac_prog_version" >&5
+-echo "${ECHO_T}$ac_prog_version" >&6
+-fi
+-if test $ac_verc_fail = yes; then
+-  critic_missing="$critic_missing gcc"
+-fi
+-
+ for ac_prog in gnumake gmake make
+ do
+   # Extract the first word of "$ac_prog", so it can be a program name with args.
diff --git a/recipes/glibc/glibc-2.3.3/etc/ld.so.conf b/recipes/glibc/glibc-2.3.3/etc/ld.so.conf
new file mode 100644 (file)
index 0000000..dfa65ed
--- /dev/null
@@ -0,0 +1,2 @@
+/usr/local/lib
+/usr/X11R6/lib
diff --git a/recipes/glibc/glibc-2.3.3/mips-abio32.patch b/recipes/glibc/glibc-2.3.3/mips-abio32.patch
new file mode 100644 (file)
index 0000000..49c46f9
--- /dev/null
@@ -0,0 +1,12 @@
+--- glibc-2.3.3-r16/sysdeps/mips/sgidefs.h-orig        2009-02-27 16:05:55.000000000 +0100
++++ glibc-2.3.3-r16/sysdeps/mips/sgidefs.h     2009-02-27 16:06:26.000000000 +0100
+@@ -43,4 +43,9 @@
+ #define _MIPS_SIM_NABI32      2
+ #define _MIPS_SIM_ABI64               3
++/* compatibility stuff needed e.g. by gdb */
++#ifndef _ABIO32
++# define _ABIO32      _MIPS_SIM_ABI32
++#endif
++
+ #endif /* sgidefs.h */
index 2d2663f..0ed7d3e 100644 (file)
@@ -104,6 +104,11 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/glibc/glibc-${PV}.tar.gz \
           file://etc/ld.so.conf \
           file://generate-supported.mk"
 
+SRC_URI_append_mtx-1 = " file://mips-abio32.patch;patch=1 \
+                         file://allow-gcc.patch;patch=1 "
+SRC_URI_append_mtx-2 = " file://mips-abio32.patch;patch=1 \
+                         file://allow-gcc.patch;patch=1 "
+
 S = "${WORKDIR}/glibc-${PV}"
 B = "${WORKDIR}/build-${TARGET_SYS}"
 
index 05a8581..dada4bb 100644 (file)
@@ -49,6 +49,11 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/glibc/glibc-${PV}.tar.gz \
           file://etc/ld.so.conf \
           file://generate-supported.mk"
 
+SRC_URI_append_mtx-1 = " file://mips-abio32.patch;patch=1 \
+                         file://allow-gcc.patch;patch=1 "
+SRC_URI_append_mtx-2 = " file://mips-abio32.patch;patch=1 \
+                         file://allow-gcc.patch;patch=1 "
+
 S = "${WORKDIR}/glibc-${PV}"
 B = "${WORKDIR}/build-${TARGET_SYS}"