hal: if necessary, create $CACHEDIR before starting the daemon. Closes: #3740.
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Wed, 27 Jan 2010 23:24:52 +0000 (00:24 +0100)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Wed, 27 Jan 2010 23:38:51 +0000 (00:38 +0100)
recipes/hal/files/20hal
recipes/hal/hal_0.5.14+git.bb
recipes/hal/hal_0.5.9.1.bb
recipes/hal/hal_git.bb

index 926bd89..e98cc8a 100644 (file)
@@ -11,6 +11,7 @@
 
 PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
 DAEMON=/usr/sbin/hald
+CACHEDIR=/var/cache/hald
 PIDDIR=/var/run/hald
 PIDFILE=$PIDDIR/pid
 NAME=hald
@@ -26,6 +27,10 @@ do_start() {
     mkdir -p $PIDDIR
     chown $DAEMONUSER:$DAEMONUSER $PIDDIR
   fi
+  if [ ! -d $CACHEDIR ]; then
+    mkdir -p $CACHEDIR
+    chown $DAEMONUSER:$DAEMONUSER $CACHEDIR
+  fi
        echo "Starting $DESC" "$NAME"
        start-stop-daemon --start --pidfile $PIDFILE \
                --exec $DAEMON -- $DAEMON_OPTS
index 6a842cf..1e1f10e 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
 SRCREV = "6dccf8e3ad181e8f56b1d2a994ec50a1953a1c2d"
 
 PV = "0.5.14"
-PR = "r1"
+PR = "r2"
 PR_append = "+gitr${SRCREV}"
 
 S = "${WORKDIR}/git"
index b666446..a8ea38b 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPL LGPL AFL"
 DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat virtual/libusb0"
 RDEPENDS_${PN} += "udev-utils hal-info"
 
-PR = "r9"
+PR = "r10"
 
 SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
            file://configure_fix.patch;patch=1 \
index 8bd8285..58f534d 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
         file://99_hal"
 
 PV = "0.5.9.1+git${SRCDATE}"
-PR = "r7"
+PR = "r8"
 
 S = "${WORKDIR}/git"