merge of 4a7910f6f324ae55c1f42b4a22cbea6651e48ced
authorOyvind Repvik <nail@nslu2-linux.org>
Sun, 12 Feb 2006 06:14:45 +0000 (06:14 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sun, 12 Feb 2006 06:14:45 +0000 (06:14 +0000)
     and 8ea0fe4b0de92b762636231b067ef6a7f6137d01

conf/distro/ludeos.conf
packages/ixp4xx/ixp-osal-2.1/ixp4xx-header.patch
packages/ixp4xx/ixp-osal_2.1.bb

index fad8d4e..5ebe98b 100644 (file)
@@ -19,4 +19,18 @@ FEED_URIS_append += "native##http://ipkg.nslu2-linux.org/feeds/slugos-lag/native
 # This removes the dependency on upslug2-native.
 SLUGOS_NATIVE_DEPENDS = ""
 
+SLUGOS_EXTRA_RDEPENDS = "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck \
+kernel-module-ext2 \
+kernel-module-jbd \
+kernel-module-ext3 \
+kernel-module-nfs \
+kernel-module-vfat \
+kernel-module-ntfs \
+kernel-module-isofs \
+kernel-module-udf \
+kernel-module-reiserfs \
+kernel-module-nls-cp437 \
+kernel-module-nls-utf8 \
+"
+
 include conf/distro/slugos.conf
index 70eec5e..a9d87d4 100644 (file)
       "qMgr"                   /* name            */
 --- ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Base.h     1970-01-01 00:00:00.000000000 +0000
 +++ ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Base.h     1970-01-01 00:00:00.000000000 +0000
-@@ -0,0 +1,72 @@
+@@ -0,0 +1,80 @@
 +/*
 + * Glue for the current linux definitons of this stuff.
 + */
 +#ifndef IxOsalOsIxp425Base_H
 +#define IxOsalOsIxp425Base_H 1
 +#include <asm-arm/arch-ixp4xx/ixp4xx-regs.h>
++#include <linux/version.h>
 +
 +/* Force Address Coherent (the default) mapping on LE - Linux 2.6
 + * does not have a way of changing it.
 +#define IXP425_PCI_CFG_BASE_PHYS      IXP4XX_PCI_CFG_BASE_PHYS
 +
 +//#define IXP425_EXP_BUS_BASE1_PHYS
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,16)
 +#define IXP425_EXP_BUS_BASE2_PHYS     IXP4XX_EXP_BUS_CS2_BASE_PHYS
++#else
++/* The following definition should be IXP4XX_EXP_BUS_BASE(2), but that is not
++   static and causes compilation problems later.  So we need to hard-code it.
++   Note that this hard-coded value is only correct for IXP42X. */
++#define IXP425_EXP_BUS_BASE2_PHYS     (IXP4XX_EXP_BUS_BASE_PHYS + (2 * SZ_16M))
++#endif
 +//#define IXP425_EXP_BUS_CS0_BASE_PHYS
 +//#define IXP425_EXP_BUS_CS1_BASE_PHYS
 +//#define IXP425_EXP_BUS_CS4_BASE_PHYS
index 48d4355..7a27e28 100644 (file)
@@ -31,7 +31,7 @@ SRC_URI += "file://le.patch;patch=1"
 SRC_URI += "file://assert.patch;patch=1"
 
 S = "${WORKDIR}/ixp_osal"
-PR = "r3"
+PR = "r4"
 
 COMPATIBLE_HOST = "^arm.*-linux.*"