busybox: use short options for hwclock - closes #4978
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 9 Jan 2009 19:12:41 +0000 (20:12 +0100)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Wed, 21 Jan 2009 11:04:03 +0000 (12:04 +0100)
  Both busybox as well as big version support the same short options
  but the busybox version may be build with getopt_long turned off.

packages/busybox/busybox_1.11.3.bb
packages/busybox/busybox_1.13.2.bb
packages/busybox/busybox_1.2.1.bb
packages/busybox/busybox_1.2.2.bb
packages/busybox/busybox_1.3.1.bb
packages/busybox/busybox_1.7.2.bb
packages/busybox/busybox_1.9.2.bb
packages/busybox/files/hwclock.sh

index 16b23c8..ed74336 100644 (file)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "r8"
+PR = "r9"
 
 SRC_URI = "\
   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
index 1687f1b..ccaae8d 100644 (file)
@@ -1,6 +1,6 @@
 require busybox.inc
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "\
   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
index 346506c..63a93df 100644 (file)
@@ -1,6 +1,6 @@
 require busybox.inc
 
-PR = "r18"
+PR = "r19"
 
 SRC_URI += "file://wget-long-options.patch;patch=1 \
           file://df_rootfs.patch;patch=1 \
index 2508021..fe9d07e 100644 (file)
@@ -1,6 +1,6 @@
 require busybox.inc
 
-PR = "r4"
+PR = "r5"
 
 DEFAULT_PREFERENCE = "-1"
 
index 4742c87..2cdb81b 100644 (file)
@@ -1,6 +1,6 @@
 require busybox.inc
 
-PR = "r4"
+PR = "r5"
 
 DEFAULT_PREFERENCE = "-1"
 
index 4d93394..e98e25e 100644 (file)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "r10"
+PR = "r11"
 
 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
            file://busybox-cron \
index 3db3604..77dd2a9 100644 (file)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
            file://udhcpscript.patch;patch=1 \
index aab5c05..6c0af34 100644 (file)
@@ -28,9 +28,9 @@ case "$1" in
                then
                        if [ -z "$TZ" ]
                        then
-                          hwclock --hctosys $UTC
+                          hwclock -s $UTC;# --hctosys
                        else
-                          TZ="$TZ" hwclock --hctosys $UTC
+                          TZ="$TZ" hwclock -s $UTC;# --hctosys
                        fi
                fi
 
@@ -53,7 +53,7 @@ case "$1" in
                fi
                if [ "$HWCLOCKACCESS" != no ]
                then
-                       hwclock --systohc $UTC
+                       hwclock -w $UTC;# --systohc
                fi
                if [ "$VERBOSE" != no ]
                then
@@ -64,7 +64,7 @@ case "$1" in
        show)
                if [ "$HWCLOCKACCESS" != no ]
                then
-                       hwclock --show $UTC
+                       hwclock -r $UTC;# --show
                fi
                ;;
         *)