fuse: update to 2.6.0
authorKoen Kooi <koen@openembedded.org>
Tue, 14 Nov 2006 09:53:07 +0000 (09:53 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 14 Nov 2006 09:53:07 +0000 (09:53 +0000)
packages/fuse/files/.mtn2git_empty [new file with mode: 0644]
packages/fuse/files/not-run-updaterc.d-on-host.patch [new file with mode: 0644]
packages/fuse/fuse_2.6.0.bb [new file with mode: 0644]

diff --git a/packages/fuse/files/.mtn2git_empty b/packages/fuse/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/fuse/files/not-run-updaterc.d-on-host.patch b/packages/fuse/files/not-run-updaterc.d-on-host.patch
new file mode 100644 (file)
index 0000000..365d719
--- /dev/null
@@ -0,0 +1,21 @@
+--- /tmp/Makefile.am   2006-11-14 10:33:58.000000000 +0100
++++ fuse-2.6.0/util/Makefile.am        2006-11-14 10:34:39.308554000 +0100
+@@ -29,10 +29,6 @@
+       $(INSTALL_PROGRAM) $(srcdir)/mount.fuse $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
+       $(mkdir_p) $(DESTDIR)$(INIT_D_PATH)
+       $(INSTALL_PROGRAM) $(srcdir)/init_script $(DESTDIR)$(INIT_D_PATH)/fuse
+-      @if test -x /usr/sbin/update-rc.d; then \
+-              echo "/usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 ."; \
+-              /usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 .; \
+-      fi
+ install-data-local:
+       $(mkdir_p) $(DESTDIR)$(UDEV_RULES_PATH)
+@@ -42,7 +38,3 @@
+       rm -f $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
+       rm -f $(DESTDIR)$(UDEV_RULES_PATH)/99-fuse.rules
+       rm -f $(DESTDIR)$(INIT_D_PATH)/fuse
+-      @if test -x /usr/sbin/update-rc.d; then \
+-              echo "/usr/sbin/update-rc.d fuse remove"; \
+-              /usr/sbin/update-rc.d fuse remove; \
+-      fi
diff --git a/packages/fuse/fuse_2.6.0.bb b/packages/fuse/fuse_2.6.0.bb
new file mode 100644 (file)
index 0000000..74dd994
--- /dev/null
@@ -0,0 +1,32 @@
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+HOMEPAGE = "http://fuse.sf.net"
+LICENSE = "LGPL"
+
+PR = "r0"
+
+DEPENDS = "fakeroot-native"
+RRECOMMENDS_${PN} = "fuse-module kernel-module-fuse"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/${P}.tar.gz \
+          file://not-run-updaterc.d-on-host.patch;patch=1" 
+
+
+inherit autotools pkgconfig
+EXTRA_OECONF = " --disable-kernel-module"
+
+fakeroot do_install() {
+       oe_runmake install DESTDIR=${D}
+}
+
+#package utils in a sperate package and stop debian.bbclass renaming it to libfuse-utils, we want it to be fuse-utils
+PACKAGES =+ "lib${PN} libulockmgr"
+FILES_${PN}-dev +=     "${libdir}/*.la"
+FILES_lib${PN} =       "${libdir}/libfuse*.so.*"
+FILES_libulockmgr =    "${libdir}/libulockmgr.so.*"
+
+
+fakeroot do_stage() {
+       autotools_stage_all
+}
+
+