alsa-lib: update to 1.0.13
authorKoen Kooi <koen@openembedded.org>
Thu, 16 Nov 2006 12:33:11 +0000 (12:33 +0000)
committerKoen Kooi <koen@openembedded.org>
Thu, 16 Nov 2006 12:33:11 +0000 (12:33 +0000)
packages/alsa/alsa-lib_1.0.13.bb [new file with mode: 0644]

diff --git a/packages/alsa/alsa-lib_1.0.13.bb b/packages/alsa/alsa-lib_1.0.13.bb
new file mode 100644 (file)
index 0000000..987a590
--- /dev/null
@@ -0,0 +1,33 @@
+DESCRIPTION = "Alsa sound library"
+HOMEPAGE = "http://www.alsa-project.org"
+SECTION = "libs/multimedia"
+LICENSE = "GPL"
+PR = "r0"
+
+# configure.in sets -D__arm__ on the command line for any arm system
+# (not just those with the ARM instruction set), this should be removed,
+# (or replaced by a permitted #define).
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
+
+do_stage() {
+       oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
+       install -d ${STAGING_INCDIR}/alsa/sound
+       install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
+       install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
+       install -d ${STAGING_DATADIR}/aclocal
+       install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES =+ "alsa-server libasound alsa-conf alsa-doc alsa-dev"
+FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
+FILES_libasound = "${libdir}/libasound.so.*"
+FILES_alsa-server = "${bindir}/*"
+FILES_alsa-conf = "${datadir}"
+FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/"