packages/mesa/mesa_6.5.2.bb : Fix a bug in mesa that tries to build a binary
authorStelios Koroneos <skoroneos@digital-opsis.com>
Thu, 7 Jun 2007 21:55:05 +0000 (21:55 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Thu, 7 Jun 2007 21:55:05 +0000 (21:55 +0000)
(gen_matypes) used by the host to generate an include file (matypes.h) using target's includes

packages/mesa/mesa-6.5.2/fix-host-compile.patch [new file with mode: 0644]
packages/mesa/mesa_6.5.2.bb

diff --git a/packages/mesa/mesa-6.5.2/fix-host-compile.patch b/packages/mesa/mesa-6.5.2/fix-host-compile.patch
new file mode 100644 (file)
index 0000000..d24d03d
--- /dev/null
@@ -0,0 +1,30 @@
+--- /src/mesa/x86/orig-Makefile        2005-07-01 04:54:38.000000000 +0300
++++ /src/mesa/x86/Makefile     2007-06-07 21:52:31.000000000 +0300
+@@ -5,6 +5,7 @@
+ INCLUDE_DIRS = \
++        -I/usr/include \
+       -I$(TOP)/include/GL \
+       -I$(TOP)/include \
+       -I.. \
+@@ -13,6 +14,10 @@
+       -I../glapi \
+       -I../tnl
++OPT_FLAGS_host = -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os
++
++CFLAGS_host = -Wall -Wmissing-prototypes $(OPT_FLAGS_host) $(PIC_FLAGS) $(ARCH_FLAGS) \
++        $(DEFINES) $(ASM_FLAGS) $(X11_INCLUDES) -std=c99 -ffast-math
+ default: gen_matypes matypes.h
+@@ -21,7 +26,7 @@
+ gen_matypes: gen_matypes.c
+-      $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
++      $(CC) $(INCLUDE_DIRS) $(CFLAGS_host) gen_matypes.c -o gen_matypes
+ # need some special rules here, unfortunately
+ matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes
index 1c245f0..79993cc 100644 (file)
@@ -1,3 +1,8 @@
-PR = "r0"
+PR = "r1"
 
 include mesa-mesa.inc
+
+SRC_URI_append = " file://fix-host-compile.patch;patch=1 "
+
+
+