libopie2: add fix for cursor key rotation on spitz
authorPaul Eggleton <bluelightning@bluelightning.org>
Mon, 11 Aug 2008 22:22:32 +0000 (22:22 +0000)
committerPaul Eggleton <bluelightning@bluelightning.org>
Mon, 11 Aug 2008 22:22:32 +0000 (22:22 +0000)
packages/libopie/libopie2/spitz_rotate_fix.patch [new file with mode: 0644]
packages/libopie/libopie2_1.2.3.bb

diff --git a/packages/libopie/libopie2/spitz_rotate_fix.patch b/packages/libopie/libopie2/spitz_rotate_fix.patch
new file mode 100644 (file)
index 0000000..428ec0d
--- /dev/null
@@ -0,0 +1,23 @@
+--- libopie2/opiecore/device/odevice_zaurus.cpp        30 Jul 2007 19:10:52 -0000      1.53
++++ libopie2/opiecore/device/odevice_zaurus.cpp        8 Aug 2008 23:15:15 -0000
+@@ -760,9 +760,18 @@
+         case Key_Up   :
+         case Key_Down :
+         {
+-            if (rotation()==Rot90) {
+-                newkeycode = Key_Left + ( keycode - Key_Left + 3 ) % 4;
++            if (d->m_model == Model_Zaurus_SLC3000) {
++                // This ensures that the cursor keys work correctly and that the
++                // side wheel works as expected when the screen is flipped over
++                if (rotation() == Rot270)
++                    newkeycode = Key_Left + ( keycode - Key_Left + 1 ) % 4;
+             }
++            else {
++                if (rotation()==Rot90)
++                    newkeycode = Key_Left + ( keycode - Key_Left + 3 ) % 4;
++            }
++            break;
++            
+         }
+         break;
index 288b689..522fe55 100644 (file)
@@ -1,11 +1,12 @@
 require ${PN}.inc
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/libopie2 \
            file://include.pro \
            file://gcc-syntax-fix.patch;patch=1 \
            file://h4000_and_default_rot.patch;patch=1 \
-           file://ipaq_rotate_fix.patch;patch=1"
+           file://ipaq_rotate_fix.patch;patch=1 \
+           file://spitz_rotate_fix.patch;patch=1"
 
 SRC_URI_append_poodle = " file://poodle-2.6-hotkeys.patch;patch=1"