* Addition of jlime jornada6xx kernel (2.6.25) bb file.
authorKristoffer Ericson <kristoffer_e1@hotmail.com>
Thu, 8 May 2008 17:25:44 +0000 (17:25 +0000)
committerKristoffer Ericson <kristoffer_e1@hotmail.com>
Thu, 8 May 2008 17:25:44 +0000 (17:25 +0000)
  This package grabs sources and config from our git repository
  so no subdir is needed.

packages/linux/linux-jlime-jornada6xx_2.6.25.bb [new file with mode: 0644]

diff --git a/packages/linux/linux-jlime-jornada6xx_2.6.25.bb b/packages/linux/linux-jlime-jornada6xx_2.6.25.bb
new file mode 100644 (file)
index 0000000..c55cf15
--- /dev/null
@@ -0,0 +1,30 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for SuperH based Jornada 6xx"
+LICENSE = "GPL"
+PR = "r0"
+
+SRCREV = "${AUTOREV}"
+
+COMPATIBLE_HOST = "sh.*-linux"
+#COMPATIBLE_MACHINE = "jornada6xx"
+
+SRC_URI = "git://jlime.org/jlime-stable.git;protocol=git;branch=v2.6.25-stable"
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "sh"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+       install -m 0644 ${S}/config-hp6xx-2.6.25 ${S}/.config
+}
+
+do_deploy() {
+        install -d ${DEPLOY_DIR_IMAGE}
+       install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}
+}