boost-asio: recipes for the asio library
authorMartin Dietze <di@fh-wedel.de>
Thu, 2 Nov 2006 13:43:50 +0000 (13:43 +0000)
committerMartin Dietze <di@fh-wedel.de>
Thu, 2 Nov 2006 13:43:50 +0000 (13:43 +0000)
- the library is designed to be used with boost 1.33
- future boost releases will contain asio as a component which will obsolete this package

packages/boost-asio/.mtn2git_empty [new file with mode: 0644]
packages/boost-asio/boost-asio_0.3.7.bb [new file with mode: 0644]
packages/boost-asio/files/.mtn2git_empty [new file with mode: 0644]
packages/boost-asio/files/disable-epoll.patch [new file with mode: 0644]

diff --git a/packages/boost-asio/.mtn2git_empty b/packages/boost-asio/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/boost-asio/boost-asio_0.3.7.bb b/packages/boost-asio/boost-asio_0.3.7.bb
new file mode 100644 (file)
index 0000000..0788804
--- /dev/null
@@ -0,0 +1,39 @@
+DESCRIPTION = "Asio 0.3.7 for work with boost, should be moved into boost package once integrated into the boost distribution."
+HOMEPAGE = "http://asio.sf.net/"
+MAINTAINER = "Martin Dietze <dietze@4g-systems.com>"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r1"
+
+inherit debian
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/asio/boost_asio_0_3_7.tar.bz2"
+
+# mtx-[12] use 2.4 kernels but the kernel-libc-headers are from kernel 2.6,
+# thus the automatic epoll detection does not work in epoll_reactor_fwd.hpp.
+SRC_URI_append_mtx-1 = " file://disable-epoll.patch;patch=1"
+SRC_URI_append_mtx-2 = " file://disable-epoll.patch;patch=1"
+
+S = "${WORKDIR}/boost_asio_0_3_7"
+
+do_configure() {
+}
+
+do_compile() {
+}
+
+do_install() {
+       cd ${S}
+       install -d ${D}/usr/include
+       cp -dpR boost ${D}/usr/include
+}
+
+do_stage() {
+       cd ${S}
+       install -d -m 775 ${STAGING_INCDIR}
+       cp -dpR boost ${STAGING_INCDIR}
+}
+
+PACKAGES = "${PN}-dev"
+FILES_${PN}-dev = "/usr/include"
diff --git a/packages/boost-asio/files/.mtn2git_empty b/packages/boost-asio/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/boost-asio/files/disable-epoll.patch b/packages/boost-asio/files/disable-epoll.patch
new file mode 100644 (file)
index 0000000..2d251f6
--- /dev/null
@@ -0,0 +1,11 @@
+--- boost_asio_0_3_7-orig/boost/asio/detail/epoll_reactor_fwd.hpp      2006-10-27 09:59:16.622530738 +0200
++++ boost_asio_0_3_7/boost/asio/detail/epoll_reactor_fwd.hpp   2006-10-27 09:59:41.131614794 +0200
+@@ -17,7 +17,7 @@
+ #include <boost/asio/detail/push_options.hpp>
+-#if !defined(BOOST_ASIO_DISABLE_EPOLL)
++#if !defined(BOOST_ASIO_DISABLE_EPOLL) && 0 // mtx-[12] uses 2.4 kernels!
+ #if defined(__linux__) // This service is only supported on Linux.
+ #include <boost/asio/detail/push_options.hpp>