picocom: add UUCP_LOCK_DIR define and one patch to get it built with gcc4
authorMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 12 Mar 2007 07:54:19 +0000 (07:54 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 12 Mar 2007 07:54:19 +0000 (07:54 +0000)
packages/picocom/picocom/.mtn2git_empty [new file with mode: 0644]
packages/picocom/picocom/gcc4.patch [new file with mode: 0644]
packages/picocom/picocom_1.4.bb

diff --git a/packages/picocom/picocom/.mtn2git_empty b/packages/picocom/picocom/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/picocom/picocom/gcc4.patch b/packages/picocom/picocom/gcc4.patch
new file mode 100644 (file)
index 0000000..867ca11
--- /dev/null
@@ -0,0 +1,12 @@
+Index: picocom-1.4/picocom.c
+===================================================================
+--- picocom-1.4.orig/picocom.c 2004-08-12 13:45:11.000000000 +0200
++++ picocom-1.4/picocom.c      2007-03-08 14:40:30.000000000 +0100
+@@ -37,6 +37,7 @@
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <limits.h>
++#include <bits/posix1_lim.h>
+ #define _GNU_SOURCE
+ #include <getopt.h>
index 0464090..8bc3b89 100644 (file)
@@ -1,10 +1,13 @@
-DESCRIPTION = "Picocom is a lightweight and minimal (~20K) dumb-terminal emulation program. "
+DESCRIPTION = "Lightweight and minimal (~20K) dumb-terminal emulation program."
 SECTION = "console/utils"
 PRIORITY = "optional"
 LICENSE = "GPL"
-SRC_URI = "http://efault.net/npat/hacks/picocom/dist/picocom-${PV}.tar.gz"
+PR = "r1"
 
-CFLAGS_append = ' -DVERSION_STR=\\"${PV}\\"'
+SRC_URI = "http://efault.net/npat/hacks/picocom/dist/picocom-${PV}.tar.gz \
+           file://gcc4.patch;patch=1"
+
+CFLAGS_append = ' -DVERSION_STR=\\"${PV}\\" -DUUCP_LOCK_DIR'
 
 do_install () {
        install -d ${D}${bindir}