cacao: Use ${libdir_jni} instead of ${libdir}/jni
authorRobert Schuster <thebohemian@gmx.net>
Sat, 9 Feb 2008 03:16:38 +0000 (03:16 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Sat, 9 Feb 2008 03:16:38 +0000 (03:16 +0000)
packages/cacao/cacao.inc
packages/cacao/cacao_0.98+hg20071001.bb

index 09fc741..0d2b4c7 100644 (file)
@@ -13,7 +13,7 @@ RDEPENDS = "classpath"
 PROVIDES = "cacao virtual/java"
 RPROVIDES_cacao = "java2-runtime"
 
-inherit autotools update-alternatives
+inherit java autotools update-alternatives
 
 EXTRA_OECONF = "\
        ${@['','--enable-softfloat'][bb.data.getVar('TARGET_FPU',d,1) == 'soft']} \
@@ -41,11 +41,11 @@ do_configure_prepend() {
   # Replaces the placeholder OE_LIBDIR_JNI with the JNI library directory
   # configured in OE.
   if [ -e src/vm/properties.c ]; then
-    sed -i -e "s|OE_LIBDIR_JNI|${libdir}/jni|" src/vm/properties.c
+    sed -i -e "s|OE_LIBDIR_JNI|${libdir_jni}|" src/vm/properties.c
   fi
 
   if [ -e src/vm/properties.c ]; then
-    sed -i -e "s|OE_LIBDIR_JNI|${libdir}/jni|" src/vm/vm.c
+    sed -i -e "s|OE_LIBDIR_JNI|${libdir_jni}|" src/vm/vm.c
   fi
 }
 
index 94919ad..878827c 100644 (file)
@@ -1,6 +1,6 @@
 require cacao.inc
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "\
         http://jalimo.evolvis.org/repository/sources/cacao-${PV}.tar.bz2;md5sum=9ff10c929bd0cbf15909107c1aff7518 \