arpwatch 2.1a15: Cleanups for arpwatch:
authorJamie Lenehan <lenehan@twibble.org>
Wed, 22 Nov 2006 05:32:23 +0000 (05:32 +0000)
committerJamie Lenehan <lenehan@twibble.org>
Wed, 22 Nov 2006 05:32:23 +0000 (05:32 +0000)
- mark configuration so they don't get wiped on upgrade
- don't pass -p, for nopromisc, as an option since that isn't
  supported (must be a debian patch which is not included in OE)
- remove RUNAS which was used to specify a non-root user to run as
  since it isn't support (must be a debian patch which is not
  included in OE)
- Use volatiles to create required /var directory.
- Inherit update-rc.d so it is started and stopped during
  uninstall, upgrade and uninstall.

packages/arpwatch/arpwatch_2.1a15.bb
packages/arpwatch/files/arpwatch.default
packages/arpwatch/files/volatiles.08_arpwatch [new file with mode: 0644]

index 446dddc..74e667c 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www-nrg.ee.lbl.gov/"
 SECTION = "network"
 LICENSE = "BSD"
 RRECOMMENDS = "arpwatch-data"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "ftp://ftp.ee.lbl.gov/arpwatch-${PV}.tar.gz \
            file://05debian_fhs.patch;patch=1 \
@@ -12,11 +12,10 @@ SRC_URI = "ftp://ftp.ee.lbl.gov/arpwatch-${PV}.tar.gz \
            file://arpwatch.default \
            file://arpwatch.conf \
            file://ethercodes.dat \
-           file://make.patch;patch=1"
+           file://make.patch;patch=1 \
+           file://volatiles.08_arpwatch"
 
-inherit autotools
-
-EXTRA_OEMAKE = "LDFLAGS=-L${STAGING_LIBDIR}"
+inherit autotools update-rc.d
 
 PACKAGES =+ "arpwatch-data"
 
@@ -24,9 +23,10 @@ FILES_arpwatch-data = "${datadir}/arpwatch/ethercodes.dat"
 
 do_install() {
         install -d ${D}${bindir} ${D}${sbindir} ${D}${mandir}/man8 \
-                   ${D}${sysconfdir}/default \
-                   ${D}${sysconfdir}/init.d \
-                   ${D}${datadir}/arpwatch
+                ${D}${sysconfdir}/default \
+                ${D}${sysconfdir}/init.d \
+                ${D}${datadir}/arpwatch \
+                ${D}${sysconfdir}/default/volatiles
         oe_runmake install DESTDIR=${D}
         oe_runmake install-man DESTDIR=${D}
         for i in arp2ethers arpfetch massagevendor; do
@@ -40,4 +40,19 @@ do_install() {
         install -m 0644 ${WORKDIR}/arpwatch.default ${D}${sysconfdir}/default/arpwatch
         install -m 0644 ${WORKDIR}/arpwatch.conf ${D}${sysconfdir}
         install -m 0644 ${WORKDIR}/ethercodes.dat ${D}${datadir}/arpwatch
+
+        # We need some /var directories
+        for i in 08_arpwatch; do
+          install -m 0644 ${WORKDIR}/volatiles.$i ${D}${sysconfdir}/default/volatiles/$i
+        done
 }
+
+pkg_postinst_${PN} () {
+        /etc/init.d/populate-volatile.sh update
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/arpwatch \
+                   ${sysconfdir}/arpwatch.conf"
+
+INITSCRIPT_NAME = "arpwatch"
+INITSCRIPT_PARAMS = "defaults 95 05"
index b0a7d8f..204dfff 100644 (file)
@@ -1,7 +1,4 @@
 # Global options for arpwatch(8).
 
-# Debian: don't report bogons, don't use PROMISC.
-ARGS="-N -p"
-
-# Debian: run as `arpwatch' user.  Empty this to run as root.
-RUNAS="arpwatch"
+# Debian: don't report bogons
+ARGS="-N"
diff --git a/packages/arpwatch/files/volatiles.08_arpwatch b/packages/arpwatch/files/volatiles.08_arpwatch
new file mode 100644 (file)
index 0000000..2167361
--- /dev/null
@@ -0,0 +1,2 @@
+# <type> <owner> <group> <mode> <path> <linksource>
+d root root 0775 /var/lib/arpwatch none