gcc: Include TARGET_CC_ARCH in ARCH_FLAGS_FOR_TARGET by default for everyone, not...
authorRichard Purdie <rpurdie@rpsys.net>
Sat, 29 Mar 2008 12:47:57 +0000 (12:47 +0000)
committerRichard Purdie <rpurdie@rpsys.net>
Sat, 29 Mar 2008 12:47:57 +0000 (12:47 +0000)
37 files changed:
packages/gcc/gcc-configure-common.inc
packages/gcc/gcc-cross-sdk_3.3.4.bb
packages/gcc/gcc-cross-sdk_3.4.3.bb
packages/gcc/gcc-cross-sdk_3.4.4.bb
packages/gcc/gcc-cross-sdk_4.1.0.bb
packages/gcc/gcc-cross-sdk_4.1.1.bb
packages/gcc/gcc-cross-sdk_4.1.2.bb
packages/gcc/gcc-cross-sdk_4.2.2.bb
packages/gcc/gcc-cross-sdk_4.3.0.bb
packages/gcc/gcc-cross_3.3.3.bb
packages/gcc/gcc-cross_3.3.4.bb
packages/gcc/gcc-cross_3.4.3.bb
packages/gcc/gcc-cross_3.4.4.bb
packages/gcc/gcc-cross_4.0.0.bb
packages/gcc/gcc-cross_4.0.2.bb
packages/gcc/gcc-cross_4.1.0.bb
packages/gcc/gcc-cross_4.1.1.bb
packages/gcc/gcc-cross_4.1.2.bb
packages/gcc/gcc-cross_4.2.1.bb
packages/gcc/gcc-cross_4.2.2.bb
packages/gcc/gcc-cross_4.3.0.bb
packages/gcc/gcc-cross_csl-arm-2005q3.bb
packages/gcc/gcc-cross_csl-arm-2006q1.bb
packages/gcc/gcc_3.3.3.bb
packages/gcc/gcc_3.3.4.bb
packages/gcc/gcc_3.4.3.bb
packages/gcc/gcc_3.4.4.bb
packages/gcc/gcc_4.0.0.bb
packages/gcc/gcc_4.0.2.bb
packages/gcc/gcc_4.1.0.bb
packages/gcc/gcc_4.1.1.bb
packages/gcc/gcc_4.1.2.bb
packages/gcc/gcc_4.2.1.bb
packages/gcc/gcc_4.2.2.bb
packages/gcc/gcc_4.3.0.bb
packages/gcc/gcc_csl-arm-2005q3.bb
packages/gcc/gcc_csl-arm-2006q1.bb

index 9085367..d9bd400 100644 (file)
@@ -42,11 +42,7 @@ CPPFLAGS = ""
 
 # Used by configure to define additional values for FLAGS_FOR_TARGET -
 # passed to all the compilers.
-ARCH_FLAGS_FOR_TARGET = ""
-#NOTE: not tested on other platforms, the following is probably correct
-# everywhere!
-ARCH_FLAGS_FOR_TARGET_slugos = "${TARGET_CC_ARCH}"
-ARCH_FLAGS_FOR_TARGET_unslung = "${TARGET_CC_ARCH}"
+ARCH_FLAGS_FOR_TARGET = "${TARGET_CC_ARCH}"
 EXTRA_OEMAKE += "ARCH_FLAGS_FOR_TARGET='${ARCH_FLAGS_FOR_TARGET}'"
 
 do_configure () {
index 481f314..d9f5880 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
 
 require gcc-${PV}.inc
 require gcc-cross-sdk.inc
index 1a7faa5..c76b5b3 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-cross-sdk.inc
index 5cba195..8329aac 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
 
 require gcc-${PV}.inc
 require gcc-cross-sdk.inc
index 8329aac..ee769e0 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-cross-sdk.inc
index 89f6984..616a583 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
 
 require gcc-${PV}.inc
 require gcc-cross-sdk.inc
index c3a4daa..781214f 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-cross.inc
index 5b9c8f3..bfc37e4 100644 (file)
@@ -1,4 +1,4 @@
-PR="r6"
+PR="r7"
 
 require gcc-${PV}.inc
 require gcc-cross.inc
index ccc2cee..43d4b76 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r13"
+PR = "r14"
 
 require gcc-${PV}.inc
 require gcc-cross.inc
index 4d93346..c9b5cc9 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
 
 require gcc-${PV}.inc
 require gcc-cross.inc
index 40f5140..368c82a 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index c296a03..9d035d9 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "r11"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 82be62a..ad73dc7 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index ab3fc40..c480db7 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r18"
+PR = "r19"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index a344bfc..070a1e3 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "r15"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 8e20d03..901c87c 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "r15"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 11e0459..72f7283 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 68c4d70..036ebd9 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 09f09fa..5085855 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
 
 require gcc-csl-arm-2005q3.inc
 require gcc-cross.inc
index 49ac900..2923192 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
 
 require gcc-csl-arm-2006q1.inc
 require gcc-cross.inc
index cc7540a..2df12ef 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index cc7540a..2df12ef 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index 73e908a..1e68af5 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r12"
+PR = "r14"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index 5e25980..ff7cb7e 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index cc7540a..2df12ef 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index 5e25980..ff7cb7e 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index cc7540a..9fd2b0a 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r5"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index 8ae8710..9dbfca5 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r18"
+PR = "r20"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index c51eb23..da1ecb9 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r11"
+PR = "r12"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index 09a7cbb..c51eb23 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "r11"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index 7238aed..556fc74 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index f191a18..ff100fd 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index cc7540a..2df12ef 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
index 832167c..4999c6a 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc