Add leafpad 0.8.4
authorRichard Purdie <rpurdie@rpsys.net>
Thu, 23 Mar 2006 23:40:23 +0000 (23:40 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Thu, 23 Mar 2006 23:40:23 +0000 (23:40 +0000)
packages/leafpad/.mtn2git_empty [new file with mode: 0644]
packages/leafpad/files/.mtn2git_empty [new file with mode: 0644]
packages/leafpad/files/leafpad.desktop [new file with mode: 0644]
packages/leafpad/files/leafpad.png [new file with mode: 0644]
packages/leafpad/leafpad_0.8.4.bb [new file with mode: 0644]

diff --git a/packages/leafpad/.mtn2git_empty b/packages/leafpad/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/leafpad/files/.mtn2git_empty b/packages/leafpad/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/leafpad/files/leafpad.desktop b/packages/leafpad/files/leafpad.desktop
new file mode 100644 (file)
index 0000000..0e58279
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Notes
+Exec=/usr/bin/leafpad
+Icon=leafpad.png
+Terminal=false
+Type=Application
+Categories=Utility;PIM;
+SingleInstance=true
+StartupNotify=true
+
diff --git a/packages/leafpad/files/leafpad.png b/packages/leafpad/files/leafpad.png
new file mode 100644 (file)
index 0000000..c5ee0cf
Binary files /dev/null and b/packages/leafpad/files/leafpad.png differ
diff --git a/packages/leafpad/leafpad_0.8.4.bb b/packages/leafpad/leafpad_0.8.4.bb
new file mode 100644 (file)
index 0000000..c26f149
--- /dev/null
@@ -0,0 +1,21 @@
+LICENSE = "GPLv2"
+DEPENDS = "gtk+"
+SRC_URI = "http://savannah.nongnu.org/download/${PN}/${PN}-${PV}.tar.gz \
+          file://leafpad.desktop \
+          file://leafpad.png"
+PR = "r1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --enable-chooser --disable-gtktest --disable-print"
+
+do_install_append () {
+        install -d ${D}/${datadir}
+        install -d ${D}/${datadir}/applications
+        install -d ${D}/${datadir}/pixmaps/
+
+        install -m 0644 ${WORKDIR}/leafpad.png ${D}/${datadir}/pixmaps
+        install -m 0644 ${WORKDIR}/leafpad.desktop ${D}/${datadir}/applications
+}
+
+FILES_${PN} += "${datadir}/applications/leafpad.desktop ${datadir}/pixmaps/leafpad.png"