nautilus: add 2.28.1
authorKoen Kooi <koen@openembedded.org>
Sun, 8 Nov 2009 09:35:08 +0000 (10:35 +0100)
committerKoen Kooi <koen@openembedded.org>
Sun, 8 Nov 2009 09:35:08 +0000 (10:35 +0100)
conf/checksums.ini
recipes/nautilus/nautilus_2.28.1.bb [new file with mode: 0644]

index 4a919cb..0769727 100644 (file)
@@ -19030,6 +19030,10 @@ sha256=86c8839ad5c8a1c5674eb3617bbe15e9c9bb2358a7435a0e2d22cd25ab7718ff
 md5=14d9464043848eddd0bd0d35bbe63415
 sha256=3761b27da474b71194ff900e7941c005be608a00fe0ba1f216390ce1ba9cba72
 
+[http://ftp.gnome.org/pub/GNOME/sources/nautilus/2.28/nautilus-2.28.1.tar.bz2]
+md5=e759af11a0844828e2b484ff42ee0498
+sha256=197147d04529ee14e63609fa4755c9effff19842f77594ff8cce6e2433d0bec0
+
 [http://ftp.gnome.org/pub/GNOME/sources/nautilus/2.6/nautilus-2.6.1.tar.bz2]
 md5=50c5732c0c9736b7026bce1c6b0007dc
 sha256=83f1d6623e142af30a9b3fa9135ecf973fbb8c89f1dc36a218de0c0fef6ddf07
diff --git a/recipes/nautilus/nautilus_2.28.1.bb b/recipes/nautilus/nautilus_2.28.1.bb
new file mode 100644 (file)
index 0000000..e3a551c
--- /dev/null
@@ -0,0 +1,37 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+SRC_URI += "file://idl-sysroot.patch;patch=1 \
+            file://no-try-run-strftime.diff;patch=1 \
+"
+
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+LICENSE="GPL"
+
+DEPENDS += "libunique  gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
+RDEPENDS = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
+
+EXTRA_OECONF = " --disable-gtk-doc  --disable-update-mimedb "
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons  /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+do_configure_prepend() {
+       sed -i -e /docs/d Makefile.am
+}
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+       find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+do_stage() {
+       autotools_stage_all
+}