dfu-util: Add dfu-util and dfu-util-native from OpenMoko svn
authorMatthias Hentges <oe@hentges.net>
Fri, 9 Mar 2007 23:37:54 +0000 (23:37 +0000)
committerMatthias Hentges <oe@hentges.net>
Fri, 9 Mar 2007 23:37:54 +0000 (23:37 +0000)
packages/dfu-util/.mtn2git_empty [new file with mode: 0644]
packages/dfu-util/dfu-util-native_svn.bb [new file with mode: 0644]
packages/dfu-util/dfu-util_svn.bb [new file with mode: 0644]

diff --git a/packages/dfu-util/.mtn2git_empty b/packages/dfu-util/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/dfu-util/dfu-util-native_svn.bb b/packages/dfu-util/dfu-util-native_svn.bb
new file mode 100644 (file)
index 0000000..af6603d
--- /dev/null
@@ -0,0 +1,16 @@
+require dfu-util_${PV}.bb
+
+inherit native
+
+DEPENDS = "libusb-native"
+
+do_stage() {
+       install -m 0755 src/dfu-util ${STAGING_BINDIR_NATIVE}
+}
+
+do_deploy() {
+       install -d ${DEPLOY_DIR_IMAGE}
+       install -m 0755 src/dfu-util_static ${DEPLOY_DIR_IMAGE}/dfu-util
+}
+
+addtask deploy before do_package after do_install
diff --git a/packages/dfu-util/dfu-util_svn.bb b/packages/dfu-util/dfu-util_svn.bb
new file mode 100644 (file)
index 0000000..6f2e050
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "USB Device Firmware Upgrade utility"
+SECTION = "devel"
+AUTHOR = "Harald Welte"
+LICENSE = "GPL"
+PV = "0.1+svn${SRCDATE}"
+PR = "r0"
+
+DEPENDS = "libusb"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=dfu-util;proto=http"
+S = "${WORKDIR}/dfu-util"
+
+inherit autotools
+
+do_stage() {
+       autotools_stage_all
+}