linux-kexecboot-2.6.24: fix compilation with gcc-4.3. Bump PR
authorAndrea Adami <andrea.adami@gmail.com>
Sat, 30 May 2009 23:13:28 +0000 (01:13 +0200)
committerAndrea Adami <andrea.adami@gmail.com>
Sat, 30 May 2009 23:23:15 +0000 (01:23 +0200)
Since some architectures don't support __udivdi3().

Signed-off-by: Segher Boessenkool <segher@kernel.crashing.org>
Cc: john stultz <johnstul@us.ibm.com>
Cc: Ingo Molnar <mingo@elte.hu>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
recipes/kexecboot/linux-kexecboot-2.6.24/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch [new file with mode: 0644]
recipes/kexecboot/linux-kexecboot.inc
recipes/kexecboot/linux-kexecboot_2.6.24.bb

diff --git a/recipes/kexecboot/linux-kexecboot-2.6.24/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch b/recipes/kexecboot/linux-kexecboot-2.6.24/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch
new file mode 100644 (file)
index 0000000..9d7020d
--- /dev/null
@@ -0,0 +1,15 @@
+Index: linux-2.6.24/include/linux/time.h
+===================================================================
+--- a/include/linux/time.h
++++ b/include/linux/time.h
+@@ -172,6 +172,10 @@ static inline void timespec_add_ns(struct timespec *a, u64 ns)
+ {
+       ns += a->tv_nsec;
+       while(unlikely(ns >= NSEC_PER_SEC)) {
++              /* The following asm() prevents the compiler from
++               * optimising this loop into a modulo operation.  */
++              asm("" : "+r"(ns));
++
+               ns -= NSEC_PER_SEC;
+               a->tv_sec++;
+       }
index 74767b0..5193212 100644 (file)
@@ -1,5 +1,5 @@
 # We set PR here, since a change in the kexecboot recipe will need to get picked up by *all* the kernels:
-PR = "r12"
+PR = "r13"
 
 SRC_URI = "file://defconfig"
 
index f728c7a..82484f4 100644 (file)
@@ -21,6 +21,7 @@ DEFAULT_PREFERENCE_spitz = "1"
 # Patches submitted upstream are towards top of this list 
 # Hacks should clearly named and at the bottom
 SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
+           file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch;patch=1 \
            ${RPSRC}/export_atags-r2.patch;patch=1;status=pending \
            ${RPSRC}/lzo_crypto-r2.patch;patch=1;status=pending \
            ${RPSRC}/corgi_rearrange_lcd-r0.patch;patch=1;status=pending \