gpe-what: Add patch to set window type hint. Necessary for compatibility with matchbo...
authorFlorian Boor <florian.boor@kernelconcepts.de>
Tue, 5 Dec 2006 15:47:48 +0000 (15:47 +0000)
committerFlorian Boor <florian.boor@kernelconcepts.de>
Tue, 5 Dec 2006 15:47:48 +0000 (15:47 +0000)
packages/gpe-what/gpe-what-0.43/.mtn2git_empty [new file with mode: 0644]
packages/gpe-what/gpe-what-0.43/set-wm-hint.patch [new file with mode: 0644]
packages/gpe-what/gpe-what_0.43.bb

diff --git a/packages/gpe-what/gpe-what-0.43/.mtn2git_empty b/packages/gpe-what/gpe-what-0.43/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gpe-what/gpe-what-0.43/set-wm-hint.patch b/packages/gpe-what/gpe-what-0.43/set-wm-hint.patch
new file mode 100644 (file)
index 0000000..1300635
--- /dev/null
@@ -0,0 +1,12 @@
+Index: gpe-what.c
+===================================================================
+--- gpe-what.c (Revision 8874)
++++ gpe-what.c (Arbeitskopie)
+@@ -233,6 +233,7 @@
+   
+   gtk_window_set_default_size (GTK_WINDOW (popup), width, height);
+   gtk_window_set_decorated (GTK_WINDOW (popup), FALSE);
++  gtk_window_set_type_hint (GTK_WINDOW (popup), GDK_WINDOW_TYPE_HINT_MENU);
+   gtk_label_set_line_wrap (GTK_LABEL (label), TRUE);
+   gtk_container_set_border_width (GTK_CONTAINER (box), spacing);
+     
index 2cc0dc9..b82da4f 100644 (file)
@@ -1,8 +1,9 @@
 LICENSE = "GPL"
 DESCRIPTION = "GPE modal help"
 DEPENDS = "virtual/libx11 gtk+"
-
+PR = "r1"
 
 GPE_TARBALL_SUFFIX= "bz2"
 inherit autotools gpe
 
+SRC_URI += " file://set-wm-hint.patch;patch=1;pnum=0"