bash 3.2 fix compiling, this time for real
authorMichael Lauer <mickey@vanille-media.de>
Mon, 9 Jun 2008 23:01:14 +0000 (23:01 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Mon, 9 Jun 2008 23:01:14 +0000 (23:01 +0000)
packages/bash/bash.inc
packages/bash/bash_3.0.bb
packages/bash/bash_3.2.bb
packages/bash/files/.mtn2git_empty [new file with mode: 0644]
packages/bash/files/builtins.patch [new file with mode: 0644]

index dd2a180..bf4a345 100644 (file)
@@ -8,11 +8,13 @@ inherit autotools gettext
 
 PARALLEL_MAKE = ""
 
+SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz"
+S = "${WORKDIR}/bash-${PV}"
+
 bindir = "/bin"
 sbindir = "/sbin"
 
 EXTRA_OECONF = "--with-ncurses"
-export RM="echo"
 
 do_configure () {
        gnu-configize
index babb704..a3aa25d 100644 (file)
@@ -1,6 +1,7 @@
 require bash.inc
-PR = "r9"
+PR = "r10"
 
-SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
-        file://bash-3.0-fixes.patch;patch=1 \
-       file://signames-mipsel.diff;patch=1"
+SRC_URI += "\
+  file://bash-3.0-fixes.patch;patch=1 \
+  file://signames-mipsel.diff;patch=1 \
+"
index dc34855..568f820 100644 (file)
@@ -2,7 +2,8 @@ require bash.inc
 
 PR = "r5"
 
-SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
+SRC_URI += "\
+           file://builtins.patch;patch=1 \
            http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-001;patch=1;pnum=0 \
            http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-002;patch=1;pnum=0 \
            http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-003;patch=1;pnum=0 \
diff --git a/packages/bash/files/.mtn2git_empty b/packages/bash/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/bash/files/builtins.patch b/packages/bash/files/builtins.patch
new file mode 100644 (file)
index 0000000..d6881ac
--- /dev/null
@@ -0,0 +1,13 @@
+Index: bash-3.2/builtins/Makefile.in
+===================================================================
+--- bash-3.2.orig/builtins/Makefile.in
++++ bash-3.2/builtins/Makefile.in
+@@ -189,7 +189,7 @@ install:   @HELPINSTALL@
+ mkbuiltins.o: ../config.h
+ mkbuiltins.o: mkbuiltins.c
+-      $(RM) $@
++      echo $(RM) $@
+       $(CC_FOR_BUILD) -c $(CCFLAGS_FOR_BUILD) $<
+ mkbuiltins$(EXEEXT): mkbuiltins.o