linux-dm8000: fix enet ioctl handler
authorAndreas Oberritter <obi@opendreambox.org>
Wed, 22 Oct 2008 21:59:38 +0000 (23:59 +0200)
committerAndreas Oberritter <obi@opendreambox.org>
Wed, 22 Oct 2008 21:59:38 +0000 (23:59 +0200)
Return "operation not supported" for unhandled ioctls, so iwlib
doesn't think it's a wireless device.

packages/linux/linux-dm8000.bb
packages/linux/linux-dm8000/linux-2.6.12-fix-bcmemac-ioctl.patch [new file with mode: 0644]

index e62950d..f735c01 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "GPL"
 PN = "linux-dm8000"
 KV = "2.6.12"
 PV = "2.6.12"
-PR = "r5"
+PR = "r6"
 
 # note, the rX in the filename is *NOT* the packet revision - it's the patch revision.
 SRC_URI += "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
@@ -29,6 +29,7 @@ SRC_URI += "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
        file://linuxmips-2.6.12-gcc4-compile-fix.patch;patch=1;pnum=1 \
        file://linuxmips-2.6.12-gdb-fix.patch;patch=1;pnum=1 \
        file://linux-2.6.12-brcm-fix-minipci.patch;patch=1;pnum=1 \
+       file://linux-2.6.12-fix-bcmemac-ioctl.patch;patch=1;pnum=1 \
        http://trappist.elis.ugent.be/~mronsse/cdfs/download/cdfs-2.6.12.tar.bz2"
 
 S = "${WORKDIR}/stblinux-2.6.12"
diff --git a/packages/linux/linux-dm8000/linux-2.6.12-fix-bcmemac-ioctl.patch b/packages/linux/linux-dm8000/linux-2.6.12-fix-bcmemac-ioctl.patch
new file mode 100644 (file)
index 0000000..f7bc83f
--- /dev/null
@@ -0,0 +1,12 @@
+--- stblinux-2.6.12/drivers/net/brcmint7038/bcmemac.c.orig     2008-10-22 23:28:30.544913466 +0200
++++ stblinux-2.6.12/drivers/net/brcmint7038/bcmemac.c  2008-10-22 23:36:12.149950139 +0200
+@@ -3368,6 +3368,9 @@
+         ASSERT(pDevCtrl != NULL);
+         memset(&pDevCtrl->stats, 0, sizeof(struct net_device_stats));
+         break;
++
++    default:
++      return -EOPNOTSUPP;
+     }
+     return 0;
+ }