uboot gta01: add patch to get around EABI version 0 versus version 4 problems
authorKoen Kooi <koen@openembedded.org>
Wed, 14 Feb 2007 16:34:08 +0000 (16:34 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 14 Feb 2007 16:34:08 +0000 (16:34 +0000)
packages/uboot/files/fix-arm920t-eabi.patch [new file with mode: 0644]
packages/uboot/uboot-gta01_svn.bb

diff --git a/packages/uboot/files/fix-arm920t-eabi.patch b/packages/uboot/files/fix-arm920t-eabi.patch
new file mode 100644 (file)
index 0000000..9896388
--- /dev/null
@@ -0,0 +1,9 @@
+--- /tmp/config.mk     2007-02-14 17:23:15.000000000 +0100
++++ git/cpu/arm920t/config.mk  2007-02-14 17:23:38.475251000 +0100
+@@ -30,5 +30,5 @@
+ # Supply options according to compiler version
+ #
+ # =========================================================================
+-PLATFORM_CPPFLAGS +=$(call cc-option,-mapcs-32,-mabi=apcs-gnu)
++PLATFORM_CPPFLAGS +=$(call cc-option)
+ PLATFORM_RELFLAGS +=$(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))
index ea12a0c..21c35da 100644 (file)
@@ -4,13 +4,14 @@ LICENSE = "GPL"
 SECTION = "bootloader"
 PRIORITY = "optional"
 PV = "1.2.0+svn${SRCDATE}"
-PR = "r2"
+PR = "r3"
 
 PROVIDES = "virtual/bootloader"
 S = "${WORKDIR}/git"
 
 SRC_URI = "git://www.denx.de/git/u-boot.git/;protocol=git \
-           svn://svn.openmoko.org/trunk/src/target/u-boot;module=patches;proto=https"
+           svn://svn.openmoko.org/trunk/src/target/u-boot;module=patches;proto=https \
+          file://fix-arm920t-eabi.patch;patch=1"
 
 EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
 TARGET_LDFLAGS = ""