oxnas: kernel params for detailed uart configuration
authorSteffen Sledz <sledz@dresearch.de>
Mon, 9 Feb 2009 14:42:33 +0000 (15:42 +0100)
committerSteffen Sledz <sledz@dresearch.de>
Mon, 9 Feb 2009 14:42:33 +0000 (15:42 +0100)
packages/linux/linux-2.6.24/oxnas/oxnas-uart.patch [new file with mode: 0644]
packages/linux/linux_2.6.24.bb

diff --git a/packages/linux/linux-2.6.24/oxnas/oxnas-uart.patch b/packages/linux/linux-2.6.24/oxnas/oxnas-uart.patch
new file mode 100644 (file)
index 0000000..e72b0db
--- /dev/null
@@ -0,0 +1,176 @@
+diff -Nurd linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_dse_defconfig linux-2.6.24/arch/arm/configs/oxnas_810_eabi_dse_defconfig
+--- linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_dse_defconfig     2009-02-05 12:06:15.000000000 +0100
++++ linux-2.6.24/arch/arm/configs/oxnas_810_eabi_dse_defconfig 2009-02-05 12:08:36.000000000 +0100
+@@ -160,6 +160,8 @@
+ # CONFIG_OXNAS_VERSION_0X850 is not set
+ # CONFIG_ARCH_OXNAS_UART1 is not set
+ CONFIG_ARCH_OXNAS_UART2=y
++CONFIG_ARCH_OXNAS_UART2_DEBUG=y
++CONFIG_ARCH_OXNAS_UART2_BOOTPROGRESS=y
+ # CONFIG_ARCH_OXNAS_UART2_MODEM is not set
+ # CONFIG_ARCH_OXNAS_UART3 is not set
+ # CONFIG_ARCH_OXNAS_PCI_REQGNT_0 is not set
+diff -Nurd linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_upgrade_defconfig linux-2.6.24/arch/arm/configs/oxnas_810_eabi_upgrade_defconfig
+--- linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_upgrade_defconfig 2009-02-05 12:06:15.000000000 +0100
++++ linux-2.6.24/arch/arm/configs/oxnas_810_eabi_upgrade_defconfig     2009-02-05 12:08:36.000000000 +0100
+@@ -152,6 +152,8 @@
+ # CONFIG_OXNAS_VERSION_0X850 is not set
+ # CONFIG_ARCH_OXNAS_UART1 is not set
+ CONFIG_ARCH_OXNAS_UART2=y
++CONFIG_ARCH_OXNAS_UART2_DEBUG=y
++CONFIG_ARCH_OXNAS_UART2_BOOTPROGRESS=y
+ # CONFIG_ARCH_OXNAS_UART2_MODEM is not set
+ # CONFIG_ARCH_OXNAS_UART3 is not set
+ # CONFIG_ARCH_OXNAS_PCI_REQGNT_0 is not set
+diff -Nurd linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_wd_eval_defconfig linux-2.6.24/arch/arm/configs/oxnas_810_eabi_wd_eval_defconfig
+--- linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_wd_eval_defconfig 2009-02-05 12:06:15.000000000 +0100
++++ linux-2.6.24/arch/arm/configs/oxnas_810_eabi_wd_eval_defconfig     2009-02-05 12:08:36.000000000 +0100
+@@ -160,6 +160,8 @@
+ # CONFIG_OXNAS_VERSION_0X850 is not set
+ # CONFIG_ARCH_OXNAS_UART1 is not set
+ CONFIG_ARCH_OXNAS_UART2=y
++CONFIG_ARCH_OXNAS_UART2_DEBUG=y
++CONFIG_ARCH_OXNAS_UART2_BOOTPROGRESS=y
+ # CONFIG_ARCH_OXNAS_UART2_MODEM is not set
+ # CONFIG_ARCH_OXNAS_UART3 is not set
+ # CONFIG_ARCH_OXNAS_UART4 is not set
+diff -Nurd linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_wd_prod_defconfig linux-2.6.24/arch/arm/configs/oxnas_810_eabi_wd_prod_defconfig
+--- linux-2.6.24.org/arch/arm/configs/oxnas_810_eabi_wd_prod_defconfig 2009-02-05 12:06:15.000000000 +0100
++++ linux-2.6.24/arch/arm/configs/oxnas_810_eabi_wd_prod_defconfig     2009-02-05 12:08:36.000000000 +0100
+@@ -158,6 +158,8 @@
+ # CONFIG_OXNAS_VERSION_0X850 is not set
+ # CONFIG_ARCH_OXNAS_UART1 is not set
+ CONFIG_ARCH_OXNAS_UART2=y
++CONFIG_ARCH_OXNAS_UART2_DEBUG=y
++CONFIG_ARCH_OXNAS_UART2_BOOTPROGRESS=y
+ # CONFIG_ARCH_OXNAS_UART2_MODEM is not set
+ # CONFIG_ARCH_OXNAS_UART3 is not set
+ # CONFIG_ARCH_OXNAS_UART4 is not set
+diff -Nurd linux-2.6.24.org/arch/arm/mach-oxnas/Kconfig linux-2.6.24/arch/arm/mach-oxnas/Kconfig
+--- linux-2.6.24.org/arch/arm/mach-oxnas/Kconfig       2009-02-05 12:06:15.000000000 +0100
++++ linux-2.6.24/arch/arm/mach-oxnas/Kconfig   2009-02-05 12:08:34.000000000 +0100
+@@ -66,6 +66,20 @@
+               UARTs will be mapped to ttySn numbers from UART1 to UART4, only
+               including those UARTs selected to be present
++config ARCH_OXNAS_UART1_DEBUG
++      bool "Use UART1 as debug channel"
++      depends on ARCH_OXNAS_UART1
++      default n
++      help
++              This enables UART1 to be usable as debug channel.
++
++config ARCH_OXNAS_UART1_BOOTPROGRESS
++      bool "Display boot progress over UART1"
++      depends on ARCH_OXNAS_UART1
++      default n
++      help
++              This enables displaying boot progress over UART1.
++
+ config ARCH_OXNAS_UART1_MODEM
+       bool "Support UART1 modem control lines"
+       depends on ARCH_OXNAS_UART1
+@@ -81,6 +95,20 @@
+               UARTs will be mapped to ttySn numbers from UART1 to UART4, only
+               including those UARTs selected to be present
++config ARCH_OXNAS_UART2_DEBUG
++      bool "Use UART2 as debug channel"
++      depends on ARCH_OXNAS_UART2
++      default n
++      help
++              This enables UART2 to be usable as debug channel.
++
++config ARCH_OXNAS_UART2_BOOTPROGRESS
++      bool "Display boot progress over UART2"
++      depends on ARCH_OXNAS_UART2
++      default n
++      help
++              This enables displaying boot progress over UART2.
++
+ config ARCH_OXNAS_UART2_MODEM
+       bool "Support UART2 modem control lines"
+       depends on ARCH_OXNAS_UART2
+@@ -96,6 +124,20 @@
+               UARTs will be mapped to ttySn numbers from UART1 to UART4, only
+               including those UARTs selected to be present
++config ARCH_OXNAS_UART3_DEBUG
++      bool "Use UART3 as debug channel"
++      depends on ARCH_OXNAS_UART3
++      default n
++      help
++              This enables UART3 to be usable as debug channel.
++
++config ARCH_OXNAS_UART3_BOOTPROGRESS
++      bool "Display boot progress over UART3"
++      depends on ARCH_OXNAS_UART3
++      default n
++      help
++              This enables displaying boot progress over UART3.
++
+ config ARCH_OXNAS_UART3_MODEM
+       bool "Support UART3 modem control lines"
+       depends on ARCH_OXNAS_UART3
+@@ -114,6 +156,20 @@
+               UART4 always has its modem control lines available on external pins
+               when selected (overlaying PCI functions)
++config ARCH_OXNAS_UART4_DEBUG
++      bool "Use UART4 as debug channel"
++      depends on ARCH_OXNAS_UART4
++      default n
++      help
++              This enables UART4 to be usable as debug channel.
++
++config ARCH_OXNAS_UART4_BOOTPROGRESS
++      bool "Display boot progress over UART4"
++      depends on ARCH_OXNAS_UART4
++      default n
++      help
++              This enables displaying boot progress over UART4.
++
+ config ARCH_OXNAS_PCI_REQGNT_0
+       bool "Enable req/gnt for PCI device 0"
+       depends on PCI
+diff -Nurd linux-2.6.24.org/include/asm-arm/arch-oxnas/debug-macro.S linux-2.6.24/include/asm-arm/arch-oxnas/debug-macro.S
+--- linux-2.6.24.org/include/asm-arm/arch-oxnas/debug-macro.S  2009-02-05 12:06:19.000000000 +0100
++++ linux-2.6.24/include/asm-arm/arch-oxnas/debug-macro.S      2009-02-05 12:08:34.000000000 +0100
+@@ -14,13 +14,13 @@
+               .macro  addruart,rx
+               mrc             p15, 0, \rx, c1, c0
+               tst             \rx, #1                                 @ MMU enabled?
+-#ifdef CONFIG_ARCH_OXNAS_UART1
++#ifdef CONFIG_ARCH_OXNAS_UART1_DEBUG
+               ldreq   \rx, =UART_1_BASE_PA    @ physical base address
+               ldrne   \rx, =UART_1_BASE               @ virtual address
+-#elif CONFIG_ARCH_OXNAS_UART2
++#elif CONFIG_ARCH_OXNAS_UART2_DEBUG
+               ldreq   \rx, =UART_2_BASE_PA    @ physical base address
+               ldrne   \rx, =UART_2_BASE               @ virtual address
+-#elif CONFIG_ARCH_OXNAS_UART3
++#elif CONFIG_ARCH_OXNAS_UART3_DEBUG
+               ldreq   \rx, =UART_3_BASE_PA    @ physical base address
+               ldrne   \rx, =UART_3_BASE               @ virtual address
+ #else
+diff -Nurd linux-2.6.24.org/include/asm-arm/arch-oxnas/uncompress.h linux-2.6.24/include/asm-arm/arch-oxnas/uncompress.h
+--- linux-2.6.24.org/include/asm-arm/arch-oxnas/uncompress.h   2009-02-05 12:06:19.000000000 +0100
++++ linux-2.6.24/include/asm-arm/arch-oxnas/uncompress.h       2009-02-05 12:08:34.000000000 +0100
+@@ -12,13 +12,13 @@
+ static inline void putc(int c)
+ {
+-#ifdef CONFIG_ARCH_OXNAS_UART1
++#ifdef CONFIG_ARCH_OXNAS_UART1_BOOTPROGRESS
+     static volatile unsigned char* uart = (volatile unsigned char*)UART_1_BASE_PA;
+-#elif defined(CONFIG_ARCH_OXNAS_UART2)
++#elif defined(CONFIG_ARCH_OXNAS_UART2_BOOTPROGRESS)
+     static volatile unsigned char* uart = (volatile unsigned char*)UART_2_BASE_PA;
+-#elif defined(CONFIG_ARCH_OXNAS_UART3)
++#elif defined(CONFIG_ARCH_OXNAS_UART3_BOOTPROGRESS)
+     static volatile unsigned char* uart = (volatile unsigned char*)UART_3_BASE_PA;
+-#elif defined(CONFIG_ARCH_OXNAS_UART4)
++#elif defined(CONFIG_ARCH_OXNAS_UART4_BOOTPROGRESS)
+     static volatile unsigned char* uart = (volatile unsigned char*)UART_4_BASE_PA;
+ #else
+ #define NO_UART
index a70376c..7c4ee55 100644 (file)
@@ -11,7 +11,7 @@ DEFAULT_PREFERENCE_ts72xx = "1"
 DEFAULT_PREFERENCE_oxnas = "1"
 DEFAULT_PREFERENCE_cs-e9302 = "1"
 
-PR = "r19"
+PR = "r20"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
            http://kamikaze.waninkoko.info/patches/2.6.24/kamikaze1/broken-out/squashfs-lzma-2.6.24.patch;patch=1 \
@@ -86,6 +86,7 @@ SRC_URI_append_ts72xx = "\
 
 SRC_URI_append_oxnas = " \
        file://oxnas.diff;patch=1 \
+       file://oxnas-uart.patch;patch=1 \
        "
 
 CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"