gnome-panel: update to 2.22.2
authorKoen Kooi <koen@openembedded.org>
Mon, 1 Sep 2008 16:48:53 +0000 (16:48 +0000)
committerKoen Kooi <koen@openembedded.org>
Mon, 1 Sep 2008 16:48:53 +0000 (16:48 +0000)
libgweather: dep for gnome-panel

packages/gnome/gnome-panel_2.22.2.bb [new file with mode: 0644]
packages/gnome/libgweather_2.22.3.bb [new file with mode: 0644]

diff --git a/packages/gnome/gnome-panel_2.22.2.bb b/packages/gnome/gnome-panel_2.22.2.bb
new file mode 100644 (file)
index 0000000..b5f207a
--- /dev/null
@@ -0,0 +1,21 @@
+LICENSE = "GPL"
+DEPENDS = "libgweather startup-notification libwnck orbit2 gtk+ libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+
+inherit gnome pkgconfig
+
+do_configure_prepend() {
+        sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+                ${datadir}/icons"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_stage() {
+        autotools_stage_all
+}
diff --git a/packages/gnome/libgweather_2.22.3.bb b/packages/gnome/libgweather_2.22.3.bb
new file mode 100644 (file)
index 0000000..83fe45e
--- /dev/null
@@ -0,0 +1,21 @@
+LICENSE = "LGPL"
+DEPENDS = "libgnome"
+
+inherit gnome
+
+do_configure_prepend() {
+        sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+                ${datadir}/icons"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_stage() {
+        autotools_stage_all
+}