fakeroot: 1.9.6 -> 1.12.1
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 22 Feb 2009 18:43:14 +0000 (19:43 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 22 Feb 2009 18:43:14 +0000 (19:43 +0100)
remove 1.7

packages/fakeroot/fakeroot-native_1.12.1.bb [new file with mode: 0644]
packages/fakeroot/fakeroot-native_1.7.1.bb [deleted file]
packages/fakeroot/fakeroot-native_1.9.6.bb [deleted file]
packages/fakeroot/fakeroot_1.12.1.bb [new file with mode: 0644]
packages/fakeroot/fakeroot_1.7.1.bb [deleted file]
packages/fakeroot/fakeroot_1.9.6.bb [deleted file]
packages/fakeroot/files/configure-libtool.patch
packages/fakeroot/files/fix-prefix.patch
packages/fakeroot/files/work-with-older-libtool.patch [deleted file]

diff --git a/packages/fakeroot/fakeroot-native_1.12.1.bb b/packages/fakeroot/fakeroot-native_1.12.1.bb
new file mode 100644 (file)
index 0000000..5215dc8
--- /dev/null
@@ -0,0 +1,20 @@
+require fakeroot_${PV}.bb
+
+SRC_URI += "file://fix-prefix.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "--program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
+RDEPENDS = "util-linux-native"
diff --git a/packages/fakeroot/fakeroot-native_1.7.1.bb b/packages/fakeroot/fakeroot-native_1.7.1.bb
deleted file mode 100644 (file)
index 8a54d64..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-require fakeroot_${PV}.bb
-inherit native
-RDEPENDS = "util-linux-native"
-
-SRC_URI += "file://fix-prefix.patch;patch=1 "
-S = "${WORKDIR}/fakeroot-${PV}"
-
-EXTRA_OECONF = " --program-prefix="
-
-# Compatability for the rare systems not using or having SYSV
-python () {
-    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
-        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
-}
-
-do_stage_append () {
-    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
-}
diff --git a/packages/fakeroot/fakeroot-native_1.9.6.bb b/packages/fakeroot/fakeroot-native_1.9.6.bb
deleted file mode 100644 (file)
index 77d6f58..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-require fakeroot_${PV}.bb
-
-RDEPENDS="util-linux-native"
-
-SRC_URI += "file://fix-prefix.patch;patch=1 "
-S = "${WORKDIR}/fakeroot-${PV}"
-
-inherit native
-
-EXTRA_OECONF = " --program-prefix="
-
-# Compatability for the rare systems not using or having SYSV
-python () {
-    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
-        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
-}
-
-do_stage_append () {
-    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
-}
-
diff --git a/packages/fakeroot/fakeroot_1.12.1.bb b/packages/fakeroot/fakeroot_1.12.1.bb
new file mode 100644 (file)
index 0000000..4b61f25
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org"
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "\
+  ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+  file://configure-libtool.patch;patch=1 \
+"
+           
+inherit autotools
+
+do_stage() {
+        install -d ${STAGING_INCDIR}/fakeroot
+        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+        autotools_stage_all
+}
+
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+
diff --git a/packages/fakeroot/fakeroot_1.7.1.bb b/packages/fakeroot/fakeroot_1.7.1.bb
deleted file mode 100644 (file)
index ea3806d..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Gives a fake root environment"
-SECTION = "base"
-LICENSE = "GPL"
-# fakeroot needs getopt which is provided by the util-linux package
-RDEPENDS = "util-linux"
-PR = "r2"
-
-SRC_URI = "\
-  ftp://ftp.gentoo.mesh-solutions.com/mirrors/gentoo/distfiles/fakeroot_1.7.1.tar.gz \
-  file://work-with-older-libtool.patch;patch=1 \
-"
-
-inherit autotools
-
-do_stage() {
-        install -d ${STAGING_INCDIR}/fakeroot
-        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
-        autotools_stage_all
-}
diff --git a/packages/fakeroot/fakeroot_1.9.6.bb b/packages/fakeroot/fakeroot_1.9.6.bb
deleted file mode 100644 (file)
index aaf696d..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Gives a fake root environment"
-HOMEPAGE = "http://fakeroot.alioth.debian.org/"
-SECTION = "base"
-LICENSE = "GPL"
-# fakeroot needs getopt which is provided by the util-linux package
-RDEPENDS = "util-linux"
-PR = "r1"
-
-SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
-           file://configure-libtool.patch;patch=1"
-           
-inherit autotools
-
-do_stage() {
-        install -d ${STAGING_INCDIR}/fakeroot
-        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
-        autotools_stage_all
-}
index 8830328..46f7df7 100644 (file)
@@ -1,9 +1,11 @@
---- fakeroot-1.8.3/configure.ac.orig   2007-10-31 00:17:27.000000000 -0500
-+++ fakeroot-1.8.3/configure.ac        2007-10-31 00:18:12.000000000 -0500
-@@ -1,14 +1,12 @@
- dnl Process this file with autoconf to produce a configure script.
+Index: fakeroot-1.12.1/configure.ac
+===================================================================
+--- fakeroot-1.12.1.orig/configure.ac
++++ fakeroot-1.12.1/configure.ac
+@@ -2,14 +2,12 @@
  AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
  AC_PREREQ(2.61)
+ AC_CONFIG_MACRO_DIR([build-aux])
 -LT_PREREQ(2.1a)
  AC_CANONICAL_TARGET
  AM_INIT_AUTOMAKE
@@ -14,5 +16,5 @@
 -LT_LANG(C)
 +AC_PROG_LIBTOOL
  
- AC_ARG_WITH([ipc],
-           AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],
+ AH_BOTTOM([#if ! HAVE_BUILTIN_EXPECT
+ #define __builtin_expect(x, expected_value) (x)
index 3884aca..3c47bd7 100644 (file)
@@ -1,11 +1,8 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- fakeroot-1.2.13/scripts/fakeroot.in~fix-prefix
-+++ fakeroot-1.2.13/scripts/fakeroot.in
-@@ -15,8 +15,8 @@
+Index: fakeroot-1.12.1/scripts/fakeroot.in
+===================================================================
+--- fakeroot-1.12.1.orig/scripts/fakeroot.in
++++ fakeroot-1.12.1/scripts/fakeroot.in
+@@ -30,8 +30,8 @@
  }
  
  # strip /bin/fakeroot to find install prefix
@@ -13,6 +10,6 @@
 -BINDIR=@bindir@
 +BINDIR=`dirname $0`
 +PREFIX=`dirname ${BINDIR}`
-     
- LIB=lib@fakeroot_transformed@.so.0
- PATHS=@libdir@:${PREFIX}/lib64/libfakeroot:${PREFIX}/lib32/libfakeroot
+ USEABSLIBPATH=@LDPRELOADABS@
+ LIB=lib@fakeroot_transformed@@DLSUFFIX@
diff --git a/packages/fakeroot/files/work-with-older-libtool.patch b/packages/fakeroot/files/work-with-older-libtool.patch
deleted file mode 100644 (file)
index 05f9be8..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- fakeroot-1.7.1/configure.ac.orig   2007-08-09 16:03:34.000000000 -0500
-+++ fakeroot-1.7.1/configure.ac        2007-08-09 18:26:11.000000000 -0500
-@@ -7,8 +7,6 @@
- AC_CONFIG_HEADERS([config.h])
- AC_PROG_MAKE_SET
- AM_PROG_LIBTOOL
--LT_INIT
--LT_LANG(C)
- AC_ARG_WITH([ipc],
-           AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],