udev-124: remove boc01-specific mount.sh
authorJeremy Lainé <jeremy.laine@m4x.org>
Fri, 27 Feb 2009 11:42:08 +0000 (12:42 +0100)
committerJeremy Lainé <jeremy.laine@m4x.org>
Fri, 27 Feb 2009 11:42:08 +0000 (12:42 +0100)
packages/udev/files/boc01/mount.sh [deleted file]
packages/udev/udev_124.bb

diff --git a/packages/udev/files/boc01/mount.sh b/packages/udev/files/boc01/mount.sh
deleted file mode 100644 (file)
index 07d2fd2..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh
-#
-# Called from udev
-# Attemp to mount any added block devices 
-# and remove any removed devices
-#
-
-MOUNT="/bin/mount"
-PMOUNT="/usr/bin/pmount"
-UMOUNT="/bin/umount"
-name="`basename "$DEVNAME"`"
-
-for line in `cat /etc/udev/mount.blacklist | grep -v ^#`
-do
-       if ( echo "$DEVNAME" | grep -q "$line" )
-       then
-               logger "udev/mount.sh" "[$DEVNAME] is blacklisted, ignoring"
-               exit 0
-       fi
-done
-
-automount() {  
-       ! test -d "/media/$name" && mkdir -p "/media/$name"
-       
-       if ! $MOUNT -t auto -o ro $DEVNAME "/media/$name"
-       then
-               #logger "mount.sh/automount" "$MOUNT -t auto $DEVNAME \"/media/$name\" failed!"
-               rm_dir "/media/$name"
-       else
-               logger "mount.sh/automount" "Auto-mount of [/media/$name] successful"
-               touch "/tmp/.automount-$name"
-               boc-script scripts:photos.js "/media/$name"
-       fi
-}
-       
-rm_dir() {
-       # We do not want to rm -r populated directories
-       if test "`find "$1" | wc -l | tr -d " "`" -lt 2 -a -d "$1"
-       then
-               ! test -z "$1" && rm -r "$1"
-       else
-               logger "mount.sh/automount" "Not removing non-empty directory [$1]"
-       fi
-}
-
-if [ "$ACTION" = "add" ] && [ -n "$DEVNAME" ]; then
-       if [ -x "$PMOUNT" ]; then
-               $PMOUNT $DEVNAME 2> /dev/null
-       elif [ -x $MOUNT ]; then
-               $MOUNT $DEVNAME 2> /dev/null
-       fi
-       
-       # If the device isn't mounted at this point, it isn't configured in fstab
-       # 20061107: Small correction: The rootfs partition may be called just "rootfs" and not by
-       #           its true device name so this would break. If the rootfs is mounted on two places
-       #           during boot, it confuses the heck out of fsck. So Im auto-adding the root-partition
-       #           to /etc/udev/mount.blacklist via postinst 
-
-       cat /proc/mounts | awk '{print $1}' | grep -q "^$DEVNAME$" || automount 
-       
-fi
-
-
-
-if [ "$ACTION" = "remove" ] && [ -x "$UMOUNT" ] && [ -n "$DEVNAME" ]; then
-       for mnt in `cat /proc/mounts | grep "$DEVNAME" | cut -f 2 -d " " `
-       do
-               $UMOUNT $mnt
-       done
-       
-       # Remove empty directories from auto-mounter
-       test -e "/tmp/.automount-$name" && rm_dir "/media/$name"
-fi
index 1cae0ce..76edb2f 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 /dev/, handles hotplug events and loads drivers at boot time. It replaces \
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES_${PN} = "hotplug"
-PR = "r13"
+PR = "r14"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
           file://noasmlinkage.patch;patch=1 \