classpath:
authorRobert Schuster <thebohemian@gmx.net>
Tue, 4 Mar 2008 16:45:50 +0000 (16:45 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Tue, 4 Mar 2008 16:45:50 +0000 (16:45 +0000)
  - added patch to fix StAX API incompatibility
  - changed classpath-minimal recipes to generate less binary packages

packages/classpath/classpath-minimal_0.96.1.bb
packages/classpath/classpath-minimal_0.97.bb
packages/classpath/classpath-native_0.96.1.bb
packages/classpath/classpath.inc
packages/classpath/classpath_0.95.bb
packages/classpath/classpath_0.96.1.bb
packages/classpath/classpath_0.97.bb
packages/classpath/files/xmlstream-fix.patch [new file with mode: 0644]

index e71884d..826c5a9 100644 (file)
@@ -1,8 +1,11 @@
 require classpath.inc
 
-PR = "r5"
+PR = "r6"
 
-SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0"
+SRC_URI += "\
+  file://gjar-prefix-patch.diff;patch=1;pnum=0 \
+  file://xmlstream-fix.patch;patch=1;pnum=0 \
+  "
 
 PROVIDES = "${PN} classpath"
 
@@ -15,3 +18,5 @@ EXTRA_OECONF += "\
                 --disable-dssi \
                 --disable-examples \
                "
+
+CPPACKAGES = "${PBN}-common ${PBN}-tools"
index 14495ce..7a44226 100644 (file)
@@ -1,6 +1,10 @@
 require classpath.inc
 
-PR = "r0"
+SRC_URI += "\
+  file://xmlstream-fix.patch;patch=1;pnum=0 \
+  "
+
+PR = "r1"
 
 PROVIDES = "${PN} classpath"
 
@@ -13,3 +17,6 @@ EXTRA_OECONF += "\
                 --disable-dssi \
                 --disable-examples \
                "
+
+CPPACKAGES = "${PBN}-common ${PBN}-tools"
+
index e7d1d07..b9c3b3a 100644 (file)
@@ -1,6 +1,9 @@
 require classpath-native.inc
 
-PR = "r1"
+PR = "r2"
 
-SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0"
+SRC_URI += "\
+  file://gjar-prefix-patch.diff;patch=1;pnum=0 \
+  file://xmlstream-fix.patch;patch=1;pnum=0 \
+  "
 
index e5f5170..cfb9f1c 100644 (file)
@@ -44,9 +44,14 @@ do_install() {
        mv ${D}${libdir}/security ${D}${libdir}/${PBN}
 }
 
-PACKAGES =+ "${PBN}-common ${PN}-examples \
+# Defines the packages that this classpath recipe creates.
+# This allows the classpath-minimal variants to override this
+# again.
+CPPACKAGES = "${PBN}-common ${PN}-examples \
              ${PN}-tools ${PN}-tools-doc \
-             ${PN}-gtk ${PN}-gconf "
+             ${PN}-gtk ${PN}-gconf"
+
+PACKAGES =+ "${CPPACKAGES}"
 
 FILES_${PN}-dev += "${libdir}/${PBN}/*.la ${incdir}/${PBN}"
 
index 6b167a2..0b2090f 100644 (file)
@@ -1,8 +1,11 @@
 require classpath.inc
 
-SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0"
+SRC_URI += "\
+  file://gjar-prefix-patch.diff;patch=1;pnum=0 \
+  file://xmlstream-fix.patch;patch=1;pnum=0 \
+  "
 
-PR = "r2"
+PR = "r3"
 
 DEPENDS += "gtk+ gconf libxtst"
 
index 799b0f3..9d347a0 100644 (file)
@@ -1,8 +1,11 @@
 require classpath.inc
 
-SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0 \
-          "
-PR = "r4"
+SRC_URI += "\
+  file://gjar-prefix-patch.diff;patch=1;pnum=0 \
+  file://xmlstream-fix.patch;patch=1;pnum=0 \
+  "
+
+PR = "r5"
 
 DEPENDS += "gtk+ gconf libxtst"
 
index b8cd020..4e45dd4 100644 (file)
@@ -1,6 +1,10 @@
 require classpath.inc
 
-PR = "r0"
+SRC_URI += "\
+  file://xmlstream-fix.patch;patch=1;pnum=0 \
+  "
+
+PR = "r1"
 
 DEPENDS += "gtk+ gconf libxtst"
 
diff --git a/packages/classpath/files/xmlstream-fix.patch b/packages/classpath/files/xmlstream-fix.patch
new file mode 100644 (file)
index 0000000..30b4417
--- /dev/null
@@ -0,0 +1,93 @@
+Index: gnu/xml/stream/AttributeImpl.java
+===================================================================
+RCS file: /sources/classpath/classpath/gnu/xml/stream/AttributeImpl.java,v
+retrieving revision 1.1
+diff -u -r1.1 AttributeImpl.java
+--- gnu/xml/stream/AttributeImpl.java  4 Sep 2005 09:52:10 -0000       1.1
++++ gnu/xml/stream/AttributeImpl.java  4 Mar 2008 16:02:43 -0000
+@@ -56,11 +56,11 @@
+   protected final QName name;
+   protected final String value;
+-  protected final QName type;
++  protected final String type;
+   protected final boolean specified;
+   protected AttributeImpl(Location location,
+-                          QName name, String value, QName type,
++                          QName name, String value, String type,
+                           boolean specified)
+   {
+     super(location);
+@@ -85,7 +85,7 @@
+     return value;
+   }
+-  public QName getDTDType()
++  public String getDTDType()
+   {
+     return type;
+   }
+Index: gnu/xml/stream/XMLEventAllocatorImpl.java
+===================================================================
+RCS file: /sources/classpath/classpath/gnu/xml/stream/XMLEventAllocatorImpl.java,v
+retrieving revision 1.3
+diff -u -r1.3 XMLEventAllocatorImpl.java
+--- gnu/xml/stream/XMLEventAllocatorImpl.java  3 Mar 2006 12:30:59 -0000       1.3
++++ gnu/xml/stream/XMLEventAllocatorImpl.java  4 Mar 2008 16:02:44 -0000
+@@ -165,7 +165,7 @@
+           attributes.add(new AttributeImpl(location,
+                                            reader.getAttributeName(i),
+                                            reader.getAttributeValue(i),
+-                                           QName.valueOf(reader.getAttributeType(i)),
++                                           reader.getAttributeType(i),
+                                            reader.isAttributeSpecified(i)));
+         return new StartElementImpl(location,
+                                     reader.getName(),
+Index: gnu/xml/stream/XMLEventFactoryImpl.java
+===================================================================
+RCS file: /sources/classpath/classpath/gnu/xml/stream/XMLEventFactoryImpl.java,v
+retrieving revision 1.2
+diff -u -r1.2 XMLEventFactoryImpl.java
+--- gnu/xml/stream/XMLEventFactoryImpl.java    3 Mar 2006 12:30:59 -0000       1.2
++++ gnu/xml/stream/XMLEventFactoryImpl.java    4 Mar 2008 16:02:44 -0000
+@@ -79,20 +79,20 @@
+   {
+     return new AttributeImpl(location,
+                              new QName(namespaceURI, localName, prefix),
+-                             value, QName.valueOf("CDATA"), true);
++                             value, "CDATA", true);
+   }
+   
+   public Attribute createAttribute(String localName, String value)
+   {
+     return new AttributeImpl(location,
+                              new QName(localName),
+-                             value, QName.valueOf("CDATA"), true);
++                             value, "CDATA", true);
+   }
+   public Attribute createAttribute(QName name, String value)
+   {
+     return new AttributeImpl(location, name, value,
+-                             QName.valueOf("CDATA"), true);
++                             "CDATA", true);
+   }
+   public Namespace createNamespace(String namespaceURI)
+Index: javax/xml/stream/events/Attribute.java
+===================================================================
+RCS file: /sources/classpath/classpath/javax/xml/stream/events/Attribute.java,v
+retrieving revision 1.2
+diff -u -r1.2 Attribute.java
+--- javax/xml/stream/events/Attribute.java     4 Sep 2005 09:44:30 -0000       1.2
++++ javax/xml/stream/events/Attribute.java     4 Mar 2008 16:02:48 -0000
+@@ -59,7 +59,7 @@
+   /**
+    * Returns the type of this attribute.
+    */
+-  QName getDTDType();
++  String getDTDType();
+   /**
+    * Indicates whether this attribute was specified in the input source, or