wpa-gui: Add version 0.6.9
authorChristian Rüb <christian.rueb@gmx.net>
Fri, 15 Jan 2010 11:10:14 +0000 (11:10 +0000)
committerMartin Jansa <Martin.Jansa@gmail.com>
Fri, 15 Jan 2010 22:28:28 +0000 (23:28 +0100)
* build Qt4 version of wpa-gui
* patch to compile with Qt4 with and without session manager
* patch to use librsvg not inkscape
* include stylesheet for SHR distribution

Signed-off-by: Christian Rüb <christian.rueb@gmx.net>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/wpa-supplicant/wpa-gui-0.6.9/desktop.patch [new file with mode: 0644]
recipes/wpa-supplicant/wpa-gui-0.6.9/icons.patch [new file with mode: 0644]
recipes/wpa-supplicant/wpa-gui-0.6.9/session_manager.patch [new file with mode: 0644]
recipes/wpa-supplicant/wpa-gui-0.6.9/style [new file with mode: 0644]
recipes/wpa-supplicant/wpa-gui_0.6.9.bb [new file with mode: 0644]

diff --git a/recipes/wpa-supplicant/wpa-gui-0.6.9/desktop.patch b/recipes/wpa-supplicant/wpa-gui-0.6.9/desktop.patch
new file mode 100644 (file)
index 0000000..d83ecd9
--- /dev/null
@@ -0,0 +1,11 @@
+--- wpa_gui-qt4/wpa_gui.desktop        2009-03-23 15:06:28.000000000 +0100
++++ wpa_gui-qt4/wpa_gui.desktop        2009-11-14 18:46:09.000000000 +0100
+@@ -2,7 +2,7 @@
+ Version=1.0
+ Name=wpa_gui
+ Comment=Graphical user interface for wpa_supplicant
+-Exec=wpa_gui
++Exec=wpa_gui -stylesheet /usr/share/wpa_gui/style
+ Icon=wpa_gui
+ GenericName=wpa_supplicant user interface
+ Terminal=false
diff --git a/recipes/wpa-supplicant/wpa-gui-0.6.9/icons.patch b/recipes/wpa-supplicant/wpa-gui-0.6.9/icons.patch
new file mode 100644 (file)
index 0000000..244ec63
--- /dev/null
@@ -0,0 +1,19 @@
+diff -rup wpa_supplicant-0.6.9_orig/wpa_supplicant/wpa_gui-qt4/icons/Makefile wpa_supplicant-0.6.9/wpa_supplicant/wpa_gui-qt4/icons/Makefile
+--- wpa_gui-qt4/icons/Makefile 2009-03-23 15:06:28.000000000 +0100
++++ wpa_gui-qt4/icons/Makefile 2010-01-13 18:36:33.000000000 +0100
+@@ -10,10 +10,11 @@ all: $(ICONS)
+ %.png:
+       mkdir -p hicolor/$(@:.png=)/apps/
+-      inkscape $(SVG) --without-gui \
+-              --export-width=$(word 1,$(subst x, ,$(@:.png=)))  \
+-              --export-height=$(word 2,$(subst x, ,$(@:.png=))) \
+-              --export-png=hicolor/$(@:.png=)/apps/$(NAME).png
++      rsvg-convert $(SVG) \
++              --width=$(word 1,$(subst x, ,$(@:.png=)))  \
++              --height=$(word 2,$(subst x, ,$(@:.png=))) \
++              --format=png \
++              --output=hicolor/$(@:.png=)/apps/$(NAME).png
+ $(NAME).xpm:
+       mkdir -p pixmaps/
diff --git a/recipes/wpa-supplicant/wpa-gui-0.6.9/session_manager.patch b/recipes/wpa-supplicant/wpa-gui-0.6.9/session_manager.patch
new file mode 100644 (file)
index 0000000..23ea28c
--- /dev/null
@@ -0,0 +1,72 @@
+diff -rup wpa_supplicant-0.6.9_orig/wpa_supplicant/wpa_gui-qt4/main.cpp wpa_supplicant-0.6.9/wpa_supplicant/wpa_gui-qt4/main.cpp
+--- wpa_gui-qt4/main.cpp       2009-03-23 15:06:28.000000000 +0100
++++ wpa_gui-qt4/main.cpp       2009-11-14 17:55:47.000000000 +0100
+@@ -24,7 +24,9 @@ class WpaGuiApp : public QApplication
+ public:
+       WpaGuiApp(int &argc, char **argv);
++#ifndef QT_NO_SESSIONMANAGER
+       virtual void saveState(QSessionManager &manager);
++#endif
+       WpaGui *w;
+ };
+@@ -33,11 +35,13 @@ WpaGuiApp::WpaGuiApp(int &argc, char **a
+ {
+ }
++#ifndef QT_NO_SESSIONMANAGER
+ void WpaGuiApp::saveState(QSessionManager &manager)
+ {
+       QApplication::saveState(manager);
+       w->saveState();
+ }
++#endif
+ int main(int argc, char *argv[])
+diff -rup wpa_supplicant-0.6.9_orig/wpa_supplicant/wpa_gui-qt4/wpagui.cpp wpa_supplicant-0.6.9/wpa_supplicant/wpa_gui-qt4/wpagui.cpp
+--- wpa_gui-qt4/wpagui.cpp     2009-03-23 15:06:28.000000000 +0100
++++ wpa_gui-qt4/wpagui.cpp     2009-11-14 17:55:47.000000000 +0100
+@@ -145,6 +145,7 @@ WpaGui::WpaGui(QApplication *_app, QWidg
+       parse_argv();
++#ifndef QT_NO_SESSIONMANAGER
+       if (app->isSessionRestored()) {
+               QSettings settings("wpa_supplicant", "wpa_gui");
+               settings.beginGroup("state");
+@@ -153,6 +154,7 @@ WpaGui::WpaGui(QApplication *_app, QWidg
+                       startInTray = settings.value("in_tray").toBool();
+               settings.endGroup();
+       }
++#endif
+       if (QSystemTrayIcon::isSystemTrayAvailable())
+               createTrayIcon(startInTray);
+@@ -1689,6 +1691,7 @@ void WpaGui::addInterface()
+ }
++#ifndef QT_NO_SESSIONMANAGER
+ void WpaGui::saveState()
+ {
+       QSettings settings("wpa_supplicant", "wpa_gui");
+@@ -1697,3 +1700,4 @@ void WpaGui::saveState()
+       settings.setValue("in_tray", inTray);
+       settings.endGroup();
+ }
++#endif
+diff -rup wpa_supplicant-0.6.9_orig/wpa_supplicant/wpa_gui-qt4/wpagui.h wpa_supplicant-0.6.9/wpa_supplicant/wpa_gui-qt4/wpagui.h
+--- wpa_gui-qt4/wpagui.h       2009-03-23 15:06:28.000000000 +0100
++++ wpa_gui-qt4/wpagui.h       2009-11-14 17:55:47.000000000 +0100
+@@ -40,7 +40,9 @@ public:
+       virtual void disableNetwork(const QString &sel);
+       virtual int getNetworkDisabled(const QString &sel);
+       void setBssFromScan(const QString &bssid);
++#ifndef QT_NO_SESSIONMANAGER
+       void saveState();
++#endif
+ public slots:
+       virtual void parse_argv();
diff --git a/recipes/wpa-supplicant/wpa-gui-0.6.9/style b/recipes/wpa-supplicant/wpa-gui-0.6.9/style
new file mode 100644 (file)
index 0000000..ffd1749
--- /dev/null
@@ -0,0 +1,4 @@
+* {font-size: 16px;}
+QPushButton {
+       font-size: 20px;
+}
diff --git a/recipes/wpa-supplicant/wpa-gui_0.6.9.bb b/recipes/wpa-supplicant/wpa-gui_0.6.9.bb
new file mode 100644 (file)
index 0000000..11001b9
--- /dev/null
@@ -0,0 +1,48 @@
+DESCRIPTION = "Qt interface for choosing which configured network to connect \
+to. It also provides a method for browsing 802.11 SSID scan results, an event \
+history log of messages generated by wpa_supplicant, and a method to add or \
+edit wpa_supplicant networks."
+SECTION = "network"
+LICENSE = "GPL BSD"
+HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
+DEPENDS = "librsvg-native imagemagick-native"
+RDEPENDS = "wpa-supplicant"
+RRECOMMENDS = "${LIBC}-gconv-utf-16"
+PR = "r1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz\
+         file://icons.patch;patch=1 \
+         file://session_manager.patch;patch=1 "
+
+SRC_URI_append_shr = "file://desktop.patch;patch=1 \
+                     file://style"
+
+S = "${WORKDIR}/wpa_supplicant-${PV}/wpa_supplicant/wpa_gui-qt4"
+
+inherit qt4x11
+ARM_INSTRUCTION_SET = "arm"
+
+do_compile_append() {
+       oe_runmake -C ${S}/icons
+}
+
+do_install () {
+       install -d ${D}${bindir}
+       install -d ${D}${datadir}/wpa_gui
+       install -d ${D}${datadir}/applications
+       install -d ${D}${datadir}/pixmaps
+       install -m 644 icons/hicolor/128x128/apps/wpa_gui.png ${D}${datadir}/pixmaps
+       install -m 755 wpa_gui ${D}/${bindir}
+       install -m 644 wpa_gui.desktop ${D}/${datadir}/applications
+}
+
+do_install_append_shr() {
+       install -m 644 ${WORKDIR}/style ${D}/${datadir}/wpa_gui
+}
+
+FILES_${PN} = "/usr/share/pixmaps/wpa_gui.png \
+               /usr/share/wpa_gui/style \
+               /usr/bin/wpa_gui \
+               /usr/share/applications/wpa_gui.desktop"
+
+FILES_${PN}_append_shr = " /usr/share/wpa_gui/style"