mythplugins: added more plugins, packaging is not complete yet
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Sun, 1 Nov 2009 17:39:30 +0000 (18:39 +0100)
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Sun, 1 Nov 2009 17:39:30 +0000 (18:39 +0100)
recipes/mythtv/mythplugins_0.21+0.22rc1.bb
recipes/mythtv/mythplugins_0.21+0.22rc1/MythBackend.php.patch [new file with mode: 0644]
recipes/mythtv/mythplugins_0.21+0.22rc1/configure.patch [new file with mode: 0644]
recipes/mythtv/mythplugins_0.21+0.22rc1/mythplugins_wo_qtopengl.diff [new file with mode: 0644]
recipes/mythtv/mythplugins_0.21+0.22rc1/sysroot.patch [new file with mode: 0644]

index 62b4acc..3b7732c 100644 (file)
@@ -1,21 +1,93 @@
 inherit qmake2 qt4x11
 
-DEFAULT_PREFERENCE = "-1"
+/DEFAULT_PREFERENCE = "-1"
 
 PV = "0.21+0.22rc1"
-PR = "r0"
-DEPENDS = "flac taglib mythtv libvorbis libexif libvisual libsdl-x11 libcdaudio"
-# to add libcdparanoia
+PR = "r1"
+DEPENDS = "flac taglib mythtv libvorbis libexif libvisual libsdl-x11 libcdaudio cdparanoia"
 
 # todo: add mythweb
+# todo: fix and add mythmusic
+# todo: fix and add zoneminder
+
+PACKAGES =+ "mytharchive mytharchive-dbg \
+       mythbrowser mythbrowser-dbg \
+       mythflix mythflix-dbg \
+       mythgallery mythgallery-dbg \
+       mythgame mythgame-dbg \
+       mythmovies mythmovies-dbg \
+       mythnews mythnews-dbg \
+       mythvideo mythvideo-dbg \
+       mythweather mythweather-dbg"
+
+RDEPENDS_${PN} = "mytharchive mythbrowser mythflix mythgallery \
+       mythgame mythmovies mythnews mythvideo mythweather"
+
+FILES_mytharchive = "${libdir}/mythtv/plugins/libmytharchive.so \
+       ${bindir}/mytharchivehelper \
+       ${datadir}/mythtv/i18n/mytharchive* \
+       ${datadir}/mythtv/mytharchive/* \
+       ${datadir}/mythtv/archiveformat.xml \
+       ${datadir}/mythtv/archivemenu.xml \
+       ${datadir}/mythtv/archiveutils.xml \
+       ${datadir}/mythtv/themes/default/mytharchive-ui.xml \
+       ${datadir}/mythtv/themes/default/mythburn-ui.xml \
+       ${datadir}/mythtv/themes/default/mythnative-ui.xml \
+       ${datadir}/mythtv/themes/default/ma_*.png \
+       ${datadir}/mythtv/themes/default-wide/mytharchive-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/mythburn-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/mythnative-ui.xml \
+       "
+
+FILES_mytharchive-dbg = "${bindir}/.debug/mytharchivehelper \
+       ${libdir}/mythtv/plugins/.debug/libmytharchive.so"
+
+FILES_mythbrowser = "${libdir}/mythtv/plugins/libmythbrowser.so \
+       ${bindir}/mythbrowser \
+       ${datadir}/mythtv/i18n/mythbrowser* \
+       ${datadir}/mythtv/themes/default/webpage.png \
+       ${datadir}/mythtv/themes/default/browser-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/browser-ui.xml \
+       "
 
-PACKAGES =+ "mythmovies mythnews mythweather"
+FILES_mythbrowser-dbg = "${libdir}/mythtv/plugins/.debug/libmythbrowser.so"
+
+FILES_mythflix = "${libdir}/mythtv/plugins/libmythflix.so \
+       ${datadir}/mythtv/i18n/mythflix* \
+       ${datadir}/mythtv/mythflix/* \
+       ${datadir}/mythtv/netflix_menu.xml \
+       ${datadir}/mythtv/themes/default/mythflix_background.png \
+       ${datadir}/mythtv/themes/default/netflix-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/netflix-ui.xml \
+       ${datadir}/mythtv/themes/default/title_netflix.png \
+       ${datadir}/mythtv/themes/default-wide/title_netflix-bg.png \
+       ${datadir}/mythtv/themes/default-wide/netflix-bg.png \
+       "
+
+FILES_mythflix-dbg = "${libdir}/mythtv/plugins/.debug/libmythflix.so"
+
+FILES_mythgallery = "${libdir}/mythtv/plugins/libmythgallery.so \
+       ${datadir}/mythtv/i18n/mythgallery* \
+       ${datadir}/mythtv/themes/default/gallery*.png \
+       ${datadir}/mythtv/themes/default/gallery-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/gallery-ui.xml \
+       "
 
-RDEPENDS_${PN} = "mythmovies mythnews mythweather"
+FILES_mythgallery-dbg = "${libdir}/mythtv/plugins/.debug/libmythgallery.so"
+
+FILES_mythgame = "${libdir}/mythtv/plugins/libmythgame.so \
+       ${datadir}/mythtv/i18n/mythgame* \
+       ${datadir}/mythtv/game_settings.xml \
+       ${datadir}/mythtv/themes/default/game-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/game-ui.xml \
+       "
+
+FILES_mythgame-dbg = "${libdir}/mythtv/plugins/.debug/libmythgame.so"
 
 FILES_mythmovies = "${libdir}/mythtv/plugins/libmythmovies.so \
        ${bindir}/ignyte \
-       ${datadir}/mythtv/mythmovies/ \
+       ${datadir}/mythtv/mythmovies/* \
+       ${datadir}/mythtv/i18n/mythmovies* \
        ${datadir}/mythtv/themes/default/movies-ui.xml \
        ${datadir}/mythtv/themes/default-wide/movies-ui.xml \
        "
@@ -25,18 +97,55 @@ FILES_mythmovies-dbg = "${bindir}/.debug/ignyte \
 
 
 FILES_mythnews = "${libdir}/mythtv/plugins/libmythnews.so \
-       ${datadir}/mythtv/mythnews/ \
+       ${datadir}/mythtv/mythnews/* \
+       ${datadir}/mythtv/i18n/mythnews* \
        ${datadir}/mythtv/themes/default/enclosures.png \
-       ${datadir}/mythtv/themes/default/needs-download.png \
+       ${datadir}/mythtv/themes/default/need-download.png \
+       ${datadir}/mythtv/themes/default/podcast.png \
        ${datadir}/mythtv/themes/default/news-info-bg.png \
        ${datadir}/mythtv/themes/default/news-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/news-ui.xml \
        "
 
 FILES_mythnews-dbg = "${libdir}/mythtv/plugins/.debug/libmythnews.so"
 
+FILES_mythvideo = "${libdir}/mythtv/plugins/libmythvideo.so \
+       ${bindir}/mtd \
+       ${datadir}/mythtv/mythvideo/* \
+       ${datadir}/mythtv/i18n/mythvideo* \
+       $(datadir)/mythtv/themes/default/mv_level_none.png \
+       $(datadir)/mythtv/themes/default/mv_level_high.png \
+       $(datadir)/mythtv/themes/default/mv_results_popup.png \
+       $(datadir)/mythtv/themes/default-wide/mv_results_popup.png \
+       $(datadir)/mythtv/themes/default/mv_level_low.png \
+       $(datadir)/mythtv/themes/default/mv_level_medium.png \
+       $(datadir)/mythtv/themes/default/mv_browse_selector.png \
+       $(datadir)/mythtv/themes/default-wide/mv_browse_selector.png \
+       $(datadir)/mythtv/themes/default-wide/mv_browse_background.png \
+       $(datadir)/mythtv/themes/default-wide/mv_browse_nocover_large.png \
+       $(datadir)/mythtv/themes/default-wide/mv_itemdetail_popup.png \
+       ${datadir}/mythtv/themes/default-wide/movies-ui.xml \
+       ${datadir}/mythtv/themes/default/dvd-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/dvd-ui.xml \
+       ${datadir}/mythtv/themes/default/video-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/video-ui.xml \
+       ${datadir}/mythtv/themes/default-wide/mv-background.png \
+       ${datadir}/mythtv/themes/default-wide/mv-mselect.png \
+       ${datadir}/mythtv/themes/default-wide/mv-sel.png \
+       ${datadir}/mythtv/themes/default-wide/mv-wait-background.png \
+       ${datadir}/mythtv/themes/default-wide/mv-filerequest.png \
+       ${datadir}/mythtv/themes/default-wide/mv-other_background.png \
+       ${datadir}/mythtv/themes/default-wide/mv-selected.png \
+       ${datadir}/mythtv/video_settings.xml \
+       ${datadir}/mythtv/videomenu.xml \
+       "
+
+FILES_mythvideo-dbg = "${bindir}/.debug/mtd \
+       ${libdir}/mythtv/plugins/.debug/libmythvideo.so"
+
 FILES_mythweather = "${libdir}/mythtv/plugins/libmythweather.so \
-       ${datadir}/mythtv/mythweather/ \
-       ${datadir}/mythtv/il8n/mythweather* \
+       ${datadir}/mythtv/mythweather/* \
+       ${datadir}/mythtv/i18n/mythweather* \
        ${datadir}/mythtv/themes/default-wide/mw-background.png \
        ${datadir}/mythtv/themes/default-wide/mw-lines.png \
        ${datadir}/mythtv/themes/default-wide/mw-map-sat.png \
@@ -69,19 +178,16 @@ FILES_mythweather = "${libdir}/mythtv/plugins/libmythweather.so \
        ${datadir}/mythtv/themes/default/thunshowers.png \
        ${datadir}/mythtv/themes/default/unknown.png \
        ${datadir}/mythtv/themes/default/weather-ui.xml \
-       ${datadir}/mythtv/themes/menus/weather_settings.xml \
+       ${datadir}/mythtv/weather_settings.xml \
        "
 
 FILES_mythweather-dbg = "${libdir}/mythtv/plugins/.debug/libmythweather.so"
 
 SRC_URI = "ftp://ftp.osuosl.org/pub/mythtv/mythplugins-0.22rc1.tar.bz2 \
        file://MythBackend.php.patch;patch=1 \
-       file://mythflix.pro.patch;patch=1 \
-       file://mythgallery.pro.patch;patch=1 \
-       file://mythmovies.pro.patch;patch=1 \
-       file://mythnews.pro.patch;patch=1 \
-       file://mythweather.pro.patch;patch=1 \
-       file://mythzoneminder.pro.patch;patch=1 \
+       file://sysroot.patch;patch=1 \
+       file://mythplugins_wo_qtopengl.diff;patch=1 \
+       file://configure.patch;patch=1 \
        "
 
 S = "${WORKDIR}/mythplugins-0.22rc1"
@@ -91,19 +197,16 @@ QMAKE_PROFILES = "mythplugins.pro"
 # Note: a lot of functionality is disabled because it depends on QtOpenGL
 # which is not in OE at the moment
 
+# zoneminder needs sql files
+# mythmusic has a problem with cdparanoia and private; from the cdparanoia buglist
+# 'private' as a reserved keyword now being enforced by GCC 4.3, causes a build failure (patched in SVN).
 EXTRA_OECONF = " \
         --cross-prefix=${TARGET_PREFIX} \
         --sysroot=${STAGING_DIR_HOST} \
         --prefix=${prefix} \
         --with-libdir-name=${STAGING_LIBDIR} \
        --disable-opengl \
-       --disable-mytharchive \
-       --disable-mythbrowser \
-       --disable-mythflix \
-       --disable-mythgallery \
-       --disable-mythgame \
        --disable-mythmusic \
-       --disable-mythvideo \
        --disable-mythzoneminder \
         \
         --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
diff --git a/recipes/mythtv/mythplugins_0.21+0.22rc1/MythBackend.php.patch b/recipes/mythtv/mythplugins_0.21+0.22rc1/MythBackend.php.patch
new file mode 100644 (file)
index 0000000..95cf86e
--- /dev/null
@@ -0,0 +1,13 @@
+Index: mythplugins-0.22rc1/mythweb/classes/MythBackend.php
+===================================================================
+--- mythplugins-0.22rc1.orig/mythweb/classes/MythBackend.php
++++ mythplugins-0.22rc1/mythweb/classes/MythBackend.php
+@@ -111,7 +111,7 @@ class MythBackend {
+     }
+     public function setTimezone() {
+-        if (!is_string($_SESSION['backend']['timezone']['value']) || $_SESSION['backend']['timezone']['last_check_time'] - time() > 60*60*24) {
++        if (!is_string($_SESSION['backend']['timezone']['value']) || time() - $_SESSION['backend']['timezone']['last_check_time'] () > 60*60*24) {
+             $response = $this->sendCommand('QUERY_TIME_ZONE');
+             $timezone = str_replace(' ', '_', $response[0]);
+             $_SESSION['backend']['timezone']['value']           = $timezone;
diff --git a/recipes/mythtv/mythplugins_0.21+0.22rc1/configure.patch b/recipes/mythtv/mythplugins_0.21+0.22rc1/configure.patch
new file mode 100644 (file)
index 0000000..18e283b
--- /dev/null
@@ -0,0 +1,22 @@
+Index: mythplugins-0.22rc1/configure
+===================================================================
+--- mythplugins-0.22rc1.orig/configure
++++ mythplugins-0.22rc1/configure
+@@ -433,7 +433,7 @@ if test "$music" != "no" ; then
+     fi
+     taglib="no"
+-    taglib_minor=`taglib-config --version | cut -d. -f2`
++    taglib_minor=`$(sysroot)taglib-config --version | cut -d. -f2`
+     if test "$taglib_minor" == "" ; then
+         echo "Can't find taglib-config. Assuming 1.5 or later."
+         taglib_minor="5"
+@@ -730,7 +730,7 @@ if test "$music" = "yes" ; then
+     fi
+     if test "$taglib" = "yes" ; then
+-        echo "INCLUDEPATH += `taglib-config --prefix`/include/taglib" >> ./mythmusic/mythmusic/config.pro
++        echo "INCLUDEPATH += ${STAGING_INCDIR}/taglib" >> ./mythmusic/mythmusic/config.pro
+     fi
+ fi
diff --git a/recipes/mythtv/mythplugins_0.21+0.22rc1/mythplugins_wo_qtopengl.diff b/recipes/mythtv/mythplugins_0.21+0.22rc1/mythplugins_wo_qtopengl.diff
new file mode 100644 (file)
index 0000000..c0eb9d3
--- /dev/null
@@ -0,0 +1,129 @@
+diff --git a/mythplugins/mytharchive/mytharchive/mytharchive.pro b/mythplugins/mytharchive/mytharchive/mytharchive.pro
+index bf7f717..d20e0f7 100644
+--- mythplugins/mytharchive/mytharchive/mytharchive.pro
++++ mythplugins/mytharchive/mytharchive/mytharchive.pro
+@@ -14,7 +14,7 @@ LIBS += -lmythavcodec-$$LIBVERSION
+ LIBS += -lmythavformat-$$LIBVERSION
+ LIBS += -lmythswscale-$$LIBVERSION
+-TEMPLATE = lib opengl
++TEMPLATE = lib
+ CONFIG += plugin thread
+ TARGET = mytharchive
+ target.path = $${LIBDIR}/mythtv/plugins
+@@ -61,6 +61,7 @@ INSTALLS +=  profilefiles burnuifiles
+ INSTALLS +=  nativeuifiles 
+ #The following line was inserted by qt3to4
+-QT += xml sql opengl 
++QT += xml sql
++using_opengl:QT += opengl
+ include ( ../../libs-targetfix.pro )
+diff --git a/mythplugins/mytharchive/mytharchivehelper/mytharchivehelper.pro b/mythplugins/mytharchive/mytharchivehelper/mytharchivehelper.pro
+index ae073c1..90e413e 100644
+--- mythplugins/mytharchive/mytharchivehelper/mytharchivehelper.pro
++++ mythplugins/mytharchive/mytharchivehelper/mytharchivehelper.pro
+@@ -9,7 +9,8 @@ INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libswscale
+ DEPENDPATH *= $${INCLUDEPATH}
+ TEMPLATE = app
+-CONFIG += thread opengl
++CONFIG += thread
++using_opengl:CONFIG += opengl
+ target.path = $${PREFIX}/bin
+@@ -27,4 +28,5 @@ LIBS += -lmythavcodec-$$LIBVERSION
+ LIBS += -lmythavformat-$$LIBVERSION
+ LIBS += -lmythswscale-$$LIBVERSION
+-QT += xml sql opengl
++QT += xml sql
++using_opengl:QT += opengl
+diff --git a/mythplugins/mythbrowser/mythbrowser/mythbrowser.pro b/mythplugins/mythbrowser/mythbrowser/mythbrowser.pro
+index 98a8a9d..f689c0c 100644
+--- mythplugins/mythbrowser/mythbrowser/mythbrowser.pro
++++ mythplugins/mythbrowser/mythbrowser/mythbrowser.pro
+@@ -2,10 +2,12 @@ include (../../mythconfig.mak )
+ include (../../settings.pro )
+ include (../../programs-libs.pro )
+-QT += network xml sql opengl webkit
++QT += network xml sql webkit
++using_opengl:QT += opengl
+ TEMPLATE = lib
+-CONFIG += thread opengl plugin warn_on
++CONFIG += thread plugin warn_on
++using_opengl:CONFIG += opengl
+ TARGET = mythbrowser
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+diff --git a/mythplugins/mythflix/mythflix/mythflix.pro b/mythplugins/mythflix/mythflix/mythflix.pro
+index 5ffa22e..4359f77 100644
+--- mythplugins/mythflix/mythflix/mythflix.pro
++++ mythplugins/mythflix/mythflix/mythflix.pro
+@@ -25,6 +25,7 @@ SOURCES += newsengine.cpp dbcheck.cpp flixutil.cpp
+ #The following line was inserted by qt3to4
+-QT += network xml sql opengl qt3support
++QT += network xml sql qt3support
++using_opengl:QT += opengl
+ include ( ../../libs-targetfix.pro )
+diff --git a/mythplugins/mythgallery/mythgallery/mythgallery.pro b/mythplugins/mythgallery/mythgallery/mythgallery.pro
+index cf8219a..4542477 100644
+--- mythplugins/mythgallery/mythgallery/mythgallery.pro
++++ mythplugins/mythgallery/mythgallery/mythgallery.pro
+@@ -37,6 +37,7 @@ opengl {
+ #The following line was inserted by qt3to4
+-QT += network opengl sql xml
++QT += network sql xml
++using_opengl:QT += opengl
+ include ( ../../libs-targetfix.pro )
+diff --git a/mythplugins/mythgame/mythgame/mythgame.pro b/mythplugins/mythgame/mythgame/mythgame.pro
+index b1f371a..39e7847 100644
+--- mythplugins/mythgame/mythgame/mythgame.pro
++++ mythplugins/mythgame/mythgame/mythgame.pro
+@@ -23,6 +23,7 @@ use_hidesyms {
+ LIBS += -lz
+ #The following line was inserted by qt3to4
+-QT += xml sql opengl qt3support 
++QT += xml sql qt3support
++using_opengl:QT += opengl
+ include ( ../../libs-targetfix.pro )
+diff --git a/mythplugins/mythmusic/mythmusic/mythmusic.pro b/mythplugins/mythmusic/mythmusic/mythmusic.pro
+index 177a5bc..1153405 100644
+--- mythplugins/mythmusic/mythmusic/mythmusic.pro
++++ mythplugins/mythmusic/mythmusic/mythmusic.pro
+@@ -3,7 +3,8 @@ include ( ../../settings.pro )
+ include ( ../../programs-libs.pro )
+ include (config.pro)
+-QT += xml sql opengl qt3support network
++QT += xml sql qt3support network
++using_opengl:QT += opengl
+ !exists( config.pro ) {
+    error(Missing config.pro: please run the configure script)
+diff --git a/mythplugins/mythvideo/mtd/mtd.pro b/mythplugins/mythvideo/mtd/mtd.pro
+index 7c3c357..d63d170 100644
+--- mythplugins/mythvideo/mtd/mtd.pro
++++ mythplugins/mythvideo/mtd/mtd.pro
+@@ -5,7 +5,8 @@ include ( ../../programs-libs.pro )
+ QT += sql xml network
+ TEMPLATE = app
+-CONFIG += thread opengl
++CONFIG += thread
++using_opengl:CONFIG += opengl
+ TARGET = mtd
+ target.path = $${PREFIX}/bin
+ INSTALLS += target
diff --git a/recipes/mythtv/mythplugins_0.21+0.22rc1/sysroot.patch b/recipes/mythtv/mythplugins_0.21+0.22rc1/sysroot.patch
new file mode 100644 (file)
index 0000000..4cf344d
--- /dev/null
@@ -0,0 +1,197 @@
+Index: mythplugins/programs-libs.pro
+===================================================================
+--- mythplugins/programs-libs.pro      (revision 22430)
++++ mythplugins/programs-libs.pro      (working copy)
+@@ -4,7 +4,7 @@
+ INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmyth
+ DEPENDPATH *= $${INCLUDEPATH}
+-LIBS += -L$${LIBDIR} $$EXTRA_LIBS -lmythdb-$$LIBVERSION
++LIBS += -L$${SYSROOT}$${LIBDIR} $$EXTRA_LIBS -lmythdb-$$LIBVERSION
+ LIBS += -lmythavutil-$$LIBVERSION -lmythavcodec-$$LIBVERSION
+ LIBS += -lmyth-$$LIBVERSION -lmythui-$$LIBVERSION -lmythupnp-$$LIBVERSION
+Index: mythplugins/configure
+===================================================================
+--- mythplugins/configure      (revision 22430)
++++ mythplugins/configure      (working copy)
+@@ -266,24 +266,25 @@
+ has_library()
+ {
+-    if test -f /etc/ld.so.conf ; then
+-        LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
+-    else
+-        LIBPATHS=''
+-    fi
++    LIBPATHS=''
++    if test "x$sysroot" = "x" ; then
++        if test -f /etc/ld.so.conf ; then
++            LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
++        fi
+-    LIBPATHS="$LIBPATHS `echo $LD_LIBRARY_PATH | sed s/':'/' '/g` "
+-    # Mac OS X has a different variable for this:
+-    LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
++        LIBPATHS="$LIBPATHS `echo $LD_LIBRARY_PATH | sed s/':'/' '/g` "
++        # Mac OS X has a different variable for this:
++        LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
+-    # recurse down just one level, should be enough in most cases
+-    if test -f /etc/ld.so.conf ; then
+-        INCL=`cat /etc/ld.so.conf | grep -v "#" | grep  "^include"`
+-        SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
+-        for x in $SRCH ; do
+-            LP_APPEND=`cat $x | grep -v "#" | grep -v "^include"`
+-            LIBPATHS="$LIBPATHS $LP_APPEND"
+-        done
++        # recurse down just one level, should be enough in most cases
++        if test -f /etc/ld.so.conf ; then
++            INCL=`cat /etc/ld.so.conf | grep -v "#" | grep  "^include"`
++            SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
++            for x in $SRCH ; do
++                LP_APPEND=`cat $x | grep -v "#" | grep -v "^include"`
++                LIBPATHS="$LIBPATHS $LP_APPEND"
++            done
++        fi
+     fi
+     LIBPATHS="`echo $LIBPATHS $sysroot$prefix/$libdir_name $sysroot/$libdir_name $sysroot/usr/$libdir_name $sysroot/usr/local/$libdir_name $sysroot/usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
+@@ -300,8 +301,10 @@
+ has_header()
+ {
+     HPATHS="$sysroot$prefix/include $sysroot/usr/local/include $sysroot/usr/include $sysroot/usr/include/g++-v3 $sysroot/usr/X11R6/include $sysroot/"
+-    INCL=`echo $DYLD_LIBRARY_PATH $LD_LIBRARY_PATH | sed s/':'/' '/g`
+-    HPATHS="$HPATHS `echo $INCL | sed s/$libdir_name/include/g` "
++    if test "x$sysroot" = "x" ; then
++        INCL=`echo $DYLD_LIBRARY_PATH $LD_LIBRARY_PATH | sed s/':'/' '/g`
++        HPATHS="$HPATHS `echo $INCL | sed s/$libdir_name/include/g` "
++    fi
+     HAS_IT="no"
+     for HPATH in $HPATHS ; do
+@@ -689,7 +692,7 @@
+         if test "$sdl" = "yes" ; then
+             echo "        libvisual      support will be included in MythMusic"
+             echo "#define LIBVISUAL_SUPPORT 1" >> ./mythmusic/mythmusic/config.h
+-            echo "INCLUDEPATH += /usr/include/libvisual-0.4" >> ./mythmusic/mythmusic/config.pro
++            echo "INCLUDEPATH += ${sysroot}/usr/include/libvisual-0.4" >> ./mythmusic/mythmusic/config.pro
+             echo "LIBS += -lvisual-0.4" >> ./mythmusic/mythmusic/config.pro
+         else
+             echo "        libvisual      support will not be included in MythMusic (requires SDL support)"
+Index: mythplugins/settings.pro
+===================================================================
+--- mythplugins/settings.pro   (revision 22430)
++++ mythplugins/settings.pro   (working copy)
+@@ -3,8 +3,8 @@
+ LIBVERSION = 0.22
+ INCLUDEPATH += $${SYSROOT}$${PREFIX}/include
+-#INCLUDEPATH += /usr/include/cdda
+-#INCLUDEPATH += /usr/include/FLAC
++#INCLUDEPATH += $${SYSROOT}/usr/include/cdda
++#INCLUDEPATH += $${SYSROOT}/usr/include/FLAC
+ LIBS *= -L$${SYSROOT}$${PREFIX}/$${LIBDIRNAME}
+Index: mythplugins/mythgallery/mythgallery/mythgallery.pro
+===================================================================
+--- mythplugins/mythgallery/mythgallery/mythgallery.pro        (revision 22430)
++++ mythplugins/mythgallery/mythgallery/mythgallery.pro        (working copy)
+@@ -14,7 +14,7 @@
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+-INCLUDEPATH += $${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
+ # Input
+ HEADERS += iconview.h          singleview.h
+Index: mythplugins/mythweather/mythweather/mythweather.pro
+===================================================================
+--- mythplugins/mythweather/mythweather/mythweather.pro        (revision 22430)
++++ mythplugins/mythweather/mythweather/mythweather.pro        (working copy)
+@@ -13,8 +13,8 @@
+ QMAKE_COPY_DIR = sh ../../cpsvndir
+ win32:QMAKE_COPY_DIR = sh ../../cpsimple
+-INCLUDEPATH += $${PREFIX}/include/mythtv
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+ datafiles.path = $${PREFIX}/share/mythtv/mythweather/
+ datafiles.files = weather-screens.xml
+Index: mythplugins/mythflix/mythflix/mythflix.pro
+===================================================================
+--- mythplugins/mythflix/mythflix/mythflix.pro (revision 22430)
++++ mythplugins/mythflix/mythflix/mythflix.pro (working copy)
+@@ -8,7 +8,7 @@
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+-INCLUDEPATH += $${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
+ installfiles.path = $${PREFIX}/share/mythtv/mythflix
+ installfiles.files = netflix-rss.xml
+Index: mythplugins/mythmovies/mythmovies/mythmovies.pro
+===================================================================
+--- mythplugins/mythmovies/mythmovies/mythmovies.pro   (revision 22430)
++++ mythplugins/mythmovies/mythmovies/mythmovies.pro   (working copy)
+@@ -10,7 +10,7 @@
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+ # Input
+ HEADERS += moviesui.h helperobjects.h moviessettings.h
+Index: mythplugins/mythzoneminder/mythzoneminder/mythzoneminder.pro
+===================================================================
+--- mythplugins/mythzoneminder/mythzoneminder/mythzoneminder.pro       (revision 22430)
++++ mythplugins/mythzoneminder/mythzoneminder/mythzoneminder.pro       (working copy)
+@@ -8,7 +8,7 @@
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+ # Input
+ HEADERS += zmconsole.h zmplayer.h zmevents.h zmliveplayer.h zmdefines.h 
+Index: mythplugins/mythnews/mythnews/mythnews.pro
+===================================================================
+--- mythplugins/mythnews/mythnews/mythnews.pro (revision 22430)
++++ mythplugins/mythnews/mythnews/mythnews.pro (working copy)
+@@ -10,9 +10,9 @@
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+-INCLUDEPATH += $${PREFIX}/include/mythtv
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythdb
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythdb
+ installfiles.path = $${PREFIX}/share/mythtv/mythnews
+ installfiles.files = news-sites.xml
+Index: mythplugins/targetdep.pro
+===================================================================
+--- mythplugins/targetdep.pro  (revision 22430)
++++ mythplugins/targetdep.pro  (working copy)
+@@ -10,10 +10,10 @@
+ MYTH_LIB_EXT  =$${LIBVERSION}.$${QMAKE_EXTENSION_LIB}
+-DEPLIBS = $${LIBDIR}
++DEPLIBS = $${SYSROOT}$${LIBDIR}
+ # On Windows, dlls were installed with exes:
+-mingw : DEPLIBS = $${PREFIX}/bin
++mingw : DEPLIBS = $${SYSROOT}$${PREFIX}/bin
+ TARGETDEPS += $${DEPLIBS}/libmyth-$${MYTH_SHLIB_EXT}
+ TARGETDEPS += $${DEPLIBS}/libmythdb-$${MYTH_SHLIB_EXT}