Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
authorBruno Randolf <br1@subnet.at>
Fri, 11 Mar 2005 20:14:11 +0000 (20:14 +0000)
committerBruno Randolf <br1@subnet.at>
Fri, 11 Mar 2005 20:14:11 +0000 (20:14 +0000)
into null.(none):/data/mtx/closed/build/unstable/openembedded

2005/03/11 19:48:55+01:00 (none)!br1
nylon updates

BKrev: 4231fc13loxiimZ6UiyKsu8zAStRWg

packages/hostap/hostap-modules_0.2.6.bb
packages/linux/linux-mtx-1-2.4.27/21-mtx-1-watchdog.diff [new file with mode: 0644]
packages/linux/linux-mtx-1_2.4.27.bb
packages/nylon/nylon-scripts_cvs.bb
packages/nylon/nylon-statistics.bb

index ca7ccd6..a72a2d1 100644 (file)
@@ -31,24 +31,6 @@ do_install() {
        install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
        install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
        cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
-
-       if [ "${MACHINE}" = "mtx-1" ]; then
-               install -d ${D}${sysconfdir}/modutils
-               echo "hostap_pci" > ${D}${sysconfdir}/modutils/hostap
-       fi
-}
-
-pkg_postinst_hostap-modules-pci() {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
-  exit 1
-fi
-update-modules || true
-}
-
-pkg_postrm_hostap-modules-pci() {
-#!/bin/sh
-update-modules || true
 }
 
 PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
diff --git a/packages/linux/linux-mtx-1-2.4.27/21-mtx-1-watchdog.diff b/packages/linux/linux-mtx-1-2.4.27/21-mtx-1-watchdog.diff
new file mode 100644 (file)
index 0000000..e69de29
index 7381b8c..a73bdf6 100644 (file)
@@ -21,18 +21,19 @@ SRC_URI = "cvs://cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4_27 \
        file://12-openswan-2.2.0-nat-t.diff;patch=1 \
        file://13-openswan-2.2.0.patch;patch=1 \
        file://14-au1000-eth-link-beat.diff;patch=1 \
-       file://15-au1000-pci-fixup-non-coherent-pre-ac.diff;patch=1 \
        file://16-i2c.patch;patch=1 \
        file://17-lmsensors.2.8.8.patch;patch=1 \
        file://18-i2c-au1x00gpio.patch;patch=1 \
        file://19-kernel-make-depend.diff;patch=1 \
        file://20-au1x00_ethernet_tx_stats.diff;patch=1 \
+       file://21-mtx-1-watchdog.diff;patch=1 \
        file://defconfig-mtx-1"
 
 S = "${WORKDIR}/linux"
 
 inherit kernel
 
+COMPATIBLE_HOST = "mipsel.*-linux"
 PACKAGE_ARCH = "mtx-1"
 ARCH = "mips"
 KERNEL_OUTPUT = "arch/mips/zboot/images/mtx-1.flash.bin"
index eb6e913..c14f1c6 100644 (file)
@@ -28,10 +28,17 @@ else
        update-rc.d -s dummydate start 50 S . stop 50 0 6 .
        
        if ! grep -q flash-backup /etc/cron/crontabs/root; then
-               echo "adding crontab"
+               echo "adding flash-backup crontab"
                test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
                echo "0 * * * *    /etc/init.d/flash-backup backup" >> /etc/cron/crontabs/root
        fi
+        
+       if ! grep -q reset-wlan /etc/cron/crontabs/root; then
+               echo "adding reset-wlan crontab"
+               test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
+               echo "0 3 * * *    /usr/sbin/reset-wlan" >> /etc/cron/crontabs/root
+       fi
+
        update-rc.d -s busybox-cron defaults
 fi
 }
index 1840f4f..90da9bf 100644 (file)
@@ -15,6 +15,7 @@ do_install() {
        install -d ${D}${sbindir}
        ln -s /var/tmp ${D}/srv/www/rrd-img
        install -m 755 ${S}/*.html ${D}/srv/www/cgi-bin
+       ln -s /var/tmp/nav.inc.html ${D}/srv/www/cgi-bin
        install -m 755 ${S}/collect.sh ${D}${sbindir}
 }
 
@@ -33,6 +34,11 @@ else
                echo "A:*" > /etc/httpd.conf
        fi      
        update-rc.d -s busybox-httpd defaults
+       
+       if ! grep -q "/var/lib/rrd/" /etc/nylon/backup.list; then
+               echo "adding to backup list"
+               echo "/var/lib/rrd/" >> /etc/nylon/backup.list
+       fi
 fi
 }