compulab-pxa270-2.6.22: fix kernel command line, add support for W module
authorCliff Brake <cbrake@bec-systems.com>
Wed, 26 Sep 2007 21:04:41 +0000 (21:04 +0000)
committerCliff Brake <cbrake@bec-systems.com>
Wed, 26 Sep 2007 21:04:41 +0000 (21:04 +0000)
conf/machine/compulab-pxa270.conf
packages/linux/compulab-pxa270-2.6.22/defconfig
packages/linux/compulab-pxa270_2.6.22.bb

index c8aad09..1b80289 100644 (file)
@@ -11,13 +11,21 @@ PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
 
 require conf/machine/include/tune-xscale.inc
 
+# console serial port.  If you have a L module
+# the below works.  If you have a W module, add
+# the following line to your local.conf:
+#   CMX270_CONSOLE_SERIAL_PORT = "ttyS0"
+
+# the following is for the cm-x270 L module
+CMX270_CONSOLE_SERIAL_PORT ?= "ttyS1"
+
 # used by sysvinit_2 package, so rebuild this
 # package if you change the SERIAL_CONSOLE setting
 # the following is the for the cm-x270 L module
 # I think the W module would use ttyS0, but has
 # not been tested.  This can be overwritten in 
 # local.conf
-SERIAL_CONSOLE ?= "38400 ttyS1"
+SERIAL_CONSOLE ?= "38400 ${CMX270_CONSOLE_SERIAL_PORT}"
 
 # used by opie-collections.inc
 ROOT_FLASH_SIZE ?= "32"
@@ -37,7 +45,7 @@ MACHINE_FEATURES = "kernel26 pcmcia usbhost usbgadget pcmcia touchscreen alsa"
 # to program the compulab NAND flash, the following scheme is suggested.  Create
 # a small rootfs that can fit in NOR flash using the following config:
 #   - Angstrom distro
-#   - uclibc
+#   - uclibc (set ANGSTROM_MODE = "uclibc" in local.conf)
 #   - angstrom-minimal-image-with-mtd-utils bitbake target
 #   - put the following in your local.conf
 #     - IMAGE_FSTYPES = "jffs2 tar cpio.gz"
index a6966d2..be9f102 100644 (file)
@@ -220,7 +220,7 @@ CONFIG_ALIGNMENT_TRAP=y
 #
 CONFIG_ZBOOT_ROM_TEXT=0x0
 CONFIG_ZBOOT_ROM_BSS=0x0
-CONFIG_CMDLINE="console=ttyS1,38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data)"
+CONFIG_CMDLINE="console=ttyS1,38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init"
 # CONFIG_XIP_KERNEL is not set
 # CONFIG_KEXEC is not set
 
index 963a8cf..080ee5f 100644 (file)
@@ -3,7 +3,7 @@ require linux.inc
 SECTION = "kernel"
 DESCRIPTION = "Linux kernel for the Compulab PXA270 system"
 LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
        file://0001-cm-x270-base2.patch;patch=1 \
@@ -30,6 +30,8 @@ S = "${WORKDIR}/linux-${PV}"
 COMPATIBLE_HOST = 'arm.*-linux'
 COMPATIBLE_MACHINE = "compulab-pxa270"
 
+CMDLINE = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init"
+
 inherit kernel
 inherit package