v4l-dvb-modules_hg.bb: fixed get_property implementation
authorghost <andreas.monzner@multimedia-labs.de>
Sun, 1 May 2011 13:26:24 +0000 (15:26 +0200)
committerghost <andreas.monzner@multimedia-labs.de>
Sun, 1 May 2011 13:26:24 +0000 (15:26 +0200)
recipes/v4l-dvb/files/fix-get-property.patch [new file with mode: 0644]
recipes/v4l-dvb/v4l-dvb-modules_hg.bb

diff --git a/recipes/v4l-dvb/files/fix-get-property.patch b/recipes/v4l-dvb/files/fix-get-property.patch
new file mode 100644 (file)
index 0000000..3529c9d
--- /dev/null
@@ -0,0 +1,31 @@
+--- v4l-dvb-org/linux/drivers/media/dvb/dvb-core/dvb_frontend.c        2010-11-05 18:00:34.000000000 +0100
++++ v4l-dvb/linux/drivers/media/dvb/dvb-core/dvb_frontend.c    2011-04-04 14:32:50.867986700 +0200
+@@ -1218,13 +1218,6 @@
+ {
+       int r = 0;
+-      /* Allow the frontend to validate incoming properties */
+-      if (fe->ops.get_property)
+-              r = fe->ops.get_property(fe, tvp);
+-
+-      if (r < 0)
+-              return r;
+-
+       switch(tvp->cmd) {
+       case DTV_FREQUENCY:
+               tvp->u.data = fe->dtv_property_cache.frequency;
+@@ -1340,6 +1333,14 @@
+               r = -1;
+       }
++      /* Allow the frontend to override outgoing properties */
++      if (!r && fe->ops.get_property) {
++              r = fe->ops.get_property(fe, tvp);
++
++              if (r < 0)
++                      return r;
++      }
++
+       dtv_property_dump(tvp);
+       return r;
index 824c04b..16382aa 100644 (file)
@@ -5,7 +5,7 @@ DEPENDS += " mercurial-native"
 SRCDATE = "20100904"
 SRCREV = "6e0befab696a"
 PV = "0.0+hg${SRCDATE}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "hg://linuxtv.org/hg/;module=v4l-dvb;rev=${SRCREV} \
            file://defconfig \
@@ -16,6 +16,7 @@ SRC_URI = "hg://linuxtv.org/hg/;module=v4l-dvb;rev=${SRCREV} \
            file://localversion.patch;patch=1 \
            file://fix-strip.patch;patch=1 \
            file://build-fix.patch;patch=1 \
+           file://fix-get-property.patch;patch=1 \
 "
 
 S = "${WORKDIR}/v4l-dvb"