gnuplot: update 4.2.2, add 4.3.0+cvs
authorJunqian Gordon Xu <xjqian@gmail.com>
Sun, 27 Jan 2008 13:37:05 +0000 (13:37 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Sun, 27 Jan 2008 13:37:05 +0000 (13:37 +0000)
* restructure patch directories
* update angstrom-preferred

16 files changed:
conf/distro/include/angstrom-2007-preferred-versions.inc
packages/gnuplot/files/debian-separate-x11-package.patch [deleted file]
packages/gnuplot/files/matrix.patch [deleted file]
packages/gnuplot/files/subdirs.patch
packages/gnuplot/files/term.patch
packages/gnuplot/gnuplot-4.0.0/.mtn2git_empty [new file with mode: 0644]
packages/gnuplot/gnuplot-4.0.0/debian-separate-x11-package.patch [new file with mode: 0644]
packages/gnuplot/gnuplot-4.0.0/matrix.patch [new file with mode: 0644]
packages/gnuplot/gnuplot-4.0.0/subdirs.patch [new file with mode: 0644]
packages/gnuplot/gnuplot-4.0.0/term.patch [new file with mode: 0644]
packages/gnuplot/gnuplot-4.2.0/.mtn2git_empty [deleted file]
packages/gnuplot/gnuplot-4.2.0/subdirs.patch [deleted file]
packages/gnuplot/gnuplot-4.2.0/term.patch [deleted file]
packages/gnuplot/gnuplot_4.2.0.bb [deleted file]
packages/gnuplot/gnuplot_4.2.2.bb [new file with mode: 0644]
packages/gnuplot/gnuplot_cvs.bb [new file with mode: 0644]

index 156b5b2..02e2399 100644 (file)
@@ -509,7 +509,7 @@ PREFERRED_VERSION_gnomesword ?= "2.1.2"
 PREFERRED_VERSION_gnuchess ?= "5.05"
 PREFERRED_VERSION_gnumeric ?= "1.6.3"
 PREFERRED_VERSION_gnupg ?= "1.4.2.2"
-PREFERRED_VERSION_gnuplot ?= "4.2.0"
+PREFERRED_VERSION_gnuplot ?= "4.2.2"
 PREFERRED_VERSION_gnuradio ?= "3.0.4"
 PREFERRED_VERSION_gnutls ?= "1.6.3"
 PREFERRED_VERSION_gob2 ?= "2.0.14"
diff --git a/packages/gnuplot/files/debian-separate-x11-package.patch b/packages/gnuplot/files/debian-separate-x11-package.patch
deleted file mode 100644 (file)
index 7afa0ee..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
---- gnuplot-4.0.0.orig/src/term.c
-+++ gnuplot-4.0.0/src/term.c
-@@ -1278,6 +1278,33 @@
-     return (t);
- }
-+#ifdef X11
-+int
-+x11driver_found()
-+{
-+  char *binname = "/gnuplot_x11";
-+  char *fullname;
-+  struct stat buf;
-+  
-+  fullname = (char*)malloc(sizeof(X11_DRIVER_DIR) + sizeof(binname) + 1);
-+  strcat(fullname, X11_DRIVER_DIR);
-+  strcat(fullname, binname);
-+
-+  /* exists? */
-+  if (stat(fullname, &buf)) {
-+    free(fullname);
-+    return 0;
-+  }
-+
-+  free(fullname);
-+  /* executable? */
-+  if (buf.st_mode && S_IXOTH)
-+    return 1;
-+
-+  return 0;
-+}
-+#endif
-+
- /*
-  * Routine to detect what terminal is being used (or do anything else
-  * that would be nice).  One anticipated (or allowed for) side effect
-@@ -1356,12 +1383,18 @@
-       env_term = getenv("TERM");      /* try $TERM */
-       if (term_name == (char *) NULL
-           && env_term != (char *) NULL && strcmp(env_term, "xterm") == 0)
--          term_name = "x11";
-+        term_name = "x11";
-       display = getenv("DISPLAY");
-       if (term_name == (char *) NULL && display != (char *) NULL)
--          term_name = "x11";
-+        term_name = "x11";
-       if (X11_Display)
--          term_name = "x11";
-+        term_name = "x11";
-+      /* if x11 was selected check for driver */
-+      if (term_name && (strcmp(term_name, "x11") == 0) && !x11driver_found() && isatty(fileno(stdin))) {
-+        printf("*** X11 output driver not found, switching to dumb terminal!\n");
-+        printf("*** If you want to use the X11 output, please install the ""gnuplot-x11"" package\n");
-+        term_name = "dumb";
-+      };      
- #endif /* x11 */
- #ifdef AMIGA
-
diff --git a/packages/gnuplot/files/matrix.patch b/packages/gnuplot/files/matrix.patch
deleted file mode 100644 (file)
index 10f56d9..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
---- gnuplot-4.0.0/src/matrix.c.old     2004-04-13 18:23:58.000000000 +0100
-+++ gnuplot-4.0.0/src/matrix.c 2005-03-01 12:38:07.068232748 +0000
-@@ -290,9 +290,12 @@
-     *d = 1.0;
-     for (ar = a, lim = &(a[n]); ar < lim; ar++) {
-       large = 0.0;
--      for (ac = *ar, limc = &(ac[n]); ac < limc;)
--          if ((temp = fabs(*ac++)) > large)
-+      for (ac = *ar, limc = &(ac[n]); ac < limc;){
-+      temp = *ac++;
-+      temp = fabs(temp);
-+          if (temp > large)
-               large = temp;
-+      }
-       if (large == 0.0)
-           int_error(NO_CARET, "Singular matrix in LU-DECOMP");
-       *dp++ = 1 / large;
index 69c7753..8c7d1f0 100644 (file)
@@ -1,16 +1,11 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- gnuplot-4.0.0/Makefile.am~nodocs
-+++ gnuplot-4.0.0/Makefile.am
+--- /tmp/Makefile.am   2007-08-23 13:10:15.560659023 +0200
++++ gnuplot-4.2.0/Makefile.am  2007-08-23 13:10:34.961764629 +0200
 @@ -1,7 +1,7 @@
  ## Process this file with automake to produce Makefile.in -*-Makefile-*-
  AUTOMAKE_OPTIONS = foreign 1.2h
  
--SUBDIRS = config m4 term src docs lisp man demo tutorial
-+SUBDIRS = config m4 term src man tutorial
+-SUBDIRS = config m4 term src docs $(LISPDIR) man demo tutorial share
++SUBDIRS = config m4 term src  $(LISPDIR) man share
  
  EXTRA_DIST = BUGS CodeStyle Copyright FAQ GNUmakefile INSTALL INSTALL.gnu \
  Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST README.exp \
index 2979b5e..41aa8e7 100644 (file)
@@ -1,14 +1,14 @@
---- gnuplot-4.0.0/src/term.h.old       2005-03-01 15:17:46.424111687 +0000
-+++ gnuplot-4.0.0/src/term.h   2005-03-01 15:18:50.961405665 +0000
-@@ -54,6 +54,7 @@
+--- gnuplot-4.2.0/src/term.h.old       2007-11-16 01:21:09.000000000 -0600
++++ gnuplot-4.2.0/src/term.h   2007-11-16 01:22:45.000000000 -0600
+@@ -70,6 +70,7 @@
   */
  #ifdef SHORT_TERMLIST
  # include "dumb.trm"          /* dumb terminal */
 +# include "qtopia.trm"         /* QTopia terminal */
- # include "post.trm"          /* postscript */
- # include "table.trm"         /* built-in, but used for the documentation */
- # if !(defined(OS2) || defined(MSDOS) || defined(_Windows) || defined(ATARI) || defined(MTOS) || defined(AMIGA))
-@@ -432,6 +433,9 @@
+ # ifdef GP_ENH_EST
+ #  include "estimate.trm"     /* used for enhanced text processing */
+@@ -436,6 +437,9 @@
  /* TeXDraw drawing package for LaTeX */
  #include "texdraw.trm"
  
diff --git a/packages/gnuplot/gnuplot-4.0.0/.mtn2git_empty b/packages/gnuplot/gnuplot-4.0.0/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gnuplot/gnuplot-4.0.0/debian-separate-x11-package.patch b/packages/gnuplot/gnuplot-4.0.0/debian-separate-x11-package.patch
new file mode 100644 (file)
index 0000000..7afa0ee
--- /dev/null
@@ -0,0 +1,59 @@
+--- gnuplot-4.0.0.orig/src/term.c
++++ gnuplot-4.0.0/src/term.c
+@@ -1278,6 +1278,33 @@
+     return (t);
+ }
++#ifdef X11
++int
++x11driver_found()
++{
++  char *binname = "/gnuplot_x11";
++  char *fullname;
++  struct stat buf;
++  
++  fullname = (char*)malloc(sizeof(X11_DRIVER_DIR) + sizeof(binname) + 1);
++  strcat(fullname, X11_DRIVER_DIR);
++  strcat(fullname, binname);
++
++  /* exists? */
++  if (stat(fullname, &buf)) {
++    free(fullname);
++    return 0;
++  }
++
++  free(fullname);
++  /* executable? */
++  if (buf.st_mode && S_IXOTH)
++    return 1;
++
++  return 0;
++}
++#endif
++
+ /*
+  * Routine to detect what terminal is being used (or do anything else
+  * that would be nice).  One anticipated (or allowed for) side effect
+@@ -1356,12 +1383,18 @@
+       env_term = getenv("TERM");      /* try $TERM */
+       if (term_name == (char *) NULL
+           && env_term != (char *) NULL && strcmp(env_term, "xterm") == 0)
+-          term_name = "x11";
++        term_name = "x11";
+       display = getenv("DISPLAY");
+       if (term_name == (char *) NULL && display != (char *) NULL)
+-          term_name = "x11";
++        term_name = "x11";
+       if (X11_Display)
+-          term_name = "x11";
++        term_name = "x11";
++      /* if x11 was selected check for driver */
++      if (term_name && (strcmp(term_name, "x11") == 0) && !x11driver_found() && isatty(fileno(stdin))) {
++        printf("*** X11 output driver not found, switching to dumb terminal!\n");
++        printf("*** If you want to use the X11 output, please install the ""gnuplot-x11"" package\n");
++        term_name = "dumb";
++      };      
+ #endif /* x11 */
+ #ifdef AMIGA
+
diff --git a/packages/gnuplot/gnuplot-4.0.0/matrix.patch b/packages/gnuplot/gnuplot-4.0.0/matrix.patch
new file mode 100644 (file)
index 0000000..10f56d9
--- /dev/null
@@ -0,0 +1,17 @@
+--- gnuplot-4.0.0/src/matrix.c.old     2004-04-13 18:23:58.000000000 +0100
++++ gnuplot-4.0.0/src/matrix.c 2005-03-01 12:38:07.068232748 +0000
+@@ -290,9 +290,12 @@
+     *d = 1.0;
+     for (ar = a, lim = &(a[n]); ar < lim; ar++) {
+       large = 0.0;
+-      for (ac = *ar, limc = &(ac[n]); ac < limc;)
+-          if ((temp = fabs(*ac++)) > large)
++      for (ac = *ar, limc = &(ac[n]); ac < limc;){
++      temp = *ac++;
++      temp = fabs(temp);
++          if (temp > large)
+               large = temp;
++      }
+       if (large == 0.0)
+           int_error(NO_CARET, "Singular matrix in LU-DECOMP");
+       *dp++ = 1 / large;
diff --git a/packages/gnuplot/gnuplot-4.0.0/subdirs.patch b/packages/gnuplot/gnuplot-4.0.0/subdirs.patch
new file mode 100644 (file)
index 0000000..69c7753
--- /dev/null
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- gnuplot-4.0.0/Makefile.am~nodocs
++++ gnuplot-4.0.0/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
+ AUTOMAKE_OPTIONS = foreign 1.2h
+-SUBDIRS = config m4 term src docs lisp man demo tutorial
++SUBDIRS = config m4 term src man tutorial
+ EXTRA_DIST = BUGS CodeStyle Copyright FAQ GNUmakefile INSTALL INSTALL.gnu \
+ Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST README.exp \
diff --git a/packages/gnuplot/gnuplot-4.0.0/term.patch b/packages/gnuplot/gnuplot-4.0.0/term.patch
new file mode 100644 (file)
index 0000000..2979b5e
--- /dev/null
@@ -0,0 +1,20 @@
+--- gnuplot-4.0.0/src/term.h.old       2005-03-01 15:17:46.424111687 +0000
++++ gnuplot-4.0.0/src/term.h   2005-03-01 15:18:50.961405665 +0000
+@@ -54,6 +54,7 @@
+  */
+ #ifdef SHORT_TERMLIST
+ # include "dumb.trm"          /* dumb terminal */
++# include "qtopia.trm"         /* QTopia terminal */
+ # include "post.trm"          /* postscript */
+ # include "table.trm"         /* built-in, but used for the documentation */
+ # if !(defined(OS2) || defined(MSDOS) || defined(_Windows) || defined(ATARI) || defined(MTOS) || defined(AMIGA))
+@@ -432,6 +433,9 @@
+ /* TeXDraw drawing package for LaTeX */
+ #include "texdraw.trm"
++/* Qtopia */
++#include "qtopia.trm"
++
+ /* METAFONT */
+ #include "metafont.trm"
diff --git a/packages/gnuplot/gnuplot-4.2.0/.mtn2git_empty b/packages/gnuplot/gnuplot-4.2.0/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/gnuplot/gnuplot-4.2.0/subdirs.patch b/packages/gnuplot/gnuplot-4.2.0/subdirs.patch
deleted file mode 100644 (file)
index 8c7d1f0..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/Makefile.am   2007-08-23 13:10:15.560659023 +0200
-+++ gnuplot-4.2.0/Makefile.am  2007-08-23 13:10:34.961764629 +0200
-@@ -1,7 +1,7 @@
- ## Process this file with automake to produce Makefile.in -*-Makefile-*-
- AUTOMAKE_OPTIONS = foreign 1.2h
--SUBDIRS = config m4 term src docs $(LISPDIR) man demo tutorial share
-+SUBDIRS = config m4 term src  $(LISPDIR) man share
- EXTRA_DIST = BUGS CodeStyle Copyright FAQ GNUmakefile INSTALL INSTALL.gnu \
- Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST README.exp \
diff --git a/packages/gnuplot/gnuplot-4.2.0/term.patch b/packages/gnuplot/gnuplot-4.2.0/term.patch
deleted file mode 100644 (file)
index 41aa8e7..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- gnuplot-4.2.0/src/term.h.old       2007-11-16 01:21:09.000000000 -0600
-+++ gnuplot-4.2.0/src/term.h   2007-11-16 01:22:45.000000000 -0600
-@@ -70,6 +70,7 @@
-  */
- #ifdef SHORT_TERMLIST
- # include "dumb.trm"          /* dumb terminal */
-+# include "qtopia.trm"         /* QTopia terminal */
- # ifdef GP_ENH_EST
- #  include "estimate.trm"     /* used for enhanced text processing */
-@@ -436,6 +437,9 @@
- /* TeXDraw drawing package for LaTeX */
- #include "texdraw.trm"
-+/* Qtopia */
-+#include "qtopia.trm"
-+
- /* METAFONT */
- #include "metafont.trm"
diff --git a/packages/gnuplot/gnuplot_4.2.0.bb b/packages/gnuplot/gnuplot_4.2.0.bb
deleted file mode 100644 (file)
index 1df0c9f..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-require gnuplot.inc
-
-PR = "r1"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz \
-           http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz \
-          file://subdirs.patch;patch=1 \
-           file://term.patch;patch=1 \
-          file://gnuplot.desktop \
-          file://gnuplot.png"
diff --git a/packages/gnuplot/gnuplot_4.2.2.bb b/packages/gnuplot/gnuplot_4.2.2.bb
new file mode 100644 (file)
index 0000000..478f6e2
--- /dev/null
@@ -0,0 +1,10 @@
+require gnuplot.inc
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz \
+           http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz \
+          file://subdirs.patch;patch=1 \
+           file://term.patch;patch=1 \
+          file://gnuplot.desktop \
+          file://gnuplot.png"
diff --git a/packages/gnuplot/gnuplot_cvs.bb b/packages/gnuplot/gnuplot_cvs.bb
new file mode 100644 (file)
index 0000000..d63d31a
--- /dev/null
@@ -0,0 +1,17 @@
+require gnuplot.inc
+
+PV = "4.3.0+cvs${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "cvs://anonymous@gnuplot.cvs.sourceforge.net/cvsroot/${PN};module=${PN} \
+           http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz \
+           file://subdirs.patch;patch=1 \
+           file://term.patch;patch=1 \
+           file://gnuplot.desktop \
+           file://gnuplot.png"
+
+S = "${WORKDIR}/${PN}"
+
+do_configure_prepend() {
+           ./prepare
+}