gcc 4.3.2, 4.3.3, 4.4.0: attempt to fix zecke-no-host-includes.patch
authorKoen Kooi <koen@openembedded.org>
Wed, 20 May 2009 10:00:17 +0000 (12:00 +0200)
committerKoen Kooi <koen@openembedded.org>
Wed, 20 May 2009 10:00:17 +0000 (12:00 +0200)
recipes/gcc/gcc-4.3.2/zecke-no-host-includes.patch
recipes/gcc/gcc-4.3.3.inc
recipes/gcc/gcc-4.3.3/zecke-no-host-includes.patch
recipes/gcc/gcc-4.4.0/zecke-no-host-includes.patch
recipes/gcc/gcc-cross_4.3.2.bb
recipes/gcc/gcc-cross_4.4.0.bb

index 6afb10d..1f3b062 100644 (file)
@@ -6,7 +6,7 @@ Index: gcc-4.0.2/gcc/c-incpath.c
    p->construct = 0;
    p->user_supplied_p = user_supplied_p;
  
-+#ifdef CROSS_COMPILE
++#ifdef CROSS_DIRECTORY_STRUCTURE
 +    /* A common error when cross compiling is including
 +    host headers. This code below will try to fail fast
 +    for cross compiling. Currently we consider /usr/include,
index 3e6c097..2947b18 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "GPLv3"
 
 DEPENDS = "mpfr gmp"
 
-INC_PR = "r3"
+INC_PR = "r4"
 
 SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
        file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
index 6afb10d..1f3b062 100644 (file)
@@ -6,7 +6,7 @@ Index: gcc-4.0.2/gcc/c-incpath.c
    p->construct = 0;
    p->user_supplied_p = user_supplied_p;
  
-+#ifdef CROSS_COMPILE
++#ifdef CROSS_DIRECTORY_STRUCTURE
 +    /* A common error when cross compiling is including
 +    host headers. This code below will try to fail fast
 +    for cross compiling. Currently we consider /usr/include,
index 4ccf35f..abf829c 100644 (file)
@@ -6,7 +6,7 @@ Index: gcc-4.4+svnr145550/gcc/incpath.c
    p->construct = 0;
    p->user_supplied_p = user_supplied_p;
  
-+#ifdef CROSS_COMPILE
++#ifdef CROSS_DIRECTORY_STRUCTURE
 +    /* A common error when cross compiling is including
 +    host headers. This code below will try to fail fast
 +    for cross compiling. Currently we consider /usr/include,
index 7116611..598da3c 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
 require gcc-${PV}.inc
 require gcc-cross4.inc
 require gcc-configure-cross.inc
index e3941b9..731a956 100644 (file)
@@ -2,7 +2,7 @@ require gcc-${PV}.inc
 require gcc-cross4.inc
 require gcc-configure-cross.inc
 require gcc-package-cross.inc
-PR = "r0"
+PR = "r1"
 
 SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "