add dreambox-libpassthrough to support DTS-HD -> DTS conversion for passthrough ...
authorghost <andreas.monzner@multimedia-labs.de>
Wed, 16 Feb 2011 17:49:19 +0000 (18:49 +0100)
committerghost <andreas.monzner@multimedia-labs.de>
Wed, 16 Feb 2011 17:49:19 +0000 (18:49 +0100)
conf/checksums.ini
recipes/dreambox/dreambox-libpassthrough.bb [new file with mode: 0644]

index 37ab355..1e246af 100644 (file)
@@ -17390,6 +17390,22 @@ sha256=074fbf840f73b1e13e0405fce261078c81c8c0a4859e30a7bba10510f9199908
 md5=5999c2d52f8c07eeef2a8808fee4f858
 sha256=5aed4edfd2023ed3ccd566fe76131d10faf43c8c3efa2e90978eed37c5503165
 
+[http://sources.dreamboxupdate.com/download/7020/libpassthrough-0.1-dm500hd.so]
+md5=8a1a8c0600358220af6afebe79d8ff0d
+sha256=208f54c24f62b5f73f6c0879b242c6a42be21d61311d206edebf543ede2c8634
+
+[http://sources.dreamboxupdate.com/download/7020/libpassthrough-0.1-dm7020hd.so]
+md5=8a1a8c0600358220af6afebe79d8ff0d
+sha256=208f54c24f62b5f73f6c0879b242c6a42be21d61311d206edebf543ede2c8634
+
+[http://sources.dreamboxupdate.com/download/7020/libpassthrough-0.1-dm8000.so]
+md5=8a1a8c0600358220af6afebe79d8ff0d
+sha256=208f54c24f62b5f73f6c0879b242c6a42be21d61311d206edebf543ede2c8634
+
+[http://sources.dreamboxupdate.com/download/7020/libpassthrough-0.1-dm800se.so]
+md5=8a1a8c0600358220af6afebe79d8ff0d
+sha256=208f54c24f62b5f73f6c0879b242c6a42be21d61311d206edebf543ede2c8634
+
 [http://www.at.tcpdump.org/release/libpcap-0.9.3.tar.gz]
 md5=0ad921c881fdd3d278046afcd352a151
 sha256=f20d19b1f32e4ee465169ff1e17a3755bfda8c697cfed11fe36cbf6959c80441
diff --git a/recipes/dreambox/dreambox-libpassthrough.bb b/recipes/dreambox/dreambox-libpassthrough.bb
new file mode 100644 (file)
index 0000000..dd8ae64
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Dreambox TS/M2TS audio passthrough helper lib"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "proprietary"
+MAINTAINER = "Andreas Monzner <andreas.monzner@multimedia-labs.de>"
+
+PV = "0.1"
+PR = "r0"
+
+SRC_URI = "http://sources.dreamboxupdate.com/download/7020/libpassthrough-${PV}-${MACHINE}.so"
+
+do_install() {
+       install -d ${D}${libdir}
+       install -m 0755 ${WORKDIR}/libpassthrough-${PV}-${MACHINE}.so ${D}${libdir}/libpassthrough.so
+}
+
+RPROVIDES += "libpassthrough"
+
+PACKAGE_ARCH := "${MACHINE_ARCH}"
+FILES_${PN} = "/"