mythtv svn: it now completes packaging for armv5te!
authorKoen Kooi <koen@openembedded.org>
Tue, 22 Jul 2008 17:59:38 +0000 (17:59 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 22 Jul 2008 17:59:38 +0000 (17:59 +0000)
packages/mythtv/mythtv_svn.bb

index 861f4df..39645af 100644 (file)
@@ -4,6 +4,7 @@ DEFAULT_PREFERENCE = "-1"
 
 PV = "0.21+svnr${SRCREV}"
 PR = "r0"
+REALPV = "0.22"
 
 SRCREV = "17891"
 SRC_URI = "svn://svn.mythtv.org/svn/trunk;module=mythtv;proto=http"
@@ -19,11 +20,12 @@ QMAKE_PROFILES = "mythtv.pro"
 mythlibs = "mythavutil mythavcodec mythavformat myth mythtv mythui mythfreemheg mythupnp mythlivemedia"
 PACKAGES =+ "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
 
+FILES_${PN}-dbg += "${libdir}/mythtv/filters/.debug"
 FILES_mythtv-backend = "${bindir}/mythbackend ${bindir}/mythcommflag ${bindir}/mythfilldatabase ${bindir}/mythtranscode"
 FILES_mythtv-frontend = "${bindir}/mythfrontend ${datadir}/mythtv/i18n/mythfrontend_* ${datadir}/mythtv/*.ttf"
 RDEPENDS_mythtv-frontend = "qt-x11-plugins-sqldrivers qt-x11-plugins-imageformats"
-FILES_mythtv-bin = "${bindir}"
-FILES_mythtv-filters = "${libdir}/mythtv/filters"
+FILES_mythtv-bin = "${bindir}/*"
+FILES_mythtv-filters = "${libdir}/mythtv/filters/*"
 FILES_mythtv-data = "${datadir}"
 RDEPENDS_${PN} = "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
 ALLOW_EMPTY_${PN} = "1"
@@ -34,7 +36,7 @@ python __anonymous () {
     import bb
 
     mythlibs = bb.data.getVar('mythlibs', d).split()
-    pv = bb.data.expand(bb.data.getVar("PV", d), d)
+    pv = bb.data.expand(bb.data.getVar("REALPV", d), d)
 
     for m in mythlibs:
         bb.data.setVar("FILES_lib%s%s" % (m, pv), "${libdir}/lib%s-%s.so.*" % (m, pv), d)
@@ -78,14 +80,15 @@ do_configure_prepend() {
                        --enable-libmp3lame \
                        --cross-compile \
             --dvb-path=${STAGING_INCDIR} \
+                       --with-bindings= \
                        ${EXTRA_OECONF}
 
        sed 's!PREFIX =.*!PREFIX = ${prefix}!;/INCLUDEPATH += $${PREFIX}\/include/d' < settings.pro > settings.pro.new
        mv settings.pro.new settings.pro
-    for pro in ${S}/libs/*pro ${S}/libs/*/*pro; do
+    for pro in ${S}/*/*pro ${S}/*/*/*pro ${S}/*/*/*/*pro ; do
                sed -i -e s:opengl::g $pro
        done
-
+       sed -i /.SUBDIR/d ${S}/bindings/*pro
 }
 
 python populate_packages_prepend () {