jamvm: Increased default max heap.
authorRobert Schuster <thebohemian@gmx.net>
Thu, 18 Dec 2008 13:40:30 +0000 (14:40 +0100)
committerRobert Schuster <thebohemian@gmx.net>
Fri, 19 Dec 2008 16:54:33 +0000 (17:54 +0100)
packages/jamvm/jamvm-native.inc
packages/jamvm/jamvm-native_1.5.1.bb

index c3e4f84..ff2dba6 100644 (file)
@@ -10,6 +10,9 @@ RPROVIDES_jamvm = ""
 # This uses 32 bit arm, so force the instruction set to arm, not thumb
 ARM_INSTRUCTION_SET = "arm"
 
+# Needed for big compilation targets like OpenJDK
+CFLAGS += "-DDEFAULT_MAX_HEAP=2048*MB"
+
 inherit native
 
 S = "${WORKDIR}/jamvm-${PV}"
index 3b42dbb..f38ae9f 100644 (file)
@@ -1,4 +1,4 @@
 require jamvm-native.inc
 
-PR = "r1"
+PR = "r2"