python-gst 0.10.10 do not require pygtk, gobject is really all it needs
authorMichael Lauer <mickey@vanille-media.de>
Fri, 13 Jun 2008 06:30:54 +0000 (06:30 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Fri, 13 Jun 2008 06:30:54 +0000 (06:30 +0000)
packages/python/python-gst/import-gobject-instead-of-pygtk.patch [new file with mode: 0644]
packages/python/python-gst_0.10.10.bb

diff --git a/packages/python/python-gst/import-gobject-instead-of-pygtk.patch b/packages/python/python-gst/import-gobject-instead-of-pygtk.patch
new file mode 100644 (file)
index 0000000..b4dafa1
--- /dev/null
@@ -0,0 +1,19 @@
+Index: gst-python-0.10.10/gst/__init__.py
+===================================================================
+--- gst-python-0.10.10.orig/gst/__init__.py
++++ gst-python-0.10.10/gst/__init__.py
+@@ -28,13 +28,8 @@ try:
+ except:
+    pass
+-import sys
++import sys, gobject
+-# we always require 2.0 of pygtk; so if pygtk is not imported anywhere
+-# yet, we import pygtk here and .require
+-if 'gobject' not in sys.modules:
+-    import pygtk
+-    pygtk.require('2.0')
+ class Value:
+    def __init__(self, type):
index 59cc6ad..ea2b100 100644 (file)
@@ -2,10 +2,13 @@ DESCRIPTION = "Python Gstreamer bindings"
 SECTION = "devel/python"
 LICENSE = "LGPL"
 DEPENDS = "gstreamer gst-plugins-base python-pygobject"
-PR = "ml1"
+PR = "ml2"
 
-SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
-           file://python-path.patch;patch=1"
+SRC_URI = "\
+  http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
+  file://python-path.patch;patch=1 \
+  file://import-gobject-instead-of-pygtk.patch;patch=1 \
+"
 S = "${WORKDIR}/gst-python-${PV}"
 
 inherit autotools distutils-base pkgconfig
@@ -30,3 +33,4 @@ FILES_${PN}-dev += "\
 "
 FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/"
 FILES_${PN}-examples = "${datadir}/gst-python/0.10/examples"
+