gcc 4.0.0: Fix fortran building, disable libmudflap/ssp, add gcc-posix-open-fix.patch...
authorTom Rini <trini@embeddedalley.com>
Thu, 30 Apr 2009 15:55:10 +0000 (08:55 -0700)
committerTom Rini <trini@embeddedalley.com>
Thu, 30 Apr 2009 16:16:40 +0000 (09:16 -0700)
recipes/gcc/gcc-4.0.0.inc
recipes/gcc/gcc-4.0.0/ldflags.patch [deleted file]
recipes/gcc/gcc-cross-initial_4.0.0.bb [new file with mode: 0644]
recipes/gcc/gcc-cross-intermediate_4.0.0.bb [new file with mode: 0644]
recipes/gcc/gcc-cross_4.0.0.bb
recipes/gcc/gcc_4.0.0.bb

index 5745ba0..fe56c34 100644 (file)
@@ -1,11 +1,13 @@
 require gcc-common.inc
 
+DEPENDS = "mpfr gmp"
+
 SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
-       file://zecke-xgcc-cpp.patch;patch=1 \
-       file://ldflags.patch;patch=1"
+       file://gcc-posix-open-fix.patch;patch=1 \
+       file://zecke-xgcc-cpp.patch;patch=1"
 SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
 
 # Language Overrides
 FORTRAN = ",f95"
 
-EXTRA_OECONF_BASE = "--disable-libssp"
+EXTRA_OECONF_BASE = "--disable-libssp --disable-libmudflap"
diff --git a/recipes/gcc/gcc-4.0.0/ldflags.patch b/recipes/gcc/gcc-4.0.0/ldflags.patch
deleted file mode 100644 (file)
index 1196bf0..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- gcc-4.0.0/Makefile.tpl.old 2005-06-10 13:05:09.000000000 +0100
-+++ gcc-4.0.0/Makefile.tpl     2005-06-10 13:05:10.000000000 +0100
-@@ -339,7 +339,7 @@
- NM = @NM@
- LD = @LD@
--LDFLAGS = 
-+LDFLAGS = @LDFLAGS@
- RANLIB = @RANLIB@
---- gcc-4.0.0/Makefile.in.old  2005-06-10 17:13:12.000000000 +0100
-+++ gcc-4.0.0/Makefile.in      2005-06-10 17:13:22.000000000 +0100
-@@ -336,7 +336,7 @@
- NM = @NM@
- LD = @LD@
--LDFLAGS = 
-+LDFLAGS = @LDFLAGS@
- RANLIB = @RANLIB@
diff --git a/recipes/gcc/gcc-cross-initial_4.0.0.bb b/recipes/gcc/gcc-cross-initial_4.0.0.bb
new file mode 100644 (file)
index 0000000..976cd96
--- /dev/null
@@ -0,0 +1,6 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-initial.inc
+
+DEPENDS += "gmp-native mpfr-native"
+
+EXTRA_OECONF += "--disable-multilib --disable-libssp --disable-libmudflap"
diff --git a/recipes/gcc/gcc-cross-intermediate_4.0.0.bb b/recipes/gcc/gcc-cross-intermediate_4.0.0.bb
new file mode 100644 (file)
index 0000000..1feb434
--- /dev/null
@@ -0,0 +1,4 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-intermediate.inc
+
+EXTRA_OECONF += "--disable-multilib --disable-libssp --disable-libmudflap"
index e192d82..e9e2e7b 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 1bbab50..5e25980 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc