linux-rp-2.6.19+git: Fix two compile failures
authorRichard Purdie <rpurdie@rpsys.net>
Sun, 17 Dec 2006 01:36:21 +0000 (01:36 +0000)
committerRichard Purdie <rpurdie@rpsys.net>
Sun, 17 Dec 2006 01:36:21 +0000 (01:36 +0000)
packages/linux/linux-rp-2.6.19+git/squashfs3.0-2.6.15.patch
packages/linux/linux-rp_2.6.19+git.bb

index 097659a..405d4ec 100644 (file)
@@ -2182,7 +2182,7 @@ Index: git/fs/squashfs/inode.c
 +static struct inode *squashfs_alloc_inode(struct super_block *sb)
 +{
 +      struct squashfs_inode_info *ei;
-+      ei = kmem_cache_alloc(squashfs_inode_cachep, SLAB_KERNEL);
++      ei = kmem_cache_alloc(squashfs_inode_cachep, GFP_KERNEL);
 +      if (!ei)
 +              return NULL;
 +      return &ei->vfs_inode;
index 5dfe715..f5af2ae 100644 (file)
@@ -1,6 +1,6 @@
 require linux-rp.inc
 
-PR = "r0"
+PR = "r1"
 
 DEFAULT_PREFERENCE = "-1"
 
@@ -29,7 +29,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;
            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
            ${RPSRC}/pm_changes-r1.patch;patch=1 \
            ${RPSRC}/usb_add_epalloc-r3.patch;patch=1 \
-           ${RPSRC}/usb_pxa27x_udc-r2.patch;patch=1 \
+           ${RPSRC}/usb_pxa27x_udc-r3.patch;patch=1 \
            ${DOSRC}/kexec-arm-r3.patch;patch=1 \
            ${RPSRC}/locomo_kbd_tweak-r1.patch;patch=1 \
            ${RPSRC}/poodle_pm-r3.patch;patch=1 \